Problem with Audio Output - Only AirPlay

My setup is the following:

  • Core Server installed on a Mac Mini, latest version of core roon server;
  • Linn Majik DSM, connected to the local network.

Everything was perfect until yesterday with my setup, and I was able to stream local flac files and MQA Tidal files to the Majik without any problem. Near the track title there was always a bright purple light.

Yesterday roon server got stucked and was unresponsive so I was forced to reinstall my Audio sources. In Settings->Audio section I see my Majik DSM. I enabled it, using default presets. The problem is that the output is AirPlay streaming. On the majik the source is recognized as AirPlay and if I check in the Signal Path, the final Output step is “AirPlay streaming” with a lower audio quality: now there is a green light.

How can I revert to the previous situation?

Thanks in advance for your support,

Hi @Lorenzo_De_Santis,

Can you post a Screenshot of your Roon Settings -> Audio Tab? It should look something like this:

You would need to enable the Majik there and select it as the active source in the Zone Picker:

– Noris

Hi @noris.

These are the requested screenshots: hope it may help to solve problem.
Audio Devices

Signal Path while streaming a flac files (hosted on a local QNAP device):

Signal Path while streaming a TIDAL MQA file:

In both situation you see a green spot. When it was working there was a bright purple light.
Furthermore, when a try to change the volume moving the slider from 0 to 100 nothing happens. The only way to change the volume is to use the Linn remote control. I think this is also a “strange” behaviour, isn’t it?

Thank you very much,

You might try:
Turn off both Core (mac mini) and Linn.
Boot up the mac mini, wait till you see it on remote.
Boot up Linn. Set device in Audio?

Hi @Lorenzo_De_Santis,

Thank you for sharing those screenshots, I do notice now why the signal path is green. This is because you are using Airplay streaming and the maximum sample rate for Airplay on your device is 44.1kHz while you were previously using RAAT Streaming before.

There should be a field in the Networked section that says “Roon Ready”, but I am not seeing it in your screenshot. Is it perhaps located lower in the list (if you scroll down)? I would also try rebooting your Linn and making sure that you have the proper Linn Subnet selected in Roon Settings -> Setup:

– Noris

Hi @noris.

Now it works, but actually I do not understand very well this issue… Probably the Linn reboot was the right move.

In any case, I rebooted the roon server and the Linn Majik. After the reboot, in Roon Settings->Audio now I see another section

You can see in my previous post that the Linn was recognized only under the Airplay section.

Now the streaming of a Tidal MQA file works correctly and I can see a bright purple spot:

Now also the volume slider works perfectly…
Very strange, but anyhow thank you very much for your support.

Hi @Lorenzo_De_Santis,

Thank you for letting me know that things are working again after a reboot! I think the Linn might have been in a bad state and rebooting it corrected the behavior. I will be marking this thread as [Solved] but do let us know feel free to reach out to us again if you have similar issues in the future!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.