Problem with Bluesound and Roon

@support I have exactly the same issues. It seems playback from Roon with Bluesound WiFi devices is very problematic.

I did the following test:I have tried to stream music from TIDAL directly with the BlueOS app and compared with the same song I picked of the same album that I have also ripped in Roon:

  1. I played a specific song from TIDAL in BlueOS and streaming was OK (I am streaming in Hi Res from Tidal)
  2. I tried to play the same song from my library in Roon and it simply wouldn’t play. I had to keep trying for several minutes to start streaming from Roon.

Conclusion: It seems that streaming from Roon has an issue with Bluesound players, whether this is streaming local files or even from Tidal. When I play Tidal directly from BlueOS directly on the player, there doesn’t seem to be any issues. I get the message in Roon “An audio file is loading slowly. This may indicate a performance or hardware problem”.

A further observation I have made with Roon and Bluesound players is that this difficulty with playing various songs happens only in the beginning, when you I play the first song. Once Roon manages to play the first song all next songs in the queue play correctly without issues, or at least very rarely. If you “disrupt” the played queue by skipping a song in the Roon interface or start a song form the beginning, I get the same issue most of the time.

1 Like

Just to add to the above: I have also a meridian device connected with Roon via Ethernet and never had these issues. It seems that the combination of Roon with WiFi or BlueSound players specifically cause the issue.

Hi @Vassilis_Papaeconomo,

Just to confirm, if you connect the BlueSound devices via Ethernet (as you have the Meridian devices) does it work okay?

Assuming your bluesound device is connected via Wi-Fi:
It is a commonly known issue that Bluesound has a Wi-Fi handling problem.
The problem lies in the fact that Bluesound has a serious issue with roaming to and from Wi-Fi access points.
So if you have multiple access points or repeaters, Bluesound will always try to switch to another access point.
Even if the signal is perfect.
As a result, Bluesound makes a random connection to an access point with a very low range.
I have had several sessions on this with Bluesound.
They also recognize the issue.
In the end I solved it myself.
What I did was create an extra SSID (so with a different name) in the same subnet.
I have linked this SSID to 1 access point (near to the Bluesound device)
Since then, the problem has disappeared and you can listen to HD without any problems via Roon and directly via Bluesound.

Of course I do not know if this also gives the solution in this situation, but at least I had the exact same problem.

1 Like

I am not sure this is the case with me. Had the same issue when I had only one or more APs in the area.

I have created a new SSID for troubleshooting purposes, I can check if the Bluesound devices change their association with the two APs I have now.

I have not checked that. I will try tomorrow and will let you know of the outcome.

I’m getting the exact same issues that you have described for both my Nad M10 a d Bluesound Node 2I. The issues started after the latest software updates. The units are also connected by wifi and I have no issues when using the Bluos software. I can listen to Tidal and local tracks without issue. I will raise a separate supporti ticket. I even have problems with to Live Radio. Roon stating the URL doesn’t exist anymore and when I click the radio link again, Roon connects to the radio station!

1 Like

Dylan, it seems that when I connect the Bluesound player to Ethernet it works indeed. I cannot be entirely sure because this problem does not happen always. What I did was tried this with a Bluesound player over WiFi and when I noticed the problem I tried to play the same song with another player via Ethernet. In the first case songs were skipped one after the other after waiting a few seconds and with the Ethernet player it started playing as it should be without skipping songs. It is very likely that the WiFi is the problem, but the signal of the WiFi players is very good.

Hi @Vassilis_Papaeconomo,

Can you please try an extended test on the same player via Ethernet and verify if that is stable?
If it is indeed the WiFi, you could leave them Ethernet connected or try switching WiFi channels, another one might have less congestion.

I am afraid using Ethernet is not an option as I do not have the cabling in place. I needed to move the player near the router and connect via patch cord to do the test, but this won’t work for what I intended the players for.

From the router interface I can see that signal strength and signal quality are very good. It does not justify the issues I am experiencing.

I have read in some posts in this forum that other users are experiencing similar issues with the last Roon release. Unfortunately I just installed the players so I have no experience with previous releases of Roon.

Hello @Vassilis_Papaeconomo,
Just wanted to post a quick note to say that I had the exact same experience as you (combination of Allo Digi + Bluesound devices). While there are some users who report hassle free operation with Bluesound devices on WiFi, others (me included) have struggled for years. Sorry to read you are one of the unfortunate users like me. If you search through the forum for ‘Bluesound problems’ you will find a detailed record over time. In my case, after trying everything, I had to accept ethernet connection as the only way to get my bluesound units working with Roon (I used TP Link powerline adapters). It is certainly not ideal, it means you need to invest in additional equipment and cables etc.

Worth noting:

  • Support (as well as the fortunate users who use Bluesound without issue) will point to your WiFi / Router as the cause of any problem.
  • Bluesound 2i units are not Roon certified and they have been out for quite a while (my hunch is they will never be certified)
  • Engaging with Bluesound support will eventually point you back to Roon support

I am not suggesting you quit but I sincerely hope you avoid the frustration I went through.


@Yiannis_Kouropalatis thank you for this information! I am getting seriously frustrated with these players and indeed there have been some responses indicating the router as a possible problem, but luckily I have a high end Cisco router and APs which are not a black box to me and can see what is happening on the router’s end. I have not seen any issues with comms so far, actually to the contrary signal strength and quality is excellent. Roon recognizes the Bluesound players as “Roon tested” and I trust (hope?) there will be a solution to this. Also read in some forum posts that these issues started happening after a recent update of Roon. If this is true it gives me some hope that this can be resolved. If not, I will be heavily disappointed from Roon…

1 Like

Hi @Vassilis_Papaeconomo,

We have managed to reproduce this behavior in the QA lab using BluOS gear via WiFi and we’re working directly with Bluesound to resolve these issues. In the meantime, we would suggest using a direct Ethernet connection instead of WiFi for your 2i devices.


This is great news, thank you @noris!
Unfortunately it is not possible for me to use ethernet. I will keep the current setup until we can come up with a solution, hopefully soon.

Happy to see that the issue is recognised. And hopefully will get resolved.

A post was merged into an existing topic: Random skipping and random stopping on Qobuz

I have an eero Pro with an ethernet connection to my Node 2i and it works perfectly with my library and Qobuz. An expensive work around but effective. The Node 2i also takes my TV to a pair of Dali Kubiks. The Node 2i was not without its issues before the work around.