Problem with clicks or skipping while music is playing?[Solved]

I am in the 14 day trial with Roon and it was working fine but has now has started skipping while playing both tidal and my ripped music from hard drive. Here is a bit of info on my system any help would be appreciated I would hate to have to not purchace because of this problem.

Roon 1.1 build 102 stable 64 bit
Sound Science Music Vault Ultra 2 windows 7 64 bit Intel I5-4590S CPU 16 gb memory Wyred 4Sound Dac2DSDSE Usb DH Labs Mirage

Hello @Brian_Borgman,

Before going deep into troubleshooting process, have you tried to restart Roon/Your DAC/ Music server?
Can you verify that while Roon is playing other software, which can use same output device, isn’t running?


Hi Vova, nothing else was running and I did restart Roon and my Music Server multiple times and also restarted my modum, but did not restart my dac. I did however click the Event Driven Mode button and it has seemed to fix the problem. I am also using Exclusive Mode. Could this have been the issue or may there be something else going on? Thx Brian

Hey @Brian_Borgman, I think you’ve nailed the issue.

WASAPI has two output modes: ‘Push’ and ‘Event-driven’ mode. Some sound cards work better with ‘Push’ others need ‘Event-driven’ mode. By default Roon uses ‘Push’ mode, in case of checking off ‘Event Driven Mode’ option Roon starts to use this mode.