Problem with Meridian endpoints

Hi, I have been experiencing a similar but more critical problem recently. Roon recognises my Meridian 818v3 and MS 200 when you power them on and then drops them after a few minutes at most (or a couple of seconds if I select them as a zone to play). They only reappear if powered off and on again with the same effect but basically cannot be used for playback directly any more.

Roon server runs on an i7 windows PC (Quiet PC i7 8700 running Windows 10 Home) with the following set up:

PC (1) => 16 ethernet gigabit TP link switch (2)=> MS 200

PC (1) => 16 ethernet gigabit TP link switch (2)=> 8 ethernet port gigabit TP link switch (3) => 8 ethernet port gigabit TP link switch (4) => 818v3

All linked up by cat 7 cable between the switches.

My router is a Netgear Orbi linked to switch (3). Up to a year ago it was set up in lieu of switch (3) but I then also had problems and having read on these forums that putting a switch between the router and the rest of my home network may solve the problem, I tried that and it has worked until now. IGMP proxying is disabled on the Orbi. (the Orbi is only linked to switch 3 and the internet). The Orbi does detect and list both the MS 200 and 818v3 in the list of attached devices and assigns them an IP address. I use a Global Cache iTach to run vMSR to control the 818v3 through my iPad which works fine. I can also access both devices through their web pages when entering their IP addresses on a browse.

Connected to switch 4 are also a Lumin U1 mini which feeds into the 818v3’s USB (for direct DSD playback) and has no issues working with Roon and into the 818v3.

A Bluesound Pulse is also linked by cat 7 to switch 4 and has no problems with Roon.

Other devices are connected wirelessly (Bluesound Pulse mini, all Chromecast, iOs or Android devices) are also recognised and play back with no issues from the main Orbi router or either of the 2 sateliites.

I did try to play around with the Orbi settings thinking that might be the problem but nothing has helped and it seems others have a problem with disappearing Meridian devices.

All switches are basic unmanaged switches.

Bitdefender used as firewall programme (replaced Kaspersky 6 months ago as it was slowing down Roon and demanding to be reauthorized far too often for my liking) but once Roon and its various applications were authorised the first time all has been fine.

Hi @Happycy,

Just to verify here, everything was working previously in this exact configuration for quite some time before experiencing this issue, correct? How long ago did this start occurring? Were there any changes around that time to your setup, or possible Windows updates?

Can you confirm that the Meridian devices you’re experiencing issues with are fully up to date?

If you play to these devices outside of Roon do you have any similar issues?

Hi, Dylan. Many thanks for your prompt response and help.

I was away end of April to early May. The problem started then and it has been going on since then.

The changes in my system between the week before I left and my return were the following:

  • there was a Roon update on my return
  • there was a software update to the Orbi firmware
  • I installed a PCMIA 10g ethernet card on my PC (the old gigabit port is still there)
  • the last switch (4) is now connected by an AudioQuest Vodka cable to the 818v3

I believe that the latest Windows update (which I think was more important than usual as it took longer to install and rebooted my computer many times) was launched after the problems started.

Everything was working fine for the last 12 months. I have of course tried switching back to a normal ethernet cable instead of the AudioQuest Vodka and connecting the PC via the gigagbit port but it doesn’t change anything (and it has connected back on my network without problem -the card is for future proofing as I have not changed the router or switching infrastructure- I did try moving the switches around but it makes no difference). In any case I tried the Vodka cable in early April on loan from my dealer and had no problems then.

As far as I am aware my Meridian devices are up to date although I do not run a Sooloos core any more on my QNAP any more since 18 months as I preferred to update QTS as I also run PLEX (and have been doing so for 2 years without problem) from my PC and as Roon is incomparably better (I have been a client from nearly day 1 and this is my first major problem and contact with support except once in the very early days ). The MS 200 is also not current any more. Obviously I cannot comment on Sooloos streaming as I am not set up for it but I have no issues with 818v3 as preamp or when the Lumin feeds it by USB be it for DSD, PCM or MQA.

The symptoms seem to be worsening as even powering Meridian devices on and off does not guarantee any more that Roon will briefly list them before they disappear…

All other devices work and play fine as I mentioned previously (whether via Roon or through their native apps). My initial reaction was to blame the ORBI because of multicasting issues with Sooloos but prior software updates have not caused issues and unless I missed them I have seen no post complaining here or the Meridian forums.

I should also add that the Lumin U1 mini joined my network in early February as the model did not exist a year ago. Up to my return in early May it cohabited perfectly well with the 818 and there was not issue when using one or the other device to stream.

Couple of thoughts, TP link switches can be a source of issues, have/can you try a different manufacturers switch?

Meridian Sooloos devices can be updated by running the Meridian Sooloos Configure program on a Windows PC available to download here

Hello Ratbert, I have also used a Netgear 8 port as switch 4 in the past and tried when problems but it has made no difference. Switches 2 have always been TP Link with no issues. Many thanks for the MConfig link. Although a long time Meridian user I can’t say I have used it in the past (but of course know of it). Seems not too complicated other than the need for a USB to serial converter: last time I had to use one was some years ago before Roon when I had a Naim Uniti that required a serial link for updates. Finding a cable that worked proved quite a challenge at the time and I am not sure I still have one around…

It does however seem odd that Meridian firmware would cause the problem.

What I haven’t tried is to run another router due to the hassle involved and also because I am restricted as regards the type of router I can use as it has to have the ability to create a separate walled network (sorry if I use the wrong terms) as my internet connection is provided by the building manager of the building where I live (and I am assigned one IP gateway) which allows me to be connected via a BT Business high speed line which is ironically otherwise very difficult to have access to in central London. Prior to the ORBI I had a Draytek router which offers the same network management facilities.

It is however a pain for a non techie like me to reset up unless absolutely necessary and the Lumin provides access to the 818 with a very good soundstage although the direct link would be nice too

1 Like

To do the update no adapters are required, just ensure all your Meridian Sooloos endpoints are in standby and connected to the network, run Sooloos config on the pc connected to the network as well and if an update is required it will be installed.

I did try Sooloos config which finds both end points. When I select either it goes to “Properties”: for the 818 to use DHCP (which is ticked). It then saves settings and tells me there is “Nothing to configure”. For the MS 200, the same with the additional choice whether to force upsampling and fix analogue volume (both unticked), saves settings and tells me “Nothing to configure”. The MS 200 tells me it runs version 1.0 and Device build 169, the 818 version 1.1 and Device Build 169. I also ran MConfig setting up an 818 with DSP 8000 speakers with speakerlink and using the adapter I found. Hasn’t helped either…

Hi @Happycy,

There is quite a bit here in the network chain where issues could be stemming from, so I’d like to simplify things a bit if possible and see if there’s any change when in that configuration.

As a test, can you try connecting both the Core machine and one of the Meridian devices to the primary Orbi router via Ethernet directly, bypassing any switches? Knowing if this configuration works or not can help us rule out many variables here and better understand where this issue is stemming from.


Hi, Dylan. The good news is that I have found what is causing the problem but can’t say I understand why. I stripped it down to the basic direct connections to the Orbi and 818 and eliminated all switches and it still didn’t work until I thought that to go back to
a closer past stateo … I also link the ethernet on the PC to the Gigabit port instead of the 10G card I had installed at the same time as things went kaput and then all now works again even with the switches and so on. The card is an ASUS XG-C100C PCI-E Network Interface Card and for reasons well beyond my comprehension it works with everything except for Roon and Meridian end products. I don’t need 10G capability right now but was something I had planned down the line and may need to rethink. If you know of a tried and tested PCI card, I would be happy to know about it. The ASUS is quite mainstream as far as I am aware of; maybe you have heard of issues with it before or a recommendation for a potential replacement?

I’m glad the Lumin works with your Meridian equipment. As for the problem with the other non-Lumin endpoint, try forcing the 10G card to run at 1G instead of auto negotiation:

Also disable Energy Efficient Ethernet.

After setting these, reboot your PC.

Hi, Peter. I tried your suggestion but it doesn’t help so I will continue to use the other Gigabit ethernet port on my core. I might try to see if using both works later when I get a decent spare ethernet cable.

Congratulations on the design of the U1 mini. It’s a great network streamer with excellent digital connections and with great versatility, which for the money, makes it stand out against the competition in the transport streamer stack space. My only concern was when connecting my power cable at first which I though might be too tight to fit under the metal plate at the back but it just fits!

1 Like

I’m glad you like our product.

One last suggestion for you to try: toggle the Flow Control setting for the 10G card.

If you wish to get another Ethernet cable to test, get a CAT6A, but that’s not likely to cure the problems you described if all other network uses with the PC is normal.

Even if all these settings do not cure the problem, I’ll not conclude it’s the 10G card being incompatible yet, as there is someone else (not a Lumin user) who has unsolvable issues with direct wired connection to Orbi.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.