Problem with new Qnap update (PROBLEM IS BACK)

Reinstalled Roon app. Worked perfectly for about 15 minutes and now cpu and memory are at 100%. Get message server is busy and it shuts down. Obviously something to do with Roon.
Any help would be greatly appreciated.

My Qnap TVS-471 did an update the other day and the system began to crash. Something was using all of the memory. Just finished with Qnap support via remote and they found that Roon was causing the problem. They removed it and everything was fine.
Using Qnap version (2018/11/14)
Would like to hear if this is a problem before I reinstall roon.
Have lifetime membership.

I have the same QNAP and it’s running the same version of code as you. I have not experienced any crashing and my memory usage says it’s at 12%. I also run my core on the QNAP. I am guessing that you do as well? Something else must be happening there. It’s not a problem here.

OK, Guess I will reinstall and see what happens

Its working. Must have just one of those tech mysteries

Excellent news!!

Worked perfectly for about 15 minutes and now memory and cpu usage is at 100%

You need to speak with @crieke about this. He is the resident QNAP expert.

Thomas any luck getting this resolved?

I have been in touch with Christopher but his brother was getting married yesterday so he is getting back to me.
I was able to get back into the NAS and stopped all apps that were running and let things settle for a few hours with no problems. Turned roon back on and within 15 minutes CPU and Ram were at 100% and system was unusable. Definitely something going on with roon.
Im sure Christopher will get me squared away.

Okay, good luck.

Thomas I am not sure if you saw that QNAP dipped another firmware update this morning. Might be worth trying to see if it solves your issue.

Thanks for the heads up John.
Im out of town and will try ut when I get back Thusday.
Sure would be nice if it turns out to be that easy.

The issue has been resolved in a TeamViewer session today.

This was quite a weird thing.
First there was an error in the stdout:

00:00:00.001 Error: Atomic File Move: /share/RoonServer/RAATServer/Logs/RAATServer_log.txt -> /share/RoonServer/RAATServer/Logs/RAATServer_log.01.txt failed on linux: EISDIR

I looked in the RAATServer’s log folder and saw just one logfile and a folder.

So apparently this folder was blocking the mechanism of moving or renaming the logfile.

RAATServer_log.txt -> RAATServer_log.01.txt
RAATServer_log.01.txt -> RAATServer_log.02.txt
RAATServer_log.02.txt -> RAATServer_log.03.txt

When I created this folder on my QNAP, I got the same error message. But the CPU was still at a normal level.

Due to the fact, that no new log file could be created, the one existing logfile grew over time to about 120 GB (!). I created a logfile with nearly the same size on my system and could replicate the high cpu usage afterwards. It seems the RAATServer process was freezing and taking a lot of usage and it seemed to trigger additional RAATServer processes, which were active simultaniously and were freezing then as well. The longer you let RoonServer run in that state, the more RAATServer processes were started.

The solution was to delete the 120 GB logfile and the folder, that was blocking the renaming task.

I have no clue, where the folder came from. It contained 2 images, which were probably from an album artwork.

(*Images were taken from my system for documentation.)


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.