Problem with NUC, hard disk directly connected via USB

Roon Core Machine

Roon Optimized Core Kit on a NUC7iBNH

Networking Gear & Setup Details

AVM Fritzbox 7590

Connected Audio Devices

Bluesound Powernode 2
Raspberry Pi with ropieee

Number of Tracks in Library

121.000

Description of Issue

The Roon-Core runs on an Intel Nuc (NUC7i7BNH) with Intel Core I7 processor. My music collection is stored on a hard drive that is directly connected to the Intel Nuc (USB). Furthermore, a USB stick is also connected to the Nuc, on which the backups are stored. Everything worked without problems for many years.

Now in the Roon software under Settings/Storage the message is displayed: >Roon Optimized Core Kit > Seagate Expansion Drive > Music This drive is not available. Check the drive or edit this folder if it’s been moved.

A similar message also comes up in the settings for backups.

Now when I want to edit this drive/folder (edit storage location) and/ or click on “Browse”, no folders are shown as selectable, only the “Add Network Share” button is available. I’m pretty sure that during the initial setup, the hard drive connected to the Nuc was available for selection without having to set up a network share. I checked the hard drive and USB stick on the Windows machine, they are fine. Restarting the Nuc did not help either. I cannot access the Seagate hard disk and the USB stick connected to the Nuc via the Windows computer.

Further, I noticed that quite a few playlists are empty. Since I have my backups on the USB stick, I could not access them. Even after connecting the USB stick directly to the router, Roon indicated that no backup could be found.

I triggered the rest button in Database & Settings in WebUI. This did not fix the problem. I also connected the USB hard drive directly to the router. Now I was able to create a network share. But this is not the solution I wanted.

Further I renamed the folder “Roonserver” in Rock to “Roonserver_old” and restarted Rock. This also had no success.

I hope you can help me
Many thanks

Are the drives formatted with the NTFS file system? Did you ever unplug them from the NUC before shutting down the NUC, or from Windows without going through the proper “safely remove hardware” procedure?

Can you plug them into a Windows machine and do they work there?

Yes the drives are formatted with the NTFS file system. I have plug them into a Windows machine and they work there.
I am not quite sure, but I think, I have unplug the Drives from the NUC before shutting down the NUC. From Windows I go through the proper “safely remove hardware” procedure.

Ok, in this case it might be caused by an unclean removal. ROCK refuses to mount such disks to prevent corruption. Try the solution here if it helps:

1 Like

Thank you very, very much.
The tip to check the hard disk on the Windows computer (chkdsk) has solved the problem. The hard disk is recognized by Roon again and all playlists contain the songs again. Now I can sleep peacefully again.

I will follow the advice and format the hard disk in ExFat.

After reading the notes, the cause of the defect is also clear to me. It is probably due to work on my home electrical system, during which the power was switched off several times.

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.