Problem with Nucleus and RoPieee

Hi @spockfish - After a recent reboot, I can no longer get to my Allo USBridge endpoint via this link:

I can get to it with the IP adress, so that’s fine, but I used to be able to get to it by hitting that link on the Getting Started page of the site.

I’ve tried rebooting, but same issue.

Any thoughts? I’m running version 414.

Have you tried rebooting your router?

Did you rename your unit by any chance?

Yes, I did. But I’ve rebooted since then, and still no luck with the link from your website. It’s not an issue since I can get to it via IP address and it hasn’t impacted Roon at all. Just wondering why the link no longer works for me. Thanks.

I have not. I can try that, but why would that be an issue?

Twice this evening, Roon has lost the Allo USBridge device. I’ve had to reboot the Allo to get Roon (or my router to which it is connected via Ethernet cable) to find it again. Something strange is going on. The Router is fine and operating fine with other parts of the system as is Roon, but the Allo is acting up. And yes, I’ve rebooted Roon, the router, and the Allo. Roon lost the device both before and after the latest reboot. Software related? Hardware? This is really the first significant problem I’ve had with the Allo. Coincidence that it’s happening since Version 414?

@spockfish - sent you some feedback info in case that will tell you anything about the issue. This feedback was after I rebooted the Allo for the third time this evening. It has twice now simply dropped off the network. Strange stuff.



I wonder if your connectivity problems might be related to the ethernet issues I was having with my USBridge. I’m no network engineer, but I was seeing 90% dropped packets on my unit, and if you’re seeing the same maybe it could be causing some issues?

If you can ssh into RoPieee, run the command:
ip -s link show eth0

It will show you dropped packets and errors on your ethernet connection to RoPieee. In any case, I’m curious if I was the only one having the dropped packets issue.

Yes, I’m aware of that thanks. Name was saved and reboot took place and it was fine…until it wasn’t. I’ve renamed it a few times and it’s never been a problem before. I don’t think this has anything to do with changing the name. Let’s wait and see what Harry has to say.

Well, you lost me at “ssh into RoPieee”, so I won’t be able to see anything. I have no idea what that even means?

Looks like you’re on a Mac? I have a PC, so I’m not sure exactly what’s possible with Mac… but the terminal program on your Mac should have an ssh client built in.

SSH stands for Secure Shell. It’s a command line program that allows you to access a terminal on another networked computer.

Open a terminal window on your Mac and type the following:
ssh root@[ip of ropieee machine]

Then enter the password (pretty sure it is “root”).
Then type:
ip -s link show eth0

Thanks for the explanation. I’m actually on my iPad. I don’t own a Mac. I have a PC, but don’t run Roon from it…strictly use my iPhone and iPad. Not a power user of any of my devices. I’ll wait to hear what Harry says, but thanks.

Roon and the Router just lost the USBridge again. Have no idea why this is suddenly happening. Roon is doing fine with the Sonos gear and the Router certainly isn’t dropping any other device on the network.

Again, all since version 414 of RoPieee.

I now will have to reboot the Allo yet again. I even tried reflashing the MicroSD card with the latest version and it still seems to be a problem.

I hope it’s a software, and not a hardware issue since the Allo is just over a month old.

@FastHound Since it seems like you’re comfortable flashing an image to the SD card, you could try flashing the DietPi image supplied by Allo, then at least you would know if there’s a problem with the hardware. The version located here (DietPi_v6.26m1_RPi-ARMv7-Stretch_AlloGUI.img) is working perfectly for me. Be sure to get the “v6.26m1” version.

I strongly prefer RoPieee to the Allo software, but this might work for a short-term fix (assuming the problem is the ethernet driver).

Hi @FastHound,

Can you send me feedback? You can find that on the ‘advanced’ tab.

@farmbacker I appreciate your support, but there is no evidence what soever that this is related to the network driver. I’m running a Usbridge fine for several months now.


@spockfish - if you scroll back a day or two in this thread, I did send you feedback. Shall I send additional feedback as well? Happy to do so, and thanks for your help.

@FastHound Sorry Kevin, missed it the first time.

Ok, the logs look ok. That’s too bad, so we need to look further.
I’m curious if the device goes ‘dead’: so the next time it happens can you

  1. look if the green led is stil flashing
  2. see if you can reach the web interface


@spockfish…Thanks, and no worries. My experience so far is that green light stays on solid, not flashing, but suddenly the router and Roon don’t see the Allo. I have to pull the power plug and restart the Allo and then the router and Roon see it again usually. I did have to reboot the Nucleus one time.

Come to think of it, I’m not sure the green light flashes at any time…just the red light flashes on startup I think? I’ll verify that next time I reboot.

And last evening all ran fine with no dropouts. Very strange.

@spockfish - it just when out again. Music just suddenly stops, Roon says its lost the audio device and it doesn’t show up on the router. So, pull the plug and and do a reboot of the Allo and after five minutes or so, it shows back up on Roon and the router and Roon picks up where it was in the song as if nothing happened. The green light never went out (except when power off).

Oops…while typing this, the Allo dropped off again. This time I was sitting next to it and the red light was flashing for a brief period right after it dropped out. Roon showed it had lost the audio zone. And just now, maybe a minute later, red light is out and Roon has it again…I push the Play button in Roon and it starts right up again.

Very strange. And now I just tried to access the Allo via the IP address and it tells me it is updating, yet the red light isn’t flashing. Very confusing. And now it says I need to reboot the Allo, so I shall. Will report back in a few minutes…hopefully with logs.

I pushed out an update, so that’s normal.

What is interesting that it came back after a minute without a reboot. That could provide some information.

@spockfish - back working again. Here’s the feedback file.


I’m stumped.