Problem with "pops" from DACs and Amps

Hi everyone.

I have issues with “pops” when switching between different bitrates or switching songs using Hifiberry DAC2HD

Also tried this

Finally also tried this
HiFiBerry Amp100 | HiFiBerry

But getting same problems across the board.

(I do also have two Hifiberry Amp2’s and they don’t have this problem for some reason…)

It’s very annoying and I’ve found multiple threads about this but no seemingly solutions? Someone suggested to use DSP Sample rate conversion but it doesn’t seem to help me.

Is anyone having a successful setup with a DAC on a Raspberry without pops? (both tried on RPi4b and RPi3B+)


I have both RPi3 and RPi4 setups, using the HiFiBerry DAC2 HD board and HiFiBerry OS, but have never experienced the symptoms you describe.
Sorry I can’t be more helpful.

That’s super interesting for me :stuck_out_tongue:

I don’t know what I am doing wrong. The issue I encounter is that there’s a small “noise” or “popping” when I start new songs.

How do you power your Raspberry?

What software do you run on it? I have both tried with Ropieee and HiFiBerryOS.

Standard RP 5v power supply and HiFiBerryOS.
Fit and forget.

Another person had this recently and it was the ethernet connection causing it.

@Ettrig I have no idea if this will help, but you might try playing with the resync delay setting in device setup. Best of luck with it.

Hey @ged_hickman1 interesting, but doesn’t seem to help me.

I just tried with the Raspberry directly powered by Standard RP 5V PSU and no ethernet wire connected (using WIFI) (I was actually a bit hopefull here, as I previously ran it powered using a PoE…)

Same result :frowning:

Have you reseated the board?

No, you mean the DAC2HD itself or the RPI?

How do you mean with “reset”?

I meant the audio hat.

Nope, how do you do that? :slight_smile:

Btw, I have played around a ton with Roon settings now.

One thing I noted. In Device Setup, the setting by default gets set to MQA Capability "Renderer only"

Afaik a Raspberry Pi with a Hifiberry DAC shouldn’t be listed as MQA compatible?

The pops definitely seems related to bitrate changes.

If I enable DSP bitrate conversion (custom setting all to 192 kHz) that doesn’t seem to help, but if I combine it with disabling MQA setting, it seems to make no pops anymore?.. interesting.

FWIW I always disable any Roon MQA settings.

who needs MQA… :slight_smile:

Btw, it seems that the pops are gone when I use
DSP bitrate conversion in Roon and disable MQA things.

I still get a “pop” when I turn on and off the Raspberry, but I assume this is perhaps to be expected if you have your amplifier turned on when turning on and off the DAC.

I realize that the procedure probably is to avoid messing with the DAC with the amplifier on (basically always turning off the amplifier before the dac, and turning it on after the dac?