Problem with QNAP and Geek Pulse X fi


I’m running Roon Server on a QNAP NAS with a Geek Pulse X fi DAC attached. Music then goes into active speakers. This set-up worked well since I set it up a couple of days ago. Just now, all of a sudden, it stopped working and Roon can’t find the DAC anymore. It can be identified by the QNAP Music app though, but playing music with that app doesn’t work either, it just stops playing after a few seconds. The DAC can play music using the optical S/PDIF Toslink input.
Of course I will ask for help at the LH and the QNAP helpdesks but propably someone here in the forum has experienced a similar problem. I already restarted the NAS without solving the problem.


Maybe plug and unplug the USB. USB can get into a state where the connection needs to be broken completely to be reset. I usually unplug everything.

Thanks Daniel, I did that already, plus exchanged the USB cables, re-starts, etc. I normally wouldn’t think it has something to do with Roon, but the funny thing is, Roon finished the playlist and only after that refused to go on and couldn’t find the DAC. Now I’m a bit in a panic mode, as the whole set-up is new and I don’t know where to begin to look. I just bought the DAC two weeks ago, the NAS I bought last month and the speakers last week. So lots of possibilities. I just hate it when stuff doesn’t work and I poke around in darkness. I hope the LH lab guys have an idea what to do. In a forum I read about a similar problem with my model and a firmware upgrade was able to fix it. Let’s hope it’s that simple (and I find someone with a Windos computer).

If you did not already do so, I’d try to restart each device (or regarding your DAC: unplug it from power and plug it back in)

Did that and I guess everything else one can do who’s not a service technician. Still no recognising. Hopefully LH Labs will read my ticket…

Strange: Now when I plug-in my Mac, it works just fine with the USB outlet. But with Roon it doesn’t… :disappointed_relieved:

Here I am again to include the Roon tech support:


My NAS is a brand new QNAP TS-453B with 16 GB of memory, working just fine. I run the Roon server and have an external SSD attached, just for you. Via USB I have attached a Geek Pulse Xfi DAC together with a Geek LPS power supply. This set-up also optimizes the USB signal, so USB goes from the NAS into the Geek LPS and a second cable then goes from that devise into the DAC. I use special audio USB cables. The Roon setup went fine. All software is on the latest version. Roon worked fine but a couple of days ago Roon refused to see my DAC. It was playing an album until the end and then just stopped playing. It wouldn’t see the DAC any more and did so before the album finished playing, which is strange.

I didn’t had the time then to systematically test everything and just tried out re-starting the DAC, the Roon server and also the NAS and changed the cables and the USB port on the NAS - without any success. I’m not sure if I checked much more, as I have a ruff time at the moment. So only yesterday I started to look at problem again and connected my PS4 to the DAC via the optical Toslink connection - and the DAC worked fine with that. I also could do that with my Macbook and today tried the USB outlet of my Mac computer and the DAC was visible and able to play music. I can’t remember having tried this a couple of days ago. Normally I am a systematically working guy and this would be the first thing to test to see if the DAC is broken, but I just don’t know if I had tested this.

Anyway: Today I figured out that the DAC works via USB with my Macbook and I installed Roon on it and tried it out with that set-up and it works. Roon recognizes the DAC and plays music. So I went back to a set-up that I hope I would be able to get rid of: My music on a headless Mac Mini. Which is what works at the moment, but shouldn’t. I’d love to bring it back to the QNAP NAS!

Thanks for help,

Hi, if you wish include support you need an @ before it like this : @support.

Hi Bernd,
I can’t say for sure what happened. But I’d test the following:

  • Will the Geek Pulse Xfi DAC recognized by your QNAP without the Geek LPS (this is a just a test to simplify the setup and exclude components from the equation)

  • Does it work after a reboot of the QNAP? (Just a guess: It could be that there was, for whatever reason, a power peak in the USB connection, so it got disabled)

Regarding your current setup: Even if you connect your DAC to your MacBook, it should be seen by RoonServer on the QNAP. Normally there is no need to move the core to a different computer (like your MacMini). But maybe I misinterpreted your last paragraph.

Thanks Carl - I forgot that and just edited the message.

1 Like

Did several reboots and changed the USB sockets but will give the rest a try: Good suggestions.

There is no physical connection between the Mac Mini and the NAS. I just tested if the DAC worked at all with the simplest test I could think of - and it did. I used the Mac Mini resp. my Macbook to rule out a defective DAC, as it could be that the NAS’ USB somehow is somewhere broken or misbehaving (as you suggested). As I wrote above it’s quite new and I don’t know much about it. As a next step I tried if Roon would recognize the DAC with a totally different set-up - my Mac Mini. And it worked and still works. But I would prefer the NAS setup-

My now steps are: crying for help at Roon and at QNAP. I already opened a ticked with LH Labs for the DAC, as I read about a problem recognizing the DAC in another environmet that was fixed by a firmware update. But they haven’t answered yet.

Hi @Bernd_Eichhorn1 ----- Thank you for the report and sorry to hear of the troubles here.

Moving forward, I would like to enable diagnostics on your account so our techs can have a closer look into what could potentially be causing this behavior when the Pulse X is mounted to the NAS via USB but before I do that may I very kindly ask you for the following:

  • With the original configuration in place (Roon Server on a QNAP NAS with a Geek Pulse X fi DAC attached) please reproduce the issue and not the time when the DAC is powered up/connected but cannot be seen by the application.

Once I have the above time frame I will go ahead and enable the mentioned diagnostics.

Additional feedback:

  • You mentioned that you can not stream to the device via the QNAP music application, is this still the case?

  • @crieke beat me to the punch on this one (:+1:) as I was going to make a similar suggestion:

    " Will the Geek Pulse Xfi DAC recognized by your QNAP without the Geek LPS (this is a just a test to simplify the setup and exclude components from the equation)"

    You responded with the following:

    “I just tested if the DAC worked at all with the simplest test I could think of - and it did.”

    • It’s a touch unclear to me but it sounds like this test was performed via one of your MAC devices or am I mistaken? If you have not tested with a shortened chain of communication between the DAC and the NAS as proposed by Chris, I would highly recommend giving this a go as this will be a good data point for our troubleshooting of this behavior.


1 Like

Hi Eric,

thanks for the fast replay!

Whatever I try, the DAC still isn’t recognized by Roon when connected to the NAS.

Yes, the DAC shows up in the list of devices and you can add music into its playlist, but after a few seconds after hitting the Play button it stops again. I just found out that the QNAP music app has the DAC on its list even if it’s not connected or powered on, so that’s nothing to work with. This app is far from being usable anyway.

Yes, my test was: Connecting the NAS to my Macbook Pro and it worked there. I then connected it to my Mac Mini and it worked there too, both using the USB connection. Just did this: same result.

Tried it, but the result unfortunatelly is the same.

Doesn’t work after rebooting NAS, DAC and/or LPS


Didn’t know that. It works! Thanks for that idea!

Aaand we’re back!! :grinning:


As I was sitting next to my QNAP NAS today I noticed a note on the little display the NAS has, saying that the system was rebooting - which was strange, as the NAS was working “correct” with housing my data and videos and receiving back-up’s from my computer, etc (the display really is tiny). So it obviously was stuck somewhere and propably never had rebooted since the problem with the DAC appeared although it alway said it was rebooting when I triggered it. So I again rebooted the NAS fromout it’s web interface which it said it was doing, but the NAS’s display wasn’t changing nor were the control lights. As a Mac user I then pushed the power button forcing the NAS to a fast shut down (I propably should have done this different…). Anyway, after turning it on again I did a normal shut down, unplugged it from the power source and waited for about ten minutes before I fired it up again. The DAC appeared like it should now works like it did before and should. I still don’t know what happened, but sent a protocol dump to QNAP to see if they find something out.

So, for the moment: Music is rolling and I’m happy again!

Thanks everyone for reading and helping!


I am happy you could resolve this on your own.
I assume one process was stuck, (which maybe also prevented your QNAP also from rebooting).
Even better you noticed it! :+1:

Still some open questions, which I hope QNAP can answer with the protocols I sent them. Unfortunatelly I can’t say anything positive about the LH Labs help desk, as they never answered the ticket I opened although I kept it up to date and alive. I can’t get rid of the feeling that a newer firmware (if available) would do the DAC a favour.

It seems tha NAS’s RAM was broken. Over all the time the mild idea in my head grew, it might be the RAM and the other day I exchanged it with same and newer modules. The NAS now reboots correctly and this might also have caused the inability to read what’s behind a USB socket.

1 Like