Problem with Roon and Nucleus + tracks loading slowly

Hey @thomas_clark1,

Thanks for the updated info! When you did the database refresh, did you by chance test out how Roon was running prior to loading up your local library? That was the primary goal I was hoping to hear back on, my apologies for not being more specific!

I was able to review diagnostics on your Nucleus, and I did see a handful of critical errors surrounding the identification of certain tracks in your library. However, I’m not convinced this is directly related to your overall slowness. With that, I also see repeating connection errors like below:

03/15 17:04:51 Debug: [roon/cifs] returned 32: mount error(101): Network is unreachable

Would you be able to provide a bit more information around your network setup? Are you able to test hardwiring your core directly to your router, bypassing any network gear/switches?


I’m not sure I understand your 1st question.
I re-did my database as you requested.
ROON then Scanned my files for about 2 days.
When it had finished I then started using it but found no improvement in speed. Should I have Done something else?
If so please advise

My Network setup

-comcast modem

-,EERO router connect to it via Ethernet cable

-switch to EERO via Ethernet cable

-nucleus + to switch via Ethernet

-silent angel streamer Connect to EERO by Ethernet.

-QNAP nas connected to EERO node via Ethernet

It may have nothing to do with it but recently I switched my library of FLAC files from an external drive connected to the nucleus because it was having these issues and it was constantly displaying track loading errors
I suspected the external drive was causing issues
I don’t get track loading issues anymore just slowness.

I can try to remove switches etc this weekend

Judy out of curiosity should there be any delay for these functions or should it be instantaneous?

Thanks again


In the scenario when I had External HD Connected to nucleus I had the nucleus wired directly into Comcast modem and still had issues which I thought was due to the external drive not being able to keep up

Last bit of nothing

I’ve never really had a smooth Roon experience
Something always seems not right
Hoping to spend the time and effort this time figuring it out.

Yesterday I tried the “play from here” function expecting it to hang up as it went into the next sing but it was smooth and there was no pause

Seems to be when shuffling or looking at artist or track sections
Anyway I’ll await your reply
Thanks again

This is Bizarre but now when shuffling the next track is chosen and begins immediately.
The only thing that is different is that I just updated to latest version of ROON.
I really hope it stays like this
I had sort of forgotten Room was like this
It’s really great
I will be doing a good amount of listening over the weekend to see if the problem returns
Thank you

Too bad
Problem is back
Very weird

I thought id try to see how using the APP in my Silent Angel M1T and see how music fares with that.
Ill admit it was a much smaller database than my ROON library but when shuffling with just over 400 tracks it worked great. No hang up issues etc.

I guess i should try using ROPN with a smaller database?

Im not sure what this proves other than maybe ROON isn’t for me?

I recall over the past year that someone with ROON said my database presented ROON a “unique challenge” my 143,000 tracks only come from 8 different artists and are FLAC files with different sample rates etc and are 90% bootlegs from the net.

Im not sure of the value of bringing this up but perhaps it goes to that my library is beyond ROONS capability?

trying to just display tracks…now over a minute of this…

after about 90 seconds the screen is blank with a message “album not found”

Hey @thomas_clark1,

When refreshing a database, we ideally like to test things out before adding the full library back, or before restoring from a backup. In your situation, it may be tedious to do if you don’t use Tidal or Qobuz to stream content, and only use local files. In this situation, it would be ideal to refresh the database, and then only add a small portion of your local files back into your library and test performance.

Can you test out hardwiring your Nucleus directly to your Router?

Is this still the case? You’re able to play music without issues, but navigating around Roon is slower than expected? If you disable this external drive, do you still experience slowness?

If you pull up the webUI of your Nucleus, how much space is left under both your Roon Database, as well as your Interal Music Storage? Here is more info on how to access the webUI of your Nucleus:

Thanks Ben-
I’ll do my best to answer

  1. Ill try to create a smaller database and test it this week. When My database was loading after creating a new one navigating the controller was very fast at the beginning. I did not try playing any music

  2. I have used my nucleus without my EERO router (plugged into Comcast modem/Router) and I was still having these problems that I am having now. Also with Nucleus plugged into EERO or COMCAST router it will work great for 3 songs and then the issues start again …30 mins later its fine again. Its just random. Because it does work fine from time to time I don’t think its the router etc. If it was a problem with the Router it seems unlikely it would work sometimes (or am I wrong on that?)

-when track selected it can take minutes to begin playing—other times its fine–and then not again in the same hour time frame.

-when trying to have tracks displayed it can take minutes–sometimes screen just comes up blank-the same thing happens when trying to display artists etc…or really any other navigation in the ROON controller. All of this is still happening to the degree that its almost unusable (I’ve begun to just use the APP and OS that came with my streamer>which works flawlessly)

I am at work now but will get you the information you have requested when I get home: (your last question)

to sum it all up:

-I’ve been having these issues for at least a year Off and on.

-The controller is slow or not functional in every aspect of navigating functions

-no matter what network I use ( I have 2 ) these issues are present. They happen with EERO router and the COMCAST modem/Router

-months ago in an attempt to fix these issues I moved my library from my NAS to an external drive with hopes that taking my library off the network it would make things smoother. It sort of did for awhile but then ROON starting having “track loading” issue. Given this I thought the drive was having trouble keeping up so I moved the library back to the NAS. I now no longer am using an external drive to my nucleus because of the track loading issue

-this past summer in an effort to address these issues I was advised by ROON support (due to the nature of my library i was told) to add memory to my NUCLEUS. I did this but obviously It didn’t fix the issues.

Bottom line is ROON doesn’t really function for me beyond playing a single track.
It will work fine within a single album if i just play one track after the other. The problems occur when I create a Queue with tracks from different albums or using shuffle.

As mentioned a previous ROON support person commented that my Library presents ROON “unique challenges” and that is when they advised adding more memory-Which I have done.

Anyway —do you have any idea what is happening.

I know you are doing your best but is there any other support available?
This is a complex problem and this way of communication is not very efficient.
I don’t think there is another method of communication but thought I would ask.

Thank You

I went the WEBUI and here is the info you requested.
ROON Database space is at 97%.
Im not sure what you mean by Internal Music storage?
I will try a much smaller database tech tonight and let you know how it goes
thank you

Add images

Well this may be significant.
I created a new database…this time with only 63 tracks
Initial result is everything is perfect.
Navigation in the Controllers is instant as is the selection and playing of tracks.
So it would seem its my library?
Curious to see what comes next but i fear you telling me my library is beyond the capabilities of ROON.
Thank you

Hey @thomas_clark1,

This could certainly be the culprit, as well as the drive that holds your library. You’ve mentioned the External HD a few times, what is the specific model of the drive? With your library size being a fair size, your external drive could potentially be struggling to keep up with it.

Let me know!

Due to performance issues with the external drive I moved my library to my NAS.
With my library on my NAS I no longer got “track loading problems” that I had with the external drive but I did experience all the issues that caused me to post to this forum.

Setup has been
FLAC files on NAS
TRACKS slow to play when loaded
Navigation very slow within the controllers
Unusable basically

I followed your advice and created a smaller Library on my NAS

MY smaller Library test library is 1700 tracks and everything works perfectly

So it seems it’s an issue with my library
So where do we go from here?

Do you forsee me being able to use Roon with my entire library 143000 FLAC files on my NAS?

Thank you

I don’t use an external HD connected to my Nucleus as any longer and had stopped before creating this support thread