Problem with Roon / Chord Poly : incessant dropouts

Hello, i just bought a Poly to complement my Mojo 2 but it encounters severe network dropouts using Roon. Every few seconds the connection between the core and the Poly fail, making the Poly Roon audio zone disapear on my Roon remote (iphone 13). This situation causes the music to instantly stop then a few seconds later (30 or more) the audio zone comes back and i must press play to relaunch the song. The Poly is using the lastest firmware and seems to be properly configured.
If I stream directly from my iPhone from Tidal or Qobuz to Poly using airplay (native apps) or upnp (via mconnect) there’s no dropouts at all.
If I use Roon on my iPhone (being the remote and audio zone at the same time) plugged directly to mojo 2 via usb there’s also no dropouts.
If I want to use Roon to stream to the Poly audiozone, no matter the way (through Roon endpoint audio zone or airplay audio zone) it first works but fails a few seconds later as explained earlier.
I tried switching off all other devices using the 2.4 GHz band, same result.
The wifi is provided by the Orange Livebox 4 and I’m using its 2 bands (2.4 GHz and 5Ghz) and I’m only a few meters away from the router (between 1 and 10).
What’s going on ? Any advice ?
Thanks.

Is your core plugged into the router or situated elsewhere?

Yes, it’s a NUC directly plugged to the router via a RJ45 cable in gigabit mode each side.

@killdozer may be able to suggest something. I’m a bit computer illiterate but I’m sure it must be pretty simple as mine works perfectly and I have devolo magic wifi power plugs everywhere that are generally frowned upon by the audiophiles.

That’s not to exclude anyone else who may help!

1 Like

I’ll chip in post mention. This sounds like Roon style network fussiness/badness. Given the symptoms it’s difficult to fault any part of the chain bar Roon. This last week I’ve had issues with three zones, 1 Chromecast, on HiFiBerry hat and my Poly pause about 30 sec into playback or on changing tracks, particularly between albums.

My first step is usually to stop Roon and clear the Temp and Cache directories beneath RoonServer. Then restart and cross fingers, seems to work…

So you delete ALL content in /var/roon/RoonServer/Cache and …/Temp directories ? even devicedb-prod.zip by example ?

Here’s the cache directory content :

Cache

Here’s the temp directory content :

You stop / start RoonServer on Ubuntu via systemctl ?

Thanks.

The Poly supports only the 2.4 GHz WiFi band, which is the most crowded frequency and has the least bandwidth. Is it possible to change which channel is being used for the 2.4 GHz band on your Orange router? As I am not in Europe, I cannot remember which channel or channels are preferred there (we tend to use channels 1, 6 or 11 in the US).

Sorry, domestic chore duty today so me and Gram Parsons sorting the garden out. Yeah, I zap the lot generally, it’s far from an official cure but it’s never hosed my setup :slight_smile:

I’d thought about that but if that was the case I’d expect to see the problems surface on non-Roon connections?

Yep, or sudo service roonserver stop/start cos I’m old :wink:

I’m actualy on channel 1, i tried 11 yesterday with same result.

@killdozer ok thanks i’ll try that.

Edit : @killdozer I just tried your technique but i still have droupouts and sometimes also a message regarding the Qobuz stream loading slowly … knowing that i got a 300 Mbps up and down internet connection, I’m standing at 1 meter from the router and that’s theres few devices connected on my 2.4 GHz band (most are connected on the 5GHz), it’s quite embarassing …

ROON isn’t still loading its data base is it? That can cause it some issues?

I’ve had similar problems with Hugo 2+2Go even at a rural location where there’s no 2.4GHz contention. The same problem happens with UPnP, but less frequently. And comparable problems with an A&K SP1000M (also 2.4GHz WiFi). My conclusion is that the combination of poor quality WiFi implementations in these portable devices with the extreme sensitivity to timing/packet retransmit in Roon’s RAAT protocol (which requires precise timing to play in sync to multi-endpoint zones) makes the combination unusable. But the problem is not just Roon’s, as I see it with UPnP as well. TL;DR Portable Roon endpoints on 2.4GHz: don’t waste your money.

1 Like

Maybe, where do you see that ? But if this was the problem, wouldn’t I also have dropouts when using my iphone as the endpoint (with mojo 2 attached using USB) ?

@Fernando_Pereira i also see a lot of people using MojoPoly and Roon flawlessly (on HeadFi and here) without complaining of such issues, there must be something wrong somewhere …

Mine works absolutely fine and haven’t had an issue in years but I realise that doesn’t help you.

I think there is a circle thing slowly turning at the top of the page if it’s loading?

Does the app say the wifi signal is good? It’s the same as the phone connection bar at the top?

It may if we figure out what makes yours working and mine not working :slight_smile:

I don’t see that, on settings page or home ?

The phone’s wifi connection bar is full (I’m 1.5 meters away from the router, the opposite would have been quite strange :slight_smile: )
There is also a specific in app wifi signal bar ?

The poly go figure app has a wifi signal strength bar in it I believe. That may give you an idea?
I have just switched mine on to send a photo but Sod’s law the battery is dead.

Oh ok, you were referring to the Poly’s wifi connection, yes it’s also full in go figure app.

Very odd. Have you got up sampling or anything on in Roon that’s making it work harder?

I don’t think so, where can i see that ?
By the way, if this were the case, wouldn’t it also affect music playing on my iphone as a Roon endpoint (which is flawless) ?

I think there’s something going on with Roon that the other protocols don’t do. I play internet radio via Roon pretty much constantly, using WiFi to a CCA, and it always stops after a few hours, pretty much all the time. I looked at the logs for a number of stops.

What I see is that one of my other WiFi endpoints (usually a Pi 3B+ running RoPieee), not in active use, disconnects momentarily, and that triggers a re-probe “storm” in Roon – it actively verifies all the endpoints (I’ve got a lot of Chromecast devices enabled). This all happens in the space of a second, but at some point, the state of the CCA which is playing radio is changed from “PLAYING” to “STOPPED”, like this:

02/01 08:51:31 Trace: [CCA House] [LowQuality, 24/32 MP3 => 24/48] [PLAYING @ 0:12] Opus Five/Seamus Blake - Silver Pockets / Tickle
02/01 08:51:31 Trace: [zone CCA House] Loading
02/01 08:51:31 Trace: [zone CCA House] Suspend
02/01 08:51:31 Info: [zone CCA House] Canceling Pending Sleep
02/01 08:51:31 Info: [transport] created zone CCA House
02/01 08:51:31 Info: [transport] with endpoint Chromecast Audio (23:1:9331d93a-6c08-2f9d-547d-527e8ad6c691) [IsAvailable=True]
02/01 08:51:31 Trace: [CCA House] [LowQuality, 24/32 MP3 => 24/48] [STOPPED @ 0:00]

Now, that state change wasn’t commanded by any human, and when you’re playing radio anyway, it doesn’t make a lot of sense to turn it off simply because of a sub-second network glitch on a different endpoint, but that seems to be what Roon does. Arguably a bug.

1 Like

You may have different settings in Roon to the phone and poly.

Tap on the volume to the player (bottom right)
Cart wheel symbol above volume bar will take you to settings for Roon and device set up etc.