Problem with Rose Rs250 and hqplayer

Problem with Rose Rs250 and hqplayer. I recently got this cool streamer/dac, but it doesn’t work for me with hqplayer. I use a macmini where i have hqplayer and roon core installed. If I use coreaudio, the device appears and I select it but the sound it sends is negligible, nothing is heard. I have also tried using the NAA with rasberry but when I select NetworkAudioAdapter nothing appears. I would like them to give me a solution since at the time I paid for the license and I don’t want to lose that wonderful recoder that is hqplayer.

I have HiFi Rose RS150B.
HQPlayer and roon are installed on my desktop PC. To get HQPlayer to work with Rose RS150B I had to buy UP Board (or whatever that is recomended on Signalyst homepage to use as a NAA) as a NAA with Linux (using provided bootable image) and then USB to theRS150B. After a reboot of the RS150B and some time for HQPlayer to find the NAA on the UP Board it worked.

Which model RPi? Only RPi4 is currently supported for NAA OS.

This image to burn to SD card using Etcher:


You should also ask them to support NAA on their OS. It should be quite easy as it runs Linux already.

Then you don’t need to use USB (if it works well).

Edit: seems like it runs Android? So probably not possible

Android is also Linux. But Android has it’s own software stack on top of very bare bone Linux user space. So I have never checked if the necessary items are there. But OTOH, networkaudiod requires very little.

1 Like

That’s the image I used but there is no way I have done all kinds of reboots, roon, hqplayer, rs250 and it doesn’t detect it. Back in the day I used the raspberry as NAA with a Cayin DAC and it detected it. There is no way, can you think of something I can try? Thank you

But is your RPi an RPi4 or RPi3 model?

My raspberry is RPi4

Do you have a spare Intel laptop or something, just to do a test?

Try this to make the machine an NAA (temporary test only):


And you can see on laptop screen any errors. Also check the HQP log file also.

Thank you for your interest, I have a mac book, could I do what you ask me on the mac book?

If your Macbook is running HQPlayer then you can’t run NAA OS at the same time with same laptop. Needs a seperate Intel laptop to try this.

With your RPi4 check you follow this power sequence:

  1. DAC
  2. NAA
  3. HQPlayer

And share screenshot of what options you see on HQP settings page

No, roon and hqplayer are on the mini mac, hqplayer is not running on the macbook which is a different computer

Ok try the sequence above first with RPi4

Don’t open HQPlayer app until DAC and then NAA is fully booted first.

Your DAC spec page mentions USB Audio Class 2 compatible, so should work.

Also check your USB 2.0 cable is a proper spec cable.

And use the USB 2.0 RPi4 ports (even though the USB3 ports should be backwards compatible - or try both).

Ok, now I try it and comment. Thank you

It has worked!!!. Thank you very much, I have changed the usb cable for a newer one. And I have done the boot in the sequence that you have told me and it works. How good it sounds!!! Thanks again.

1 Like

Fantastic news!

Enjoy the music with HQPlayer :sunglasses:

At first it seemed that it was going well, but after several days of use, for now I have to give up Hqplayer with RS250, the connection is very unstable, sound is lost or does not arrive. Ideally, Rose Os would implement hqplayer as NAA on the host itself.

Hmm sorry to hear about more troubles!

Are you only have issues with DSD or also PCM?

He estado probando con una imagen más antigua de naa raspberry y de momento parece que funciona. Seguiré haciendo pruebas a ver si es estable o sigue dando problemas, ya comentaré por aquí los resultados. Gracias Dabass

1 Like

Hello Jussi, in the end I have decided to use a NUC 7i7 as NAA, what would be the best option, install windows and inside it the executable or install the image from https://www.signalyst .eu/bins/naa/images/?. I have tried naa-430-x64.7z installed on a usb but it does nothing, what image should I use for my NUC and how do I install it on the mini PC?
Thanks and regards

You should use one of the NAA OS images from the place you are referring to.

Did you extract the .img file from the archive and write it to USB memory stick using balenaEtcher or similar tool? Once it has been successfully written to USB memory stick, tell your NUC BIOS to boot from the USB memory stick (check the boot priority setting).