Problem with upgrade to 1.8 (Build 880)

Roon Core Machine

NUC 8i7beh running ROCK. 8gb memory.

Networking Gear & Setup Details

NUC connected via gigabit ethernet to router.

Connected Audio Devices

Number of Tracks in Library

Libary around 3500 album plus using Qobuz.

Description of Issue

The upgrade from most recent prior version proceeded as expected, first upgrading the NUC and then numerous Roon control apps on Windows 10 as well as endpoints. But when all complete, Roon shows no albums. The Roon home page Roon icon just pulses.

I rebooted the NUC as well as the Windows PC I was using to access Roon. No change. I then ran a restore from the most recent Roon backup. It proceeded as expected but then still no albums.

When I launch a Roon controller on a different Win PC (or iPad) that has been updated, it sits with the screen ‘Waiting for remote Core…’ indefinitely. I finally clicked ‘Select a different Core’ and it immediately saw my Roon ROCK on NUC core as available. Unfortunately, after hitting Connect, it’s back to the Roon Home screen with zero artists/albums/tracks/composers and a pulsing Roon icon.

How should I proceed?

I should add that I do use Qobuz as well. The new 1.8 Build 880 came up without me being logged in to Qobuz, so I logged in. It said it’s connected but all I’m seeing on the Qobuz page is the pulsing Roon icon.

Note: my network is working fine. I can access the Roon Optimized Core Kit page via it’s IP address. I can also access the storage connected to the NUC. I have NOT yet attempted to completely rescan my library. I thought the backup restore would have taken care of that, but it seems not.

Also note that my Live Radio links page is just showing a pulsing Roon icon as well.

Last but not least, when I click on certain items such as Playlists, the Roon control app on my Win PC just crashes.

Likely metadata meltdown due to everyone updating. Have you tried rebooting core?

Hi @mdconnelly ,

Can you please try to use an older / your oldest backup to verify if the behavior is still the same?

1 Like

2 posts were split to a new topic: “issue with database” after updating Roon

@noris, when I first tried restoring a backup it was from last night’s backup. It didn’t restore. I just now tried to restore from my oldest backup (dated 12/1/2021). Unfortunately, it also didn’t make a difference.

Any other suggestions to try? I really do not want to start over scanning my entire library since I made many changes within Roon over the years for merging albums, correcting artists, etc…

Question: If I click Reset Database and Settings on the Roon ROCK web page (acccessed via IP address) would you expect a backup restore to restore all previous settings and content? Haven’t tried that since I wasn’t sure what I’d be resetting.

@Noris… OK, I saw what @kevin posted in another thread about a database problem. I suspect my problem is similar but I never actually saw any errors indicating a database problem.

If I’m reading this correct, then if I cannot restore from even my oldest backup, then the problem is actually in the backup (i.e. it backed up a somewhat corrupt database). Is that what is being said? If that’s correct, then that seems to imply that I must start over from scratch. That my previous Roon database, which I spent a lot of time currating over the last 5 years, is gone. That none of my existing backups are useful. Is that correct? (Probably don’t need to say how much that sucks, huh? )

Please note that I was having absolutely no problems at all with Roon and the database prior to this update. It all worked perfectly right up until yesterday when I attempted the update. If I were running Roon on Windows, I would simply restore a disk image, but that is not possible with ROCK.

Bottom line, 2 questions:

  1. Is there anything I can do to restore my Roon database to the state it was in prior to yesterday’s update?

  2. If not and if I need to rescan everything, how do you recommend I proceed? Should I do a Reset Database and Settings on the Roon Rock browser page? A Reinstall of the OS?

As frustrating as this is, it is far more disconcerting to be facing the holidays without music from Roon so any insight and advice is greatly appreciated.

@support - can I get a definitive answer as to whether there is anything that can be done to restore my prior db? If not, I want to start the rescan but I don’t want to start that if there is a remote chance that it can be restored. Thanks.

1 Like

I think this issue needs to be included with this one Update to Roon 1.8 Build 880 corrupts my Roon Core database

1 Like

I’ve got a house full of family and friends this weekend and I need Roon working, so I decided to go ahead and reinstall Roon Core on my NUC and let all my music rescan. I was freaking out that I would loose all the Qobuz albums I added to my Roon library, but amazingly enough, they still seem to be there. Not sure how that works but so damn thankful it did.

I do hope you’ll provide an honest post-mortem on this as well as a means to ensure we all have rock-solid backups for crises just like this.

1 Like

All Qobuz or Tidal links are reestablished from Qobuz and Tidal.

But will the “liked” tracks from these albums be restored as well? Losing all that carefully curated data would be a deal-breaker for me.

I don’t know anything about how that works. I only link albums and listen to albums. I don’t fool with individual tracks or playlists. I have 1200 albums linked in Tidal and the same 1200 in Qobuz. I also have the same 1200 in Apple Music. There are only a few exceptions. I have both Roon and Audirvana for redundancy purposes.

Thank Keetakawee for finding the issues of your update

I think this maybe the reason why some systems keep encountering database error. It seems new update uses function that doesn’t exist in older .NET Framework/Mono version.

12/16 14:17:06 Critical: Library.Init: System.TypeInitializationException: The type initializer for ‘PetitSearch.Analysis.CommonWordsCollection’ threw an exception. —> System.MissingMethodException: Method not found: ‘System.Collections.Generic.HashSet1<!!0> System.Linq.Enumerable.ToHashSet(System.Collections.Generic.IEnumerable1<!!0>)’.
at PetitSearch.Analysis.CommonWordsCollection…cctor()
— End of inner exception stack trace —
at PetitSearch.SearchIndex1..ctor(DocumentPropertyContainer1 propertyContainer, Boolean storeDocuments)
at Sooloos.Broker.Music.LibrarySearchIndex…ctor()
at Sooloos.Broker.Music.LibraryIndex…ctor(Library library)
at Sooloos.Broker.Music.Library.Init(Database db)

Hey everyone,

While there is no final answer I can provide on the database corruption, our team has started an investigation. You can find out all about that here:


Hi @mdconnelly ,

Earlier today, we released Roon Build 882 which contains some changes to the way Roon databases are restored, we believe this may help you restore your previous database as well based on the diagnostics we saw from your Core. If you want, you can give the restore another try and let us know if it works!

This error type should have been fixed as well.

Full details in the release notes here:

1 Like

Your initial response to just start over was …say …we say …Malarkey … and you guys and girls in the Software Design and troubleshooting Dept … may have caused people to discard perfectly good Data Base’s in your Silly answers … you may want to Thank Keetakawee from FIdelIzer maker of the NimitraS RooN core unit for finding your software issue …and pointing it out …

Big Deal … You blamed corruption of Data Base’s on hardware issues …NOT as it was in reality Your Software

@noris - So I’ve already done a full rescan of my library before Build 882 was released. If I install Build 882, can I then do a full restore over it from a backup pre build 880 or do I need to start with a new empty database before doing a restore. My Core is ROCK on NUC. Please advise to be sure I don’t screw it up. Thanks.

If you read my initial posts in this thread, I noted that my problem never showed database corruption but did result in similar symptoms – empty library, no endpoints, etc… So Build 882 just might help my problem. Seems worth a try at least.