Problem with volume on AirPlay devices in Roon 2.0

Roon Core Machine

**MacMini 2014, Intel Core i5 2,4 GHz, 8 GB RAM **

Networking Gear & Setup Details

Connected Audio Devices

Primare i35 - System Audio Saxo 5 - Libratone Zipp mini - Sonos Roam - IKEA Symfonisk

Number of Tracks in Library

31,000 tracks

Description of Issue

After upgrading to Roon 2.0 I am having problems with the volume on 5 devices playing through Airplay. Until Roon 2.0 there has never been any problems with this configuration. It is System Audio Saxo 5 connected to Airport Express, 2 Libratone Zipp mini, 1 Sonos Roam and 1 IKEA Symfonisk speaker. When volume control is set to fixed i Roon it is possible to adjust volume on the 2 Zipp minis, but not on Sonos and IKEA (Sonos). When volume control in Roon is set to Device volume it is not possible to adjust volume either from Roon or any of the devices, and they are playing very loud. I am running Roon server on a MacMini 2014. Anyone out there that has any clue what the problem might be?

Hi @Petter_Larsen,

Please accept our sincere apologies for the long delay, as we’ve been working diligently through the uptick in support requests after the launch of 2.0. We’re very grateful for your patience.

I recommend first verifying that you haven’t set any Private Zones inadvertently. I’d also verify that you have the latest firmware installed across your endpoints, in case there’s a UPnP mismatch between Roon and your Sonos devices.

Failing that, I’d take the following steps to refresh RoonServer:

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Please let us know if these steps help remedy this issue.

Hi! Sorry for the late respons, I have been away from home. I have tried everything you describe, the problem remains. It seems it is a problem only with airplay. Playing directly in Sonos mode it works fine. The funny thing is when I install the Roon App on the MacMini and use that as the core everything works fine in Airplay as well, but not with Roon Server as the Core.

Hi @Petter_Larsen,

Do you have the latest firmware installed on the Airport? The team has pulled an automated diagnostic report from your account that should give us more insight into the volume control issue. Please log into Roon on your Mac Mini device at some point in the next week to allow for the report to reach our servers.

Let’s try a RAATServer refresh for due diligence in the meantime. This is similar to the step you previously attempted; note the folder name change.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder