Problems building Sonos library from Rock

Hi All

System is Rock on NUC i5. Various end points including multiple Sonos units connected via SonosNet.

I have been using the Rock as a Media Share for the Sonos without issues under the Sonos S1 controller. This week I upgraded to S2.

I added a new album to the Rock and tried to reindex but got an error that I’ve attached. I could play music from the library , but not update.

Sonos support tried some online diagnostics but were pretty much clueless. I restarted the whole system (including router) with no better result.

In a temper I deleted the library in sonos hoping I could create it from scratch - bad move!

So here is the conundrum

My CD file structure on the Rock is
Wave A to C
Wave D to F
Wave G to I

I can successfully build a share for Wave D to F and G to I , but not A to C which gives the same error as the photo. I can create a share for an album within the Wave A to C folder.

When I try to reindex, I again hit the issue shown in the photo.

The majority of the CDs were ripped with DB Poweramp, a small number are downloads .

Any ideas on this - is it something in the Data that’s crapping out the Sonos ?

Add images

I have an intereting

This is neither a Roon nor ROCK issue since you’re using ROCK as a NAS / file share.

You should post under #tinkering or #audio-gear-talk:sonos.

IIRC, ROCK supports Samba V1, so this may be the issue… can you play the files from Roon to the Sonos?

Hi Martin

Thank you for your clarification. I am able to play from the rock to Sonos end points via the Roon controller

I’ve checked on the forum, and it seems that ROCK definitely supports Samba V1 with guest access; userid and password ‘guest’ should work too.

As far as I can tell, Sonos S2 does support Samba V1, so maybe you haven’t passed the correct guest login information?

The obsolete SMB v1 supports anonymous logins without authentication (the very reason why it is considered insecure, it’s usage is discouraged and it got declared as obsolete and deactivated by default on Microsoft Windows and most (all?) other modern OS distributions) while SMB v2, which is also supported by ROCK btw., requires authentication (like Guest, Guest for example).

Note: try Anonymous as username to login, it helped at least one other user.

1 Like

It’s strange that some folders copy and others throw this error. I wonder if there is a tagging issue that Sonos doesn’t like in the Wav files?

WAV doesn’t contain metadata, so there are no tags. If you have a cue file, try splitting the WAV into individual Flac files. Then you can add metadata using MusicBrainz Picard or a similar tag editor.