Problems connecting to my Roon Core after upgrading


I have been running Roon for a year now with no issues however I upgraded on Friday to 1.3 (build 259) just gone and I am having all sorts of trouble with it taking along time to connect to the Roon Server. Also when it finally does connect I can’t always see my end point which is a Meridian MS600.

I use Mac Book Pro running Sierra as my controller, and the Server is an i5 NUC running Ubuntu 16.04 LTS.

My Roon sever is connected to my network

Please advise

Hi @Martin_Morgan ----- Thank you for the post and sharing your feedback with us. Both are appreciated.

Moving forward, to help aide in my evaluation of this behavior you’re reporting, may I very kindly ask you to please provide me with the following information:

  • Just to confirm. Roon server (i5 NUC Ubuntu 16.04 LTS) is staying in an active state and only the remote is struggling to connect, correct?

  • Since noticing this behavior, have you tried…

  • Power cycling ALL of your equipment? This would include any networking hardware as well.

  • Entering the IP address of the NUC when the MacBook Pro is searching for the NUC?

  • Testing with a hardwired connection between your MacBook Pro and your router, thus temporarily eliminating WiFi from the equation?

  • Reinstalling the application on the the MacBook Pro?

  • Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding of how your devices are communicating and the tools being used to make those connections possible.


Hi Eric,

I have tried power cycling but it didn’t seem to work. I did notice that the MS600 was saying it couldn’t get a DHCP resolution so I changed the router and that seemed to be better, however I have persevered with the Meraki device as it has 4 LAN ports not 1 when I think I know what the problem is. I think the firewall setting on the NUC are preventing connection. When I turn it off it works, when I don’t it doesn’t, so what should the firewall be set to please. It was absolutely fine until upgrade.

By the way what is ROCK please?



By the way. Its all wired connections I don’t stream audio over the WiFI



Hi @Martin_Morgan ---- Thank you for touching base with me, the follow up is appreciated!

Moving forward, it looks like you have identified the “problem” here (i.e your firewall). You should make security exceptions for “Roon” and “RAATServer” in your firewall settings or leave it disabled. While I am not totally clear on what security implementations you have in place on your i5 NUC, a quick google search provided the following: Ubuntu Documentation: Control network traffic in and out of your computer

Laslty, in regard to your question about “What ROCK is”. All that information can be found here in our Knowledge Base article: “Roon Optimized Core Kit”.