Problems transferring music from 2 servers to Nucleus+ (RevA)

Roon Core Machine

Nucleus+

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have been trying to consolidate music (in excess of 125,000 songs) stored on 2 of my network servers (a Vortexbox server & a NAD M50,2 server) onto a new Samsung 8TB SSD that I have recently installed on my Nucleus+ server. I formatted this new SSD as per Roon instructions. Here are the methods that I tried to transfer the music and the problems that I encountered:

Trying to use Windows 11 Drag & Drop from each existing server to the Roon Nucleus+ server.

Using Windows 11 operating system, I finally got the “drag & drop” feature to work but here is my problem. In windows File Explorer, upon dragging a folder called Music (where all of my songs are stored on each of the Vortexbox & NAD M50.2 servers) a strange message keeps appearing. For example It tells me that there is not enough space on the Cafe on the Corner song. 1.69 TB is needed to copy this item. Delete or move files so you have enough space. It then gives me the option of either clicking on “try again”, “skip” or “cancel”. Clicking on “try again” does not solve the problem. When I choose “Skip” it goes on supposedly transferring files to the Nucleus+ but then I keep getting the same type of message for other songs. It is impossible that each song could need such huge amounts of terabytes for storage, since when you add up all of the terabytes, the total terabytes are greater than the terabyte capacities on my Vortexbox & NAD M50.2 servers. Does anyone know what is going on here?
Next, I tried doing the following:

First Transferring music to a San Disk Extreme Pro portable 4TB SSD

I transferred my music folders from my two servers to my portable San disk Extreme Pro portable 4TB SSD. I then tried to use Windows 11 drag & drop to transfer all of the files from my portable SSD to the Nucleus+. This portable SSD was connected via a USB 3.2 Gen 2 Type C port on my Dell XPS8950 desktop computer. Some but very few of the music files transferred to the Nucleus+. Does anyone have any idea of why so little music is being transferred?

Finally, can anyone suggest a better way to transfer all of my music folders from my 2 existing servers to my Nucleus+ server?

The Nucleus will share the 8 tb drive is shared as a Network share. Using Windows File manager open a File Manager window on the 8 tb drive (see below), open a file window on the PC with the music and then copy using drag and drop with file manager. Make sure that everything is connect via ethernet and wifi is not being used during the transfer.

Opening the internal storage on Nucleus+ for Windows

  1. Open File Explorer
  2. Enter \\NUCLEUSPLUS\Data\Storage\InternalStorage

Personally, I’ve found just using external drives are so much easier. Copy the music to it. Plug it into the Nucleus or Nuc. done. Need to add more later, move the drive back to a PC, add music, move it back to the Nucleus or Nuc. In addition, the external drive

My problem has not been solved - that is I am having trouble transferring my music files from my 2 other network servers to a new Samsung 870 QVO SATA 2.5" 8 TB SSD on my Nucleus+ server.

To reiterate, upon trying to use Windows 11 to drag & drop my music files, I continue to receive a message such as the following:

“There is not enough space on the Cafe on the Corner song. 1.69 TB is needed to copy this item. Delete or move files so you have enough space.” (the original song does not use up 1.69 TB)

I am then given the option of either clicking “try again”, “skip” or “cancel”. Clicking on “try again” does not solve the problem. When I choose “Skip” it goes on supposedly transferring files to the Nucleus+ but then it is only a matter of time before I get the same type of message about another song that purportedly needs huge amounts of storage, and if I skip this song, the same type of message comes up for other songs.

I had a computer technician visit my home and look at the situation. He thought that the SSD might be defective, so I returned it & got a new replacement. The same thing is happening with the new SSD. Unfortunately, when I contact Samsung for support on this matter, they say that they are sorry, but do not have support for problems such as mine.

There is an article entitled “SSD Reports Wrong Size in Windows? Why and How to Fix it easily” by Emily (Last updated June 23, 2022). I do not know if this article is even applicable to my situation, and even if it was, the SSD may have to be installed in my desktop computer, with the Windows 11 operating system, to even try the fixes recommended. I am not sure if such a fix, if possible, could be done while the SSD is in the Nucleus+ server. This article can be accessed at https://www.diskpart.com/articles/ssd-reports-wrong-size.

I am hoping that someone in the Roon Community has an idea about what may be causing my music file copying problem.

What is the name of the destination folder that you are trying to use on the Nucleus? Are you sure that you are dropping your music files into the InternalStorage folder?

If you are dropping them into the Storage folder, then this is putting the files on the m.2 SSD, not the 2.5"8TB SSD. This won’t work, a) because there is not enough space on the m.2 SSD and b) because music files should never be put on this SSD.

1 Like

Hi @Greg_Johnson,

Please accept my apologies for the unacceptable wait time for a staff response and rest assured we’ve prioritized your issue.

First off, @Geoff_Coupe’s comment is an appropriate word of caution: I’d verify that you’re Dragging and Dropping your music into the correct filepath. Several items in your original report suggest that you’re attempting to copy music into the Nucleus’s own drive, rather than the external SSD you’ve added to your setup. I’d perhaps reformat the SSD you intend to use for storage from the Nucleus+ web administration page before rebooting and testing again.

We’ll be standing by for your response.

Hello Connor;

To answer your question, I did try to copy my music files to “\Nucleusplus\Data\Storage\Internal Storage” after haviing reformatted the Samasung 8 TB SSD , as you suggested and still ran into the same problem.

In the meantime I have been having problems with my new DELL XPS8950 desktop computer and the stopcode “WHEA unccorrecctible error” keeps popping up and rebooting my computer. Dell technicians took remote control of my computer but were not able to fix the problem. They have asked me to ship the computer back to DELL for examination.

Therefore I reverted to using my older DELL XPS8700 desktop computer and when I clicked on the Roon icon the following message appeared:

Incompatible version. Roon is trying to connect but your core and remote are running on different versions It shows:
Nucleus+ 20 build 1133) production. You have the latest version installed

    This PC 1.8 build stable

What’s Next? For more information about resolving mismatched versions visit our help center but when I try to follow the link the message comes up “The requested page could not be found”.

What should I do?

It sounds as though your Nucleus is running Roon version 2.0, while your older PC is running version 1.8. So you need to download and install the latest version of Roon on your PC. Download the PC version of Roon from here:

1 Like

Hi @Greg_Johnson,

What version of Windows are you running on the backup Dell XPS8700? Please note that Roon 2.0 will require Windows 10 or above. I’m sorry to hear that you’re down a PC Remote in the meantime.

Hello Connor;

I am running Windows 10 on my older Dell Xps 8700 desktop computer

Greg

Hi @Greg_Johnson,

Please accept my apologies that this thread has not received proper attention since your last response.

Taking a quick glance at some account data, it appears there might be ongoing issues consolidating your music library; there aren’t any tracks registered with the Nucleus+ external storage location.

However, all of your devices are now on the correct build, including a Windows 10 Remote that I believe you’d identified in your post above. Given that a build mismatch was responsible for the migration issues previously, I recommend you try the Drag and Drop method to your preferred Library location (either theInternalStorage folder on the Nucleus+ or a portable external drive).

We’re watching this thread to promptly respond. Thank you again for your patience.

Connor;

There is no build mismatch when I am using my newly purchased DELL XPS8950 desktop computer. I still have the same problems trying to drag & drop music from my existing servers and a portable USB drive to the Samsung 8 TB SSD on the Nucleus+.

For your information it was during the time that my new XPS 8950 desktop was in to DELL for repair, that I “resurrected” my old DELL XPS8700 and that is where the mismatch occurred. I corrected the mismatch on this older computer and still encountered the same problems.

I now using my new DELL XPS8900 desktop.

Hi @Greg_Johnson,

Our diagnostic records show recent activity on your Nucleus - have you been able to transfer files to the desired storage location and Core?

We’re here to support if you’re still having issues.

Connor;
I have been so preoccupied with other matters that I have not had the time to think about if or how I am going to attempt to transfer my music files from over 8000 albums, that are contained on my existing servers, to the 8TB SSD that I installed in my Nucleus+.

Right now I am disappointed that no one in the Roon community has been able to suggest a better way to transfer my music files other than by using Windows 11 drag & drop to transfer the music files, but only one or two albums at a time, due to apparent data transfer problems. I am still looking for a “bulk” solution to transfer all of my music files at once and accurately, perhaps with verification, to the 8 TB internal SSD in my Nucleus+ and also to another large hard drive for backup.

In due course I will give this matter more consideration.

Greg

Hi @Greg_Johnson ,

You could try using Robocopy to transfer the files from Server A to the Nucleus using your desktop PC. It is a far superior way to drag and drop, especially when there are lots of files involved.

It is run from the Windows Command Line, so you would need to open that first (run cmd.exe) and then type the following:

robocopy <source_drive> <destination_drive> /mir

replace <source_drive> and <destination_drive> with the windows paths to your music files on the network or map a network drive first to that path and use that letter, for example X:\

The /mir flag tells robocopy to mirror the source to the destination so it will overwrite or delete anything that exists on the destination. There are other flags you can use that are described here.

I’ve not used Windows for a while but it was always my go-to tool for copying large numbers of files (I use a similar program called rsync on my Mac and Linux system). If there are any errors then robocopy can ignore them and continue and better report on the errors it encounters.

If this doesn’t work at all then at least it will eliminate the “drag and drop” copying as part of the problem you are experiencing and may help the next person identify what is causing the problem.

I setup my NUC/ROCK some months back , I transferred around 3Tb

I used SyncBack Pro , just define source and destination and press go

For the first copy normal Copy & Paste would do the same. SyncBack only copies non identical files so once copied it works by difference and saves a lot of time.

My 3Tb took a while , can’t just remember but maybe 24 hrs, just leave it running