Problems Updating Roon PC Endpoint [resolved]

I updated my Roon PC Core to 1.3 with no problems. I then tried updating my Roon Endpoint on my laptop and I get the following screens:

After clicking “Connect” I get the following:

So the first screen indicates my core needs updating but the second screen says it has the latest version (I get the same message when I check “About” in the Core settings). When I click on the “Check for an update” link in my Endpoint laptop I get no response.

Please advise.

I see the same from my iPad and PC.

Can you click Roon on the menu bar at the top left of the screen and select About Roon?

There you should see that an update is available.

Cheers, Greg

On the iPad, go to the App Store and click Updates.

Cheers, Greg

I do not see a About Roon on the top left and the App Store does not have a new version (I am in Canada).

I am running Windows 7 Pro.

I had to download a new endpoint before Roon would update my endpoint. It is working fine now.

No, but I see they are rolling out a new build…193 downloading now so maybe that fixes it?

Looks like I just got 193 but the problem is still there.

I’m still having the problem also. :frowning:

Will try downloading Roon again. Do I need to uninstall the endpoint first?

And the iPad app won’t update.

Can you minimize Roon, so that you can see the menu bar? You’re looking for the usual File, Edit, etc.

Sorry, I’m going by memory. I don’t have a pc.

Cheers, Greg

No menu bar shown.

@support, can you help here?

Cheers, Greg

Went to Apps and was able to download latest build, Roon seems current now.

@cgw try rebooting both your core and remote computers. If/when presented with the Update Needed screen try clicking on the “Check for and Update” link again.

If that doesn’t work then uninstall Roon on your windows PC (remote). Download a new copy of Roon from this link:

and install

1 Like

I uninstalled Roon on my iPad and reinstalled it and it is now connected!

I uninstalled Roon on my Windows 7 Pro and it still says check for an update 1.2 (build 165). I used the link you gave me.

I just downloaded Roon again and ran the installation and now it works fine.

Hmmm… this is strange. Can you post a screenshot of the error you’re seeing?

we definitely fixed this bug in 1.3, but 1.2 is not 1.3 :frowning:

it only occurs in certain cases and it does do the right thing if you wait and restart or redownload from website.

I uninstalled Roon rebooted and re-downloaded but I still appear to be getting 1.2 on the PC.

Could my internet provider be caching the download? Is there another link to the download?