Problems upsampling PCM to DSD using Roon, HQ Player, PS Audio Directstream

I have clicks and pops no matter what configuration I try upsampling PCM 44.1 to DSD 64 or 128 using Roon,HQP and the Directstream. I just reinstalled HQP and updated to the latest version. I am also using a Sound Science Music Vault Ultra 2 Windows 7 with plenty of power.

When using HQP on its own to upsample PCM to DSD 64 or 128 it works great so it seems like a mismatch somewhere in Roon. Any help would be appreciated Thanks

Is “Parallelize Sigma-Delta Modulator” enabled in the DSP options?

No I have Roon DSP turned off only using hqp to upsample.

Hi @Brian_Borgman ------ Thank you for the report and sharing your feedback with us. The insight is appreciated!

I am curious, if you let Roon handle the upsampling via the DSP Engine, with HQPlayer temporarily removed from the “chain”, how do things behave?


Hi Eric things work fine using Roon DSP on its own.

1 Like

Hi @Brian_Borgman,

Would you be able to upload a pic of your HQP settings when upsampling Roon to DSD to the PS Audio ?

How is your computer connected to the DAC ?

1 Like

I am connected using Curious USB cables and a Wyred 4 Sound Recovery.

Thanks Brian,

A couple of suggestions I’d make to see if they make a difference:

  • Are you using the latest PSAudio USB DAC driver in the DirectStream ? This can be updated with an SD card as per the video on the linked page;

  • Do you have an ASIO option under Backend ? If so, try it instead of WASAPI;

  • Try setting Buffer time to the smallest minimum value instead of default. This resolved some pops and clicks for me recently when using the updated microRendu software with HQP;

  • I think the PerfectWave DirectStream has a maximum 24 bits. Try setting DAC bits to 24;

  • The Music Vault Ultra 2 appears to have an i5 processor but I can’t see mention of how many cores it has. I’d suggest ticking the “Multicore DSP” box in HQP Settings and seeing if that makes a difference. It performs a similar function in HQP to the Parallelize Sigma-Delta Modulator switch in Roon DSP mentioned above;

  • Check whether omitting the Wyred 4 Sound Recovery reclocker makes any difference. I can’t think why it should, but checking equipment in the signal path is always good troubleshooting practice.

If those things don’t help, check back here and we’ll ask Eric to take things further.

1 Like

Great advice @andybob! @Brian_Borgman, posting to let you know I have my eye on this thread :wink:


1 Like

Thx for all the suggestions. I had already tried all of them before but with no luck. I went back through again but still no improvements. Thx Brian

Thanks Brian,

I’m all out of ideas so I’ll defer to @Eric who may gather logs etc.

Am I right in thinking you’re pointing Roon to HQP using localhost ?

1 Like

Hi @Brian_Borgman ----- Thank you for giving the suggestions made by @andybob, a go. Your continued feedback has been very appreciated!

Moving forward, we are going to do some testing on our side to see if we can reproduce the same behavior and will update this thread accordingly, once completed. In the meantime, may I very kindly ask you to please reproduce the reported behavior, note the time when the issue is observed, and then using this knowledge base article as guide, send us over a set of Roon and RAATServer logs.


Eric could you please provide a way for me to upload the logs directly to you. I do not have Dropbox etc . thx Brian

Hi @Brian_Borgman ---- I have sent you upload instructions via a PM :wink:


Hi @Brian_Borgman ---- Touching base, to let you know that I have seen your PM and that the requested logs have been received, which are now in our queue to be evaluated by a member of our tech staff.

Once my report has been updated and passed back, I will be sure to reach out with the team’s thoughts/findings. Your patience is very appreciated!


Thanks Eric I appreciate it. Brian

Hi @Brian_Borgman ---- Thank you for your patience while our team has been looking into this behavior you’ve reported to us.

Moving forward, while my report is still with our techs I noticed something while reviewing my notes. You mentioned that you are using a DirectStream DAC but in your screenshot of the HQPLayer settings, under “device” it reads: PerfectWave DSD.

I just want to be certain that our team is testing with the correct equipment :sunglasses: Please advise.


Hi Eric PS Audio appears to have just one usb driver download for all of there dacs.

Im not sure if this could also be related to my problem but i have been trying the HQP Polysinc XTR & mp settings playing PCM and having the same issues as with DSD.

This seems to be the same with Waspi or Asio. Asio changes my backend to PS
Audio Driver which was named by me in Roon setup.

If it would help make troubleshooting easier someone could call me. Thx Brian

The xtr filters in HQP are about eight times more processor intensive than other filters.

Do you know anything more about the i5 in your Music Vault ? The model number would be most helpful, the number of cores and frequency if model number is unavailable.

Hey @Brian_Borgman – I just tried this exact setup here:

And I’m not having any clicks and pops. I’m trying to think of where to go with this next – @andybob’s list of troubleshooting tips was really good, and I’m assuming you’ve tried basic things like swapping cables.

Have you tried running the Core and HQP on the different machine? It’s a long shot, but I’m really just trying to eliminate variables at this point.

Can you confirm the firmware versions on the PS Audio?

For what it’s worth, here were my settings just now, running without issue. You’re seeing the same signal path right?

1 Like