Problems with Apple Mojave OS

Ever since I upgraded to Mojave on my MacMini, the Roon app no longer works. The app shows the opening banner and then closes. I have tried reinstalling the app but with the same results.
Can you point me in the right direction to fix this problem?
[Personal information removed by Staff]

Hello @M_I_Starns,

Thanks for contacting support, I’d be happy to assist. Have you dragged the into your Applications folder as so? Simply clicking it there will not work.

This may also be a permissions issue, we have instructions listed here on how to get out of that state but it would basically be to open Terminal and paste the following command:
sudo chown $(whoami) ~ ~/Library; chmod u+rwx ~/ ~/Library

Enter your password and press enter. This will reset the permissions for the installed location of Roon.

Please let me know if that helps.


I tried the permissions issue instructions but the Roon app still opens and shuts down several seconds after displaying the Roon “Quote”. I have an error message that I can send you if that helps troubleshoot the issue. I have used the app for a long time but the upgrade to Mojave seems to have caused the problem. I do not have this issue with any other audio app.
Thanks for helping.

Thanks for letting me know @M_I_Starns, that does appear to be strange behavior. Can you please let me know if you have backups made for your Roon database? Also, what is the error message that is being displayed, it would help clarify the issue a bit so please let me know.


@M_I_Starns, one question: is Roon listed (and the checkbox checked) under

System Settings >>> Security & Privacy >> Privacy > Accessibility

as an application allowed to control the Mac?