Problems with Devialet Core Infinity streaming board

I just received my Devialet Expert 220 back from Plurison in Quebec with the Core Infinity Streaming Board installed.

I reconfigured it, and it works with CD and Sonos. I cannot get the Wifi or Ethernet to work. In the settings window on the 220, it says “Wifi mode turned off" and under “Ethernet" is blank. Both have been configured.

I mainly use Roon from my Mac Powerbook, and Roon can’t find the Devialet (it did so automatically before the upgrade). I installed the newest Devialet Air on the Mac (which was not necessary with Roon), but it can’t find the Wifi or Ethernet either. When I try to stream from my iPad, the iPad finds my Aiport Express (which is connected to the Devialet via Ethernet), but the Devialet doesn’t connect.

I realize this is a Devialet glitch, not a Roon error, but I’m wondering any Devialet users here have done the upgrade and have had the same problem - and hopefully a solution.

I am running Roon through a Mac Powerbook, using a Thunderbolt to my SSD storage. I have a Mac Airport Express running into the Devialet via ethernet for a stronger and more stable wifi feed.

Thanks in advance for any help,


My understanding is that the software for the new Core board is not yet deployed and mature, it’s a matter of days. Maybe check with your dealer.

That’s really professional by Devialet, take someones Pro that’s working perfectly fine, upgrade it with the new CI board, but don’t have robust software in place that makes Wi-Fi / Ethernet connections to the upgraded Pro unusable.

Another outstanding piece of business by Devialet (not) :-1:

A service rep from Devialet just phoned me. They did install the streaming boards before the software was ready, She said they will release a new configurator which should solve the problem. No time given, but my guess is it will be within weeks, not months. But I agree with John, why install an upgrade that renders your amp unusable for its main functions?

Thanks to heads-up from Markush, I installed the new firmware made available by Devialet today. I have Roon connected by the newest Devialet Air to the Expert 220. (it seems you have to use the Air app again.) The info window now calls it Air instead of Ethernet. It was stable though one album in my library, but stuttering when playing Room radio. Haven’t had time to investigate - it could be Tidal is not in exclusive mode (that had been a problem once before). Bluetooth also shows up an option. Airplay not available yet. Anyways, it’s a start. Will have more time to play around with it this weekend.

Interesting to hear more of your testing.


Realise it’s hard to concentrate on just the SQ, when the features (that were there before the upgrade are now more unreliable), but have you had a chance to hear if the SQ with the CI is better or worse (or are you too busy pulling your hair out to notice)?

Have spent some time on a Sunday playing the upgraded 220 and the results are infuriating. An ordinary 16/44 album played with no dropouts. Switched to a Sonny Boy Williamson DSD and it broke up every 20 seconds or so. Had t take it off. Tried Joni Mitchell’s Hejira (Tidal HQA) - it broke up on first track, was stable on the second track, broke up badly on the third track. Had to take it off. Now playing Marianne Faithfull 16/44 aiff and it seems to be stable (after one fallout on the first track - one more fallout around track seven). When I wanted to switch albums, I had to turn the Devialet on and off to get it to connect to Roon again. Settings for Air: Exclusive and Integer Mode on. Max Hardware/ Power of Two on. Max sample rate uo to 192 (maybe I should disable that). I’m using a dedicated 5Ghz network via Airport Express connected by ethernet.

I recently had a more powerful modem installed - a HomeHub 3000 (5Ghz x 2; 2.4 Gz; 12 antennae; 802.11ac). Perhaps I should try a dedicated 2.4 Gz network through the Express? Or disconnect the express and beam the main modem to it directly? I can’t tell if the Air input on the Devialet is using the ethernet feed or the wifi feed - any way to ascertain that and change it?

As for sound quality, it’s very good on redbook CD rips - can’t say better than before, since I can’t A/B it. For high quality, I can’t get to play long enough to judge it. It seems to be the same troubles with Air that existed before Roon found a way to work around it. I hope we can bypass it soon.

So Markus, any advice you have is welcome. I will send these results to Devialet as well.

I’m so happy I let the door hit me on the back side on the way out.

Too bad with this first experience. One thing strikes me : do you still use the Devialet Air Driver ? If so, why not disabling it and let Roon use it’s own implementation ? Devialet has anyway to come up with fixes.

As far as I can tell, you have to use the Air app with the Core Infinity. Without Air installed, Roon couldn’t find The Devialet. This wasn’t the case pre-upgrade.

But maybe I’ve missed something. Is anyone connecting to Devislet Core Infinity remotely without using the Air app? Would love to ditch it and get back to the previous stability.

Alec- To my delight, I found that Roon did find “My Devialet- Eth”, the connection that bypassed Air and worked like a charm before the upgrade. (It was missing two days ago.) Now the problem is that I can’t open the Ethernet input in the Devialet. It has been replaced by an input called Air (which I don’t know if it’s connected by ethernet or wifi). . I removed Air from my Powerbook and tried to connect directly from Roon, but it can’t find the ethernet input on Devialet. Any suggestions?

Hi @django54. I don’t yet have my Dev back from France, so have not yet had a chance to try the new CI upgrade, but in the Configurator you could choose to de-select WiFi or Ethernet, can you still do this? If so check whether WiFi is de-selected (greyed out) and only select Ethernet. This should then see whether you are on Ethernet or not.

So the connection from Roon to the new Devialet Air input IS by Ethernet. However, I can only connect via the Air app on my MacBook Pro. The Roon “my Devialet - ETH” - you know, the remote that actually worked - can’t find the upgraded 220. So I’m stilling getting dropouts and failures. When I talked to a Devialet rep a week ago, she said a new configurator is coming, so maybe that will help. But my experience with Devialet is that a sure solution will only come from the Roon side, who are apparently working on it.

It’s strange that obviously Roon AIR is working for some with the new CI board. Any idea @danny ?

Roon Air is now working for me. I deleted the Devialet Air app. Still occasional drop-outs. Marcus, what buffering setting do you use?


I am using the default settings.

I can get 60 minutes of stable play, and then it just stops. Turn the Devialet off and on, I get stuttering play, then stable. then it will stop after 20 minutes. This is on 16/ 44.1 rips or Tidal - not HQA. It’s on a dedicated 5.2 ghz wifi/ Ethernet feed. My wifi in the house is strong - Sonos (in the kitchen, never on the same time as Devialet) never drops out. I just don’t know what to do.


Type the IP address of your Devialet into a web browser and send a report (it will automatically attach log files)

Maybe worth waiting for the next Roon update, the team said on another thread that they implemented changes to accommodate for the new Devialet OS board.