Problems with DSPeaker AM 2.0 Dual Core

Core Machine (Operating system/System info/Roon build number)

Win 10 / Amd Ryzen 3 HTPC/ latest Roon build / Roon Server installed

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus RT-AC66U AC1750 via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

DSPeaker AM 2.0 Dual Core, connected via USB on the same machine where the Roon Server is installed.

Description Of Issue
In the Roon remote app I can find the DSPeaker with WASAPI driver, but I don’t have the possibility to generate a playback, if I change to “zones” and click on the DSPeaker. Only “System Output” give me the possibility to play my titles. But why?

Hello @Ralf_Schuchardt, could you please send me a screenshot of “Settings>Audio” so we can see what shows up? Thanks!

Hi @nuwriy,

thank you very much for your help.
Attached you will find the required settings.

Thanks in advance.
Sincerely, Ralf

Hello @Ralf_Schuchardt, and thanks for the screenshots. Could you elaborate on the make and model of the DAC? Also when you try to play to it, do you see an error? You showed that you can select it as a zone, but what do you see when trying to play to it?

Dear @nuwriy, of course. It is the DSPeaker Anti-Mode 2.0 Dual Core with the latest firmware.

No, there is no error, just the message, “no playback”.
Thx in advance for your help. :slight_smile:

Hello @Ralf_Schuchardt, and thanks for the screenshots! Could you please try reinstalling the drivers for this device and see if that makes a change? Thanks!

Hello @nuwriy, I tried it out… Nothing changed. It doesn’t matter which device I activate or rather choose, the only one that works is the system output… I allways see, if I try another zone, “no playback”…

Hello @Ralf_Schuchardt,

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Thank you so much @nuwriy

Hello @Ralf_Schuchardt, I checked for the diagnostics but it looks like they haven’t come in yet. Is your Roon server instance running?

Hello @nuwriy, sorry. Yesterday I had no time. Today, in the early morning, I started the roon server.

Hello @Ralf_Schuchardt, I got the report. Thanks! I’ll send it over to the team.

Hello @Ralf_Schuchardt, and my apologies for the delay on this thread. The team and I looked over the information you sent again recently and we noticed that you also have Realtek drivers installed. If you could please remove your Realtek drivers since we’ve seen similar issues in the past resolved by doing so, let me know if this helps. Thanks!

Hello @nuwriy. This is okay. I tried what you told me, but it did not work. I uninstalled realtek driver but Realtek ASIO is visible all the time. I choose DSPeaker for playback but it is the same like before…

Hello @Ralf_Schuchardt, and thanks for trying that! Our team is going to reach out to the manufacturer and ask for their thoughts on this issue. Have you reached out to them regarding this?

Hi @nuwriy thanks for your reply. No, I didn’t contact the manufacturer. I just can try to ask the german distributor.

Dear @nuwriy, I tried different things right now and nothing works for me at all. I installed a seperate soundcard with SPDIF opt out and connect it directly to my Marantz AV8805. I see in the roon software all kind of devices / drivers but NO device is able to generate a playback except the “System output”… I don’t know why or rather why I can’t generate via ASIO or Realtek drivers. The soundcard is a ASUS Sonar XE 5.1. Thanks in advance!

Hello @Ralf_Schuchardt, could you do one more test for me and try ASIO4all and see if the issue persists? I’d also like you to try the following:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

If this continues to fail please reply here with a timestamp of when the issue repeated so I can get new diagnostics over to the team.

Dear @nuwriy, thank you very much for the information. This solutions helped me! Since there is a new RAAT Server folder, every device works properly. I have another question. This is OT. Is it possible to import .txt files to the roon eQ? DSpeaker creats a .txt file after the measurement which I can import into REW to see whats going on (before/after). Can I import the “after” file to the eQ? So I don’ need to to this manually. THX in advance!