Problems with Meridian 818

@ratbert @ncpl @viruskiller and others, suggestions for this problem?

I have recently been installing the SonicTransporter and the MicroRendu. And I had network problems, apparently caused by dodgy cabels (or the mysterious gremlins that live in my network). But it is now ok.

I can stream over wifi to the MS600s. And I can stream wired to the MicroRendu.

But the wired connection to the 818 does not work. (I nowadays use a switch, not direct-wired as before.) The 818 does not show up as a device in Roon. One other symptom: on both the switch and the 818 rear panel, only one of the lights next to the Ethernet jack lights up. I don’t know what that means, I’m sure I can find out, but it indicates something is not good. Same result with both the Windows NUC and the SonicTransporter.

I do have the 818 set up for static IP, I used that before I introduced the switch, but I can’t imagine that would be a problem. And the Windows NUC still has a static IP address.

Any ideas?

On a LAN port, one solid LED indicates a link has been established and the other flashing indicates data packet transfer.

The post on the ID41 is 100Mbs, make sure you switch (I assume it a 1Gbs) also supports 100Mbs.

I assume you have power cycled the 818.

Are you able to ping the 818?

Can the Sooloos config program (v30 now) find it?

I am able to direct a browser to it and see the configuration web site, so the connection is good.
Haven’t tried the config program.
I have power cycled.

Config program? Does it do IP? Thought it only did USB…

I checked again, and I cannot connect to the 818 config page when it is plugged into the switch.
But when I direct-connect the 818 to the NUC, and then RDP into the NUC over wifi, I can see it.
So the 818 is fine, it just doesn’t like the switch.
But the MicroRendu likes the switch, so the switch is good too.
And the cable is good.
Good point about 100 Mbps, the box only says gigabit, but I checked with Netgear and they say the switch can do 100.

@Carl And of course, when the 818 is direct-connected into the NUC, it shows up as an endpoint in Roon, while all the others are connected by wifi.
But that is not the answer, because I want to use the 818 with the SonicTransporter and it cannot be direct-connected to the 818, it needs to be connected to the switch because it doesn’t have built-in wifi.

Anyway, I’m not looking for a kludgy workaround. This problem should be solvable.

I wonder what will happen if I set the 818 back to DHCP. Then it probably needs to be connected to the switch, because the switch has an Eero connected and it should provide DHCP service. Hope that doesn’t lose all connectivity to the 818. Fingers crossed.

@ratbert @ncpl @viruskiller Solved. The problem was the static IP address when going into the switch. Set it to DHCP, lost the direct connection, plugged it into the switch and everything worked.

Every problem is trivial and obvious, once it is solved. Before that, it is incomprehensible.

Stupid stuff. The root cause is probably that I made too many changes at once, to the network and the servers and added endpoints. Know that is a bad idea.


1 Like

@ratbert @ncpl @viruskiller And by the way, I have had a problem recently where Roon wouldn’t turn on the 818 when I start playing. That also got solved. Seems as if the wakeup message didn’t like the direct connect through static IP. I could do more investigation, but I don’t really care. Works now, with a more normal connection.

Setting a Static IP on the Meridian Endpoints is never a good idea and tends to lead to several gremlins

A better approach IMHO is to

a) set the Endpoint to DHCP
b) use your Router to assign a ‘static’ IP to that device, and then Reboot your Router. This will ensure that your Endpoints are always assigned the same address at startup…best IMHO to assign it a number that is easy to remember, e.g. or or similar


Worked fine as long as the environment stayed the same. The Roon server and the 818 were not connected to a router, just a wire between them, wanted to isolate them from other traffic and changes. Very simple, very reliable. Roon behaving like a 1970s FM tuner. Static IP is a thing, works fine.

But as things became more complex, I did a more normal setup and that static address didn’t work. Gone now.

Hmm. I’ve not had problems with static IP addresses with any of my Meridian endpoints (ID40, ID41, MS200).

Using the Address Reservation page on many Routers is the recommended way to set up the Meridian Endpoints…and I would strongly encourage you to go that route

The issues with using the Meridian Endpoint’s Webpage to assign a Static IP go back to several years ago…usually manifesting with the Endpoint falling off the network…which as we know now, had much to do with the Networking stack employed by the Endpoints…and these issues have largely been solved by the most recent Firmware Updates on the Endpoints

After a discussion or 2 with Des, I felt it was better to go with the Router assigning the Static or Permanent IP to the Endpoint…and leaving the Endpoint setting as DHCP

Same result…just a different way of getting there

Hi Anders, quick question - how did you set the 818 to DHCP? I have the same problem with a static IP I used in the US on one of my 818’s, starting with and now in Europe with a new router, the addresses start with 192… Thanks, best

I don’t remember, it’s been a while.
But my memory is that I didn’t set it to anything, left everything to default.
And that includes my Eero mesh, what I love about Eero, no settings.
My addresses here (U.S.) are all 192…

Install the Meridian mcontrol application, in the device section it should find the 818 and then enable you to change it from static IP ZTO DHCP assigned IP.