Problems with moving database to a Linux Server [Solved]

I have been running Roon on Windows without problems. My Music Library is on a NAS.
With the introduction of v1.2 I have been wanting to run RoonServer on a Linux system (together with HQPlayer) and use my Windows PC as remote.
I managed to install RoonServer on Linux and my Win PC as remote (I had to “unauthorize” the original installation).
However, at this point my RoonServer had no database. So I followed the procedure in and moved my “Windows” database to Linux system (5 folders in the appropriate Linux directory).
I restarted RoonServer and started up RoonRemote on Win. Unfortunately, I get a message saying “Waiting for Remote Library - Roon is still trying to connect but it’s taking longer than normal…”
Thinking that perhaps it had to be rebuilt, I left it overnight but to no avail.
I have the option to “Select a Different Library” but it would defeat my purpose.

How can I see my database that I painstakingly tune-up?
Is there a difference in the way my NAS file paths were linked in the Windows database compared to how a Linux system wants to see them?*

  • The paths of my HQPlayer’s Windows database were slightly different from my Linux one.
  • First off make sure you have a backup of your windows database to go back to
  • Try the select a different library optoion and point it to the appropriate location
  • if that doesn’t work:
  • stop Roon Server running on the Linux box and the Windows box
  • copy the database across
  • delete RoonServer/Database/Registry/Storage/location_cifs_*
  • start Roon Server on Linux
  • point it to the new path housing your collection
  • it’ll scan the path and start matching the database contents to the files it finds

Thanks for your reply.
I did as you suggested, but I have some problems with the new path housing my collection.
I choose “Select a Different Database”. The system looks for a remote library.
Do I have to point to the NAS address or the imported database on my Linux box?
I have tried both:
a) my NAS is on
b) the imported database on the Linux box is at /var/roon/RoonServer/Database.

In both cases I get a message that either IP address or hostname are not valid.
What exactly do I have to write?

If your music is external to your Linux server I’d recommend you use NFS to mount the share on the server and you’d then point to the mountpoint as a local folder on the Linux Sever.

In order to do that you need to enable NFS shares on your NAS and note the path the NAS assigns to the music location. Then on your Linux server you create a folder inside /mnt like /mnt/nas and mount the nas share to this location.

As an example, the mount command you’d use from the Linux box would be something like: mkdir /mnt/nas sudo mount /mnt/nas

Ideally you’d want to use MAC address assignment in your router to ensure the NAS always has the same IP, then you can mount the share via /etc/fstab

Of course this could also be done using SAMBA but NFS will perform a lot better.

1 Like

I have my NAS mounted locally with SAMBA on /media/samba/Music.
I placed that path for scanning, but I still get error.

if you navigate to /media/samba/Music on the Linux server do you see any content?

Hi Evan,

An update on this issue.

Following the procedure in your first reply and remoting through an Android tablet, I managed to have the Linux box recognize my library, matching at the same time the old database contents (I think as it took only a couple of hours for over 50k tracks).

I think I was having problems because I tried to remote through my Windows box where the old database was resident. Indeed, now that the database is updated on the Linux box, if I try to use Win box as client, I cannot connect to the remote library on Linux. I think that perhaps this is due to the presence of the old Win database.

I suppose it is time to delete the old database and see if it solves the Windows client issue. Any thoughts on this?

I doubt it is due to network communication as I was able to see Linux box when its local database was empty.


You can just move the Windows folders to a new location as a backup if you’re reluctant to delete them. When you then fire up Roon in Windows it should prompt you for the role you want it to play, which will now be that of a remote.

This is exactly what happened. Once I deleted my old database, Windows box remotes perfectly Linux server/database.
I am now set :slight_smile:

1 Like

enjoy! :smiley: