Problems with MQA + DSP in Roon

Hi Dylan,
When playing around with the DSP settings this evening, came across an ‘odd’ (?) scenario.
I used the ‘speaker setup’ mode to see what it did and just using distance and listening, was able to achieve a better ‘centered’ soundstage. As I continued to listen to different tracks, with all different file types (AAC, CD, ALAC, FLAC, DSD, MQA) - it seemed like the MQA tracks were off. And sure enough, with speaker setup mode enabled, the final MQA Renderer from the PS Audio DS Jr DAC didn’t happen. Disable speaker setup; it comes back.
Any idea why that would happen?
The speaker setup filter is interesting; definitely helps with getting a more centered soundstage, but does also take something away. Hard to put into words.
Thought you might find this quirk interesting. Might be inherent in using the filter with MQA, but maybe something to investigate.

42%20PM Screen Shot 2019-10-11 at 9.25.42 PM
vs.39%20PM Screen Shot 2019-10-11 at 9.26.39 PM

Hi @Mark_Dabielski,

Do you mind if I move this last message over to the #support category? We try to do most of our support there so we can better help others who might have similar questions and issues in the future.

Can you share a screenshot of the settings used in the Zone above that resulted in the second screenshot?

Settings with ‘speaker setup’ enabled - final MQA rendering by PS DS Jr not happening.


For DSP settings;

Hi @Mark_Dabielski,

Generally, when MQA is used in Roon with DSP, Roon will engage the Core decoder and pass on the information to the audio device for final rendering. You can read more about this here:

This is a bit different when Speaker Setup is used since it introduces delay between the two speakers channels. I’m going to bring this to my meeting to confirm this behavior with the technical team later this week, but this is likely why you’re seeing this. I’ll follow up once I get more feedback from the team.

Don’t know if you have any more info on this but what I’ve been able to do with my setup is use the gain function in speaker setup along with the balance control on my DAC to get the soundstage more centered. Doing this allows MQA to be fully unfolded when playing that type of file.

Ok - now here’s a new issue. Just paid for lifetime Roon today and noticed this when playing MQA. The signal path shows everything is fine for MQA, but, the display on my PS Audio DS Jr does not show MQA decoding: any idea what would cause this?
Everything was fine until the 1.7 upgrade. This was the first chance I had to sit where the DAC is for a listen. Connected via network RJ45.
Checked all settings; tried changing a couple but still no MQA on the DAC display.


Hi @Mark_Dabielski — We’ve enabled diagnostics so the team can take a look. I’ll be sure to update you once I’ve received their feedback.

Hmm. the file you are sending is a 24/48 bit MQA file of an original 24/48 bit. It looks like you have Roon set to do the first unfold which will default 24/96. My guess is that since it is already at it’s highest output; there is nothing left to render. So it is just playing the 24/96 file.

You can test things by turning all DSP off (Volume Leveling and speaker settings), change the settings in Roon for the PS Jr. to Decoder and Renderer. Then the PS Jr. should be handling it all, and displaying MQA.

Hmm. Not sure that would be the issue as I made no changes prior to the 1.7 upgrade and with 1.6 - all MQA files would show on the PS display with MQA and the sample rate. I tried a higher rate file and the display now reads PCM/176, with no MQA display.
Whatever is causing this happened AFTER the 1.7 upgrade as I didn’t change any settings from 1.6
Here is what I’m using, same as 1.6 - MQA always showed on the PS Display.


I tried the test as you suggested: and the PS display showed MQA with DSP off - but that certainly won’t do for the longer term. If I can’t utilize DSP and still get MQA decoding, then something is still not right.

And using latest PS firmware; Windom.

Hi Dylan, any feedback on this issue?

Hi @Mark_Dabielski,

You have my sincere apologies for the delay here!

I spoke with the team on this to get some technical feedback about why this is happening. Currently, this is the expected behavior because of how MQA streams need to be handled. We have a ticket open with the team to investigate the possibility of changing things here, but I can’t make any guarantees or provide timelines about when a change would happen.

Sorry again for the delay here, Mark!

Hi Dylan,

Not sure why this is expected behaviour. All the settings in place are the same as were in Roon 1.6; and MQA processed correctly with MQA being displayed on the DS Jr.

So ‘something’ was already changed which caused this outcome - whether that is on the Roon side or PS Audio side. Given the 1.7 update, suspect on the Roon side. But I have no way in confirming that.

What is interesting is that the Signal Path on Roon indicates all is in order. It is just the display on the DS Jr. that shows Unk instead of MQA.

The marketing and technical specs from both sides claim the hardware and software ‘play nice’ together and will produce the desired audio output.

It (DSJ + Roon) was doing that, now it’s not. Major or minor issue - saying “can’t make any guarantees or provide timelines” doesn’t inspire confidence that the issue won’t end up in the box of stuff for shredding.

Having the financial investment do what it’s supposed to do is the goal.

If you need any additional screenshots, details, let me know. More than happy to try various settings, tests to see how to get this resolved. As a vinyl guy dipping into the digital processing world, a lot of this is still new and confusing.

It looks like the correct process is happening and what you are seeing is a display bug. On your screen shot of the PSjr displaying the PCM 176. It would only be such if the PSjr was doing the final rendering that is being passed to it from Roon.

Yes, that is how I have it set up. Roon does the first unfold and the DSJr does the final rendering. Which is exactly how it was with Roon 1.6 and then, the DSJr displayed MQA. Now it displays Unk. The Signal Path shows all is ok, so you may be correct, it could be a display bug.

In my thinking, if it wasn’t a display bug, then the PSjr would be reading 88.1 since the output of the first unfold is either, 88.2 or 96 (and in some rare occasions 48); never higher.

You may be correct; here is a screen shot of the signal path for an MQA file currently playing:
The DSJr display reads:

Yes. I can see how that could be disconcerting if you were expecting the final upsampling to 352.8 and it is only reading 176. However, the PS jr seems to be reporting to Roon (as in the signal path) that it is doing the correct upsampling.

Have you engage PS Audio support as well? The display issue might be on their end.

The lower 176 issue may be because the Roon Core is a network connection. I know with DSD the limit over the network is DSD64. I have been in contact with PS Audio about this as well. I’ve considered connecting my Roon Core (on a MacMini i7) directly via USB but the only realistic way, given that the length required is 50 ft, is with a glass fibre USB cable. The budget for all my new audio toys has already garnered the attention of my wonderful spouse, so frugality is the path for the next while. :slight_smile:

The current tune is another MQA track
and on this one the DSJr display reads 96
So…you might be on to something with the display bug idea.