Problems with playing on my Moon 280D "Audio Device Refused to switch input to Roon" [Resolved - New firmware update live]

Seems am not able to play Roon on my Moon 280D hence the audio device is not found or refused.
Sometimes starts to play with a lot of destortion. Crackling sound that might not be good for a system overall.

Could be that Moon made the update that it can play spotify. But am using tidal hifi.

please fix this ASAP. Want to prolonmg my subscribtion to a year but this is not the furst time Roon didnt work properly. Having doubts even after i spended a lot of money on a nuc and silent case with a liniear power supply.

Like have a problem free system and software. Thought it could be the dsd conversion but if i put out dsd conversion. I still wont play or just shuts down after a few songs.


Hi Tom,

I noticed a crackling issue a while back with DSD256 content.

It was solved by shutting down the Dac, unplugging the power from the unit and then plugging it back in.

Something to try.

Cheers, Greg

Hi Tom,
I’ve owned a 280D before, and now a 680D. Greg’s suggestion to power down the DAC and restart it is the best place to start. You can manually find your DAC on Roon. That’s what I did when I owned that unit. You may already know this, but your unit is not just a DAC, but an excellent streamer as well. That being said it should be your endpoint for Roon. You ideally should run an ethernet cable to the unit from your router. You shouldn’t need to have a usb cable plugged into the unit. This can sometimes lead to problems, as it may cause the unit to bypass the streamer. So your computer, nas, and 280D should all be wired to your router. Once I realized this, my problems were solved. Roon can be a bit challenging to set up initially unless you’re a computer person. But once it’s done correctly it’s usually problem free.

Hi Kevin and Greg! thank you for the tips. But all you guys suggest is already done.

My streamer is connected via ethernet cable. Why should I use USB… I dont see any reason for that.

I restarted all my systems. I guess it all happened after the update from moon itself adding Spotify. Not to sure… had the bug that it device would not be found a week or so. But not this wurse that my moon wouldnt even be found.

Hi Tom,
I wouldn’t suggest hooking a usb cable to the DAC at all. In your situation you have no use for one. There should be something that says find my device. Then it will bring up a list of brands. You select Moon, and then the actual model. If that doesn’t work, perhaps you have a bad ethernet cable? That’s about the limit of my knowledge. I’m still learning. There are several people on here that are experts on this sort of thing. You can try support in the menu on the left of your tablet screen. Keep me posted. It might prove helpful for me and others to learn what the solution to your problem is.

Hi Kevin,

Before I got the error " [Audio Device Refused to switch input to Roon] "as well

I opened up my moon app cleared the cache and disconnect it.
Rebooted my NuC and removed the Moon as an endpoint to Roon.

After that I restored it all. Mostly Roon will play okay for a few songs but after switching songs albums or whatever. Roon stops working…

Testing and still it doesnt work very frustrating I cant use Roon with my moon 280D

Seriously am i going to get any support here from Roon it self?
Moon 280D lways was roon ready and now it does not work anymore.

errors
Audio Device Refused to switch input to Roon
Roon losed control over the audio device

Rebooted nuc, Rebooted Moon 280
Cleared the cache on Roon and Moon 280
Rebooted routers, switches
Hardware discconected all ect…

is all i tried already

Maybe reporting this way maby will speed up things.

Read in another thread that the problem was related to a Moon software update and solved

@Mike_LC @BlackJack

My firmware is up to date and my nuc is always on. It’s in fanless housing and does not get warm at all.

Anyways! I mailed Moon and they directly contacted me and tested my problem at a dealer. The dealer had no problem. So I went to my dealer and gave my moon to be tested and the dealer gave me the same moon 280D to test at home. Until now i don’t have a problem… still tesing it. My guess and the dealer guess its the firmware update that went wrong… Think they test it for few days and comeback to me. Mostlikely they will reset my moon on hardware base. I dont like to do that. Had some bad experience with reseting my self.

So Moon and my dealer are working on it, but roon it self dont do anything. No respons or tips. Its good that the roon communitie is great!

Make still doubt to stick with roon it self.

Hi @Tom_Harskamp

Can you give some details about your Core and network?

Please also provide the following:

  • Can you share a screenshot of Device Setup and DSP settings for this device?
  • When it is playing, can you share a screenshot of the Signal Path that you see?
  • Are other endpoints working okay?

@dylan

Can you give some details about your Core and network?

Please also provide the following:

  • Can you share a screenshot of Device Setup and DSP settings for this device?
    *** DSP upsampling to DSD is most likely the problem. I turned of and had not much of a problem. Still testing.

  • When it is playing, can you share a screenshot of the Signal Path that you see?

  • Are other endpoints working okay?
    Yes only have 1 endpoint and that is my main PC where i have a desktop setup for my headphone.

I have disabled DSP so no DSD is running seems I had no problems without DSD. DSD also is crackling sometimes.

My network is the main router provided by my internet provider. I have nuc on the router. My router is connected to a media converter from copper to fiber. That fiber cable goes to a Meraki that converts it back to copper. The Meraki switch is connected to my streamer. This was never a problem.

regards

I have had a few problems with various Moon MiND devices after firmware updates (Crackling on DSD256, and inability to turn the device on and off through Roon).

Moon support said to make sure to shut off the power to the device using the rocker switch on the back panel of the device, and LEAVE IT OFF FOR AT LEAST A FULL MINUTE.

I was convinced that the full minute part was BS, but sure enough, that has always solved the problem.

Give that a try, nothing to lose :slight_smile:

Had same issues with moon 280d.What fixed for me was to turn power off with rocker switch in back.Pull power cord and ethernet cable from moon 280.Then plug all back in.

1 Like

Jason P,
You go through that whole process every time the problem occurs, or was it only a one time occurrence for you? I can find no pattern that “causes” this issue and no pattern to resolving it. It’s always a constant process of trial and error (similar to your process) and lo and behold after 3 or 4 attempts everything starts working just fine. One very knowledgeable audio engineer I know suggested that its
related to a “handshake” that Roon has to make with the network player and if they “miss” each other,
then that creates the error we’ve been getting. He suggested making sure the network player/DAC and my core were connected into the same switch, which I did, but that hasn’t improved the problem at all with my Ayon S-10II.

Am testing the problem with another unit from moon. Seems to be the dsd that is not working after the patch. Moon and me and roon dont know were the issue is. Is it in roon or in the moon. My guess its the moon patch. Hence they added Spotify… still waiting on a reply from moon to confirm. But guessing that will take some time for them.

Atleast they are on it.

So it appears to likely be a Moon problem but you are still angry at Roon?

Does not seem very fair🤔

My 280d just did a Mind Module update now having same issues as you in your first post.Hope Moon finds fix.

Can you go back to the previous firmware? Is there a way to factory reset it or initialize the settings again?

No can’t go back

I have asked this question before but not got an answer. For any Roon Ready certified equipment, does a new firmware release also go through to Roon for re-certification, or are manufacturers allowed a free hand once initial Roon Ready certification is granted?

1 Like