Problems with Roon playing to Linn Majik DSM

Core Machine (Operating system/System info/Roon build number)

Windows 10 laptop, with music library on a USB memory stick in the laptop (no NAS)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Spectrum cable modem, Google WiFi router, Netgear unmanaged switch downstream of router. Both Roon Core and Linn are on same subnet ( and connected via Ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Majik DSM on latest version of Linn software

Problem description

Just moved and hooked everything up. I have both a Linn Majik DSM and a BluSound streamer, and have connected Roon to both in the past successfully, though it’s been a while on the Linn. When I tried to play music, the following happened:

  1. My library and Tidal both come up in the Roon app (and I tried both on the iOS app and Windows). Can browse the library just fine.
  2. When I go to play from either Tidal or my library, the music never starts playing. It seems to try for a while, then I see a “too many failures” error message.

Please help, thanks.

Hi @John_H_Sea,

If you play local content to System Output of the Windows machine do you see the same behavior?

No, music plays successfully to my Windows laptop, both from my library and Tidal.

And my Linn is able to play music using its proprietary app (Kazoo) from my library and Tidal as well, plus the Linn is visible on my network when I go into network management. So the Linn can see the local network + Internet successfully.

Make sure you are on the latest linn firmware update, others have had issues that have gone away after updating.

Thanks Ged, confirmed no updates available. Other ideas?

Yep, you are on the latest Linn firmware.

When you go to Roon >> Settings >> Audio, do you see your Majik as “enabled” via Linn Streaming? Should look something like this:

Also, try to reboot your Majik if you have not done so already.

As one of those “others” yes, I’ve had some improvement since the latest update, but not 100%. Both on my Klimax system and on my Selekt/Akubarik one, I’m still getting occasionally the “stop 1-2s before end of album” problem that has happened now and then for the last year, with different DSM and Roon releases. Looking at Roon Core logs, what you see is a repeated sequence of attempts to play the last 1-2 seconds, nothing happens on the Linn system, but Roon still thinks the track is playing. My suspicion is that there’s a race condition between Roon and DSM where DSM believes they are done with a track and informed the source, while Roon still believes that last 1-2s is to be played and keeps sending it to DSM.

Sorry @Fernando_Pereira I couldn’t find your post at the time.

Already rebooted the Majik a couple times. Will look at the Audio settings tonight to make sure they appear as you showed in the screenshot.

Hi @John_H_Sea,

Are you on the correct subnet for Linn streaming? I would check your Roon Settings -> Setup -> Subnet for Linn Streaming setting.

Catching up on two questions:

  1. How does the Linn appear in Roon? It’s enabled via Roon streaming.

  2. Settings for “Subnet for Linn Streaming”? Looks correct - Linn IP address and subnet setting are lining up with the Roon setting. And I only have one subnet in my network design -

Other ideas? You all want to enable logging and then have me try again to play music?


1 Like

Hey all - a week since last response. What else can you think of to try?

Hi @John_H_Sea,

Thank you for the information and apologies for the delay in getting back to you here due to the holidays. I’ve just enabled diagnostics mode for your Core and I can confirm that a log set was delivered to our servers.

I believe I located an relevant error trace here and I’ve requested additional feedback from our technical team. It may take a bit longer than expected for them to review this due to the holidays, but once that’s been done we’ll reach out again. Thank you and Happy Holidays!

I had this problem for a long time with my previous configuration which had Linn Akurate DSM connected to Windows 10 core. I even bought new NIC to my PC (Intel I210) and disabled the integrated NIC on motherboard. I was able to make it quite stable but always when you update NIC drivers, problems might still appear. I still use the same ADSM but now with QNAP NAS running the core and I’ve had zero problems with this configuration.

Anyway, you should try to fiddle with advanced NIC settings. You can find these by right clicking My Computer on desktop -> Manage -> Device Manager -> Network adapters. From there, select your network adapter, right click and open Properties. Now navigate to Advanced tab.

From there, disable all power saving features like Green Ethernet and Energy Efficient Ethernet. I also disabled Interrupt Moderation and raised the Receive and Transmit buffer values. This helped for me but I can’t say for sure it will help for you, give it a try.

1 Like

@noris, thanks for the reply and no worries on timing. The thread went dark and wanted to make sure my issue didn’t fall through the cracks. I run a tech support team in my day job and understand holiday coverage, appreciate all you folks do. :sunglasses:

Thanks for the idea @patouskii - I will give this a try if the Roon folks don’t find any smoking guns but don’t have high hopes. FWIW, the core I’m using is one of our old laptops. We just moved and I used the same core in our old place with no problems. My core is connected to the streamer via a Gigabit switch downstream of the WiFi router in both the old and new home, with no changes to the core’s NIC configuration. My clients (another Win 10 laptop and an iPhone) both see the core just fine too.

1 Like

@noris, any update on your end after logging was enabled? I’ve tried to play tracks once (unsuccessfully again) since you all turned on logging so hopefully you have some data to look at.

1 Like

Hi @John_H_Sea,

Happy New Year! I see that you case is still pending some feedback from our technical team, apologies for the delay due to the holiday queue, I will ping the team and I hope to have some feedback here for you in the next few days. Thanks for your patience!

Trying to not be annoying but it’s been 12 days with no update. What’s going on? I’m getting no value right now out of my lifetime subscription - was happy previously when it was working but such slow support is not acceptable.

Did you try to fiddle with the NIC advanced settings?

I wouldn’t hold my breath with a fix from Roon/Linn. I had similar problem two years ago and I made ticket about it but nothing could ever be fixed. At that point there was already few threads describing the problems with Linn streaming. Mine was that playback stops after 2-3 tracks played and/or 1-2 seconds before track ends.