Problems with Sonos

Core Machine (Operating system/System info/Roon build number)


Roon Nucleus
Version 1.7
RoonOS Version - 10 (build 186)
Hardware SN - 54B2038CFEA2
Vendor - Roon Labs
Hardware Model - Nucleus
OS Version - Firmware 1.0 (build 186)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired Ethernet connection: connected to Ubiquiti Switch S-48-POE-750W, running via Cat5e cables throughout house

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

For whole-house audio, playing via Sonos Connect Zoneplayer (modern product, purchased in 2020), which is also connected to the Ubiquiti 48-port Switch. The Sonos is then connected as an RCA input into a Denon Heos Drive HS2, one of three Heos HS2 Drives which control the twelve wired pairs of speakers throughout the house. For the media room, Roon plays via a Lumin U1 Mini.

Description Of Issue

I fell in love with Roon almost instantly and purchased a lifetime subscription about two months ago. I use it both with my full-house wired sound system (the speakers are powered by three Denon Heos HS2 drives with a Sonos Connect Zoneplayer (a modern device) as an input. The Sonos and Roon Nucleus are both connected to a 48-port Ubiquiti Unifi switch which anchors my wired home network). Everything worked like a dream until about three weeks ago, when suddenly I could no longer play anything from Roon via the Sonos. I normally control Roon from my Android phone app, and when I try to play something everything looks fine visually on the app: the “play” button changes to the “pause” button, the timing indicator starts to move, and visually it looks like it should (no error messages or anything). The Heos and Sonos systems both seem to be working fine: for example, I can play music from Tidal if I select it from the Sonos app, but when I try to have Roon play something from Tidal via Sonos, I get no sound. I have tried removing disabling and re-enabling Sonos in the Roon app, and I have tried uninstalling and re-installing the Roon app, and I have power cycled my Nucleus, all to no avail.

Interestingly, I CAN play things via Roon if I play it through another device such as my phone or the Lumin player in my media room. But when I try to play Roon through Sonos, it no longer works. The Sonos Connect Zoneplayer is NOT one of the Sonos pieces that is no longer being supported, either. (I do have a few “legacy” Sonos devices, but I no longer use them.) Also, I have the problem whether I am trying to play from Tidal or from tracks in my own library.

This is quite frustrating because I have no idea what the problem is and everything worked beautifully for the first few weeks! I would really appreciate any help you can offer.

Three weeks ago Sonos released new firmware. By default Sonos is updated automatically. Try finding your Sonos firmware version.

Here is the information I have on the Sonos Connect Zoneplayer:
Version: 11.0 :(build 55174250)
Hardware Version:
Series ID: C100

Does that help? Have other people had problems with Sonos after a new firmware release?

Sorry if this is something you’re already aware of, but worth pointing out that a firmware update to Sonos devices sometimes causes duplicate IP addresses which can result in the kind of behaviour you described in your original post. This can normally be cured by re-booting your router and then the Sonos devices in your network.

1 Like

That fixed the problem! I rebooted both my gateway and switch, then the Sonos Zoneplayer. I then had to reboot (power off and on) the Roon Nucleus to get it to work again, but we’re back in business. Thank you!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.