Problems with Tidal Playback

I have been using Roon with Tidal successfully for over a year and never had any problems. Over the last couple of months however I’ve been having problems (i) getting logged out of my tidal account in roon (ii) having tracks skip with messages like “this track is currently not available from Tidal”, “too many failures stopping playback”, “network error in accessing this album. Please check internet and try again”. My setup is Roon Core on Macbook Pro running on Mac OS High Sierra connecting to Auralic Vega G1. I’ve now moved away from using Roon to using the Lightning DS app from Auralic which works perfectly - a real shame as I love the other features of Roon. I have tried moving my Cache files and moving to the Google DNS service as recommended in other strings but these have not worked. Help please!


I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

2 posts were split to a new topic: I get tons of Tidal unavailable errors

thanks Carl - i have two systems set up and have the same problem on both:

  1. Roon Core on Macbook Pro (15 inch 2017) running MacOS High Sierra Version 10.13.6 connecting wirelessly with Roon Ready Endpoint - Auralic Vega G1;
  2. Same Core setup as 1), with ethernet connection to network and connected to QNAP NAS (music library) and with Sonos Play 1, Playbar.

I have tried clearing my Cache as advised and also using Google DNS. Neither works.

David, just FYI since you started topic : I get tons of Tidal unavailable errors

Hello @David_Sutton1, can you elaborate on your network setup for me?

Thanks - what else can I elaborate on? Thanks for your reply.

thanks Nicolaas yes I am following - good luck!

Hello @David_Sutton1, I wanted to know what router you have, if there are any switches, etc.

Ok got it. On my first set up with the Auralic Vega endpoint that device is connected directly to a sky broadband router via Ethernet cable. The Core on my macbook is on wireless.

My other Sonos setup is all wired with Ethernet cable and a gigabit switch.

Same problems occur with both setups.

Hi there again - the router in my Sonos set up in a Linksys high end model. The router in my Auralic set up is provided by Sky Broadband (UK) - not sure OEM.
hope this helps - thanks

Hello @David_Sutton1, any luck if you temporarily lower streaming quality under Settings>Services? How about playing to system output? Let’s narrow the issue down to either an endpoint or if its a connection issue.

thanks for the suggestion but now I can’t even log into Tidal through Roon. Perhaps I need to do a complete reinstall?

Hello @David_Sutton1, I just spoke with another customer having a similar issue where changing to Google or Cloudflare DNS helped him log in. Please give that a try and see if you’re able to access the account.

Hi - I had already changed to DNS to Google and think I already mentioned this - thanks

Yup, Roon supports keeps blaming DNS when it’s clearly not.

FYI Roon, you own log files proves this:

Yesterday I broke my DNS on purpose to test. Logs clearly showed DNS issue:
[easyhttp] [1] Get web exception without response: : System.Net.WebException: Error: NameResolutionFailure

Most of the dozens of log files I shared by now shows sockets being disconnected.

08/10 23:53:06 Critical: [easyhttp] [97] Get web exception without response: : System.Net.WebException: Error: SecureChannelFailure (Unable to write data to the transport connection: The socket is not connected.) —> System.IO.IOException: Unable to write data to the transport connection: The socket is not connected. —> System.Net.Sockets.SocketException: The socket is not connected

Stop blaming DNS!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.