Problems with USB connection for Roon and Devialet (Mac)


I have Roon Core installed on a Mac Mini. I usually access the Mini through screen sharing via an iMac (which has Roon installed as well) but it’s also connected via HDMI cable to a tv so I can work on it direct if necessary. The Mini is connected to a Devialet 120 amplifier using a USB cable.

Ordinarily the problem isn’t a nuisance because I can avoid it by playing Roon through the Devialet via an ethernet cable, but at the moment I’m using ethernet to connect the Mini to a backup hard drive. Although, even when there’s an ethernet cable running to the Devialet, the same problem occurs if I try to use the USB pathway to play Roon.

The glitch is this: when I choose “Devialet USB 2.0 Audio” in Audio Midi/Roon the option is highlighted for sound output but the moment I hit “play” for a Roon track there’s no sound because the Audio Midi selection switches to the HDMI option. Nothing I’ve found or tried in terms of set up options or preferences in Roon or the Audio Midi makes any difference. The defaulting to HDMI is automatic and immediate and can’t be changed while Roon is playing.

I’m certain that the technology is much smarter than I, so I’d appreciate it if someone can tell me what it is that I’m doing wrong or what else I need to do.

Don’t know about the HDMI issue but a quick fix would be a cheap switch, so you can have the Mac mini on the network so it can connect to the 120 and the backup disk.

Thanks Steve. In the meantime I tried starting Roon from an iPad and for some reason it works perfectly well and the USB selection holds even when I change to using Roon on the iMac. I don’t know whether this will last but I have my fingers crossed. I’ll look at the switch possibility if things revert. Cheers

Hello @Bartleby,

The reason you are seeing the switch happen in Audio MIDI Setup when you start playback in Roon is because the Devialet is becoming unavailable to the operating system to use. Assuming you have “Exclusive Mode” enabled on Devialet zone.


Yes, John, I do.

Hello @Bartleby,

I apologize for the delay in getting back to you, I’ve been waiting for some feedback from the tech team regarding USB playback to Devialet devices on MacOS. Using an Expert 220 Pro, they were not able to reproduce the symptoms you are seeing insofar as not getting any output from Roon when using the “Devialet USB 2.0 Audio” driver on MacOS.

Have you updated the Devialet to the latest firmware? Are you able to get sound out of the Devialet using the USB output from other applications on your Mac? Have you found another solution?


Maybe I need to buy an LE220 Pro:roll_eyes:

I tried Steve’s suggestion of a switch and the whole system collapsed, i.e. nothing could find anything else on the network so I put a Netgear R7000 in bridge mode to connect Mac Mini, Devialet and NAS (I’d previously used an Apple Airport Time Capsule - and everything was fine – but the Apple network has had difficulty with our new modem so I can’t go back to that. It’s taken me a while to get some things working. Had no problem with USB but Ethernet remains useless. Unfortunately this morning the same issue (Audio Midi defaulting to HDMI) has returned.

I did a screen grab to illustrate but can’t see a way to attach it here.

Hello @Bartleby,

To attach a picture, you can click the “upload” button (rectangle with upward arrow) located in the toolbar above the text entry field.

Now that you’re back up and running, are you able to get sound out of the Devialet using the USB output from other applications on your Mac? This will determine where in your system we should be troubleshooting.


Not sure what’s going on anymore since the problem is now a bit different to before. Using USB, whether with ROON or other programs (Audirvana, Amarra) and selecting Devialet USB for sound output in the Apple Audio Midi still results in defaulting to HDMI as output as soon as something is played but the sound streams to the amplifier anyway. This is what it looks like in ROON:

So I’ve gone back to using the ethernet connection, which has meant some rejigging of my network. I’m assuming that the USB problem has to do with the Audio Midi itself rather than ROON or the amplifier. Maybe a recent upgrade has introduced some quirk.

A post was split to a new topic: Issue with Mac mini and PS Audio USB