Procedural EQ broken

Roon Core Machine

ROCK / NUC8i3 / Serial #1C697A03FBE1

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

in the Procedural EQ, when adding a new filter using iPad, there is no more possibility to specify the target channel, Left or Right, as used to be in the past.
As the tablet is the main, I believe for most Roon users, interface, and as I’m far from my computer (I use Roon rock) this missed feature, very important to me, means, in practice, that the Procedural EQ is broken
I’ve updated right now with the very last software update but nothing changed… and this trouble is not a news for you as I’ve seen at least one another post dated some moths ago about exactly the same problem.
So what can I do, or better what/when are you going to do to fix this problem?

Please let me know, I need to use it but is broken.

You need to click on: + Add operation

(Some issues in B1021 with black boxes instead of graphics).

I saw you pointed to iPAD. Did not see this initally, sorry :slight_smile:
You can not change settings for filters on iPhone at least, but you can activate/deactivate a specific filter. Use Windows, macOS or Linux Roon remote and you should be good. Don’t see this as broken functionality, more like a limitation of available screen-estate.

what do you mean with “don’t see this as broken functionality”?
did you try before reply to add a new filter in Procedural EQ via IPad ?
Where is the setting to define left… right… center… ?
Here is a screenshot from my interface

NO WAY to define the channel!… this is not just a

but a real problem as I can’t use this functionality, as it was in the past, via IPad driving Roon Rock! … are you joking???

I clearly specified I’m with Rock via IPad, as is from the beginning, did you read my post before reply?

please explain, step by step, the procedure to define a filter under procedural EQ for only one channel … if is not possible then the interface is BROKEN and I can’t fully use as usual what I’m paying for

I do hope to read you in short time with help or solution, thank you in advance!

The person you are ranting at is just a Roon user like yourself, trying to help you. So wind it in a bit.


Please beware, most people on this forum are just users of Roon, trying to help.

1 Like

Hey @Paolo_C

Please try to contain yourself and behave in a less confrontational manner in these forums – especially when asking for help.

As for your problem: you have expanded the graphic to full width – in this view channel information is not shown. Just press the little purple arrow pointing right, next to ‘Filtro’ underneath the Procedural EQ icon + heading to collapse and show the channels.

Here’s my iPad in both views:

1 Like

I thought he was from tech support, thanks to him for trying to helping me

Hello René,

So… from this

I add a new filter

and this is the filter

Then I press the purple arrow close to filtro and this is what happen

Pushing the purple arrow just drive me back without any possibility to select channels or other options…

Now, asking very gently, do you think it is broken?

I tried very carefully many times to obtain something different from the purple arrow… but no way… in the past was not so


P.S. the iPad updated itself few minutes ago but no way, situation unchanged.

Interesting. What iPad is this?

I can replicate the screens you’re seeing when using the iPad in portrait, since there’s just not enough horizontal space to render the screen. When I add Procedural EQ filters in landscape though, it all works just dandy – trying on an iPad Pro 12,9, iPad Pro 10,5 and iPad mini 6.

this one, always the same from my beginning with Rock… and I never had this problem, I’ve done/tried many different setting in the past, more the 30 probably, without facing this issue… never

I see this on iPad Mini 6 in portrait…

the same here

That appears to be a 2021 ‘regular’ iPad:

  • Retina display
  • 10.2-inch (diagonal) LED-backlit Multi-Touch display with IPS technology
  • 2160-by-1620-pixel resolution at 264 pixels per inch (ppi)

Is that correct? And can you please confirm that you are using the device in landscape mode when trying to add the Procedural EQ filters? I will flag Roon @support here for follow-up, in case the interface is not rendering well on that particular model.

And this when I click “Show All Channels.”

to be honest I would like to be able to reply to your first and 2nd question but… unluckily IPad is not as windows, the device description must be a military secret that I’m unable to discover … maybe this?

about “landscape”… if it means horizontal mode, yes is how I’m using it

edit: here they are at Support Apple.

not here unluckily … here is in vertical mode

and the purple arrow remain not useful (as described above)

Yes – that confirms it is a 2019 regular iPad, with the screen specs I posted above. I don’t have an iPad of that screen size to test – over to support, I’m afraid.

Well …. let’s wait for support, my target is to solve the problem… with an open ticket I’m fine, the pad is only 2 years old so I’m sure there will be a solution

Here’s my iPad 8th Gen…