Profil and password request on \\rock\data

I just have had an issue on the database on Rock, I have to reset the databse after that I have to install again the codec. I have an issue when I try to share on windows \rock\data because it ask a profil and password?? How I can solve this issue.

you can use user ‘guest’ with no password I think.

1 Like

Unfortunately it doesn’t work, I’m restoring a backup done some weeks ago I hope it will restore thecodec :slight_smile:

What are you accessing your rock with? Is it windows 10? Because if it is, then you may need to enter your windows username and password when it asks for permission to access the rock. I’ve had to do this several times with my mapped network drives (one of which is my ROCK\data\ drive). Windows seems to forget the login periodically either due to Windoes updates or some sort of “timeout” on the login for security?

I need to reach \rock\data to copy the ffmpeg codec which are needed when you reset the database and configuration of roon after getting an issue.
I tried also my windows (Windows 10) account, it doesn’t work.

Can you access the rock web interface? And does that show that codecs are missing?

Hi Yes the web access works perfectly.

Does it have a message saying codecs are missing? If it doesn’t, they aren’t.

Yes exactly I know it’s because I try to reach the share \rock\data to copy the appropriate codec on the disk. Unfortunately I have this message asking a profil and password when i try to connect this share on my computer on windows 10.

guest for both user and password works for me when I have to access it from Nas. I think there is a securely setting somewhere in Windows you have to turn off. I had this on my old laptop but can remind me what I changed. Just got a new laptop and not tried it yet. Have you enabled smb1 on the machine that also need to happen as its off by default.

Have you tried “map network drive” on the Win10 machine?
Under “This PC” in Windows Explorer.
then enter the “\rock\data” (I notice in the posts you are only putting one “” before rock)
If it asks for you to enter network credentials it is your Microsoft account login info as far as I know.
This worked for me. YMMV and all that.

As a note to the one that mentioned SMB1, I do not have it enabled and it is working for me.
But if you want to give it a try (do this at your own risk, low risk, but it is on you):

I also just recently set-up my new HP laptop and this worked for me. SMB is not enabled on it either. I know I have fought with this in the past but eventually it worked.

Do you have another PC or tablet? People in the past have had similar problems and for some reason using a different machine has worked.

In addition to setting SMB1 that @bearFNF suggested, you should also try this if it still is not working: Allow guest access to remote storage

Hi Rugby Sorry but I don’t find this option on local Group Policy settings, is it because the option you gave to me is only on a domain Group policy?

At the end I succeeded to copy the files because I used an other computer where the update of Windows 10 isn’t done ;-).
For the guys who have the last update of windows 10 have the same error I get?
Also I have a huge database and I’m using 3 NAS with 12TO of disk space (I have already two full). I avoid to restart my NUC and I only stop the roon software server because I notice that there is a lot of unstability when I restart my NUC specially if I have a power cut. It’s not the fist time I have to rebuilt all my database? Are you aware of that?

Well, I run Windows 10 Pro or better. If you are on the home version, then I think you have to do a Registry Change to get to the same effect.

I do have several machines all running Win 10 Pro v1909 and all of them can see and get to the Rock storage share where the Codecs live, without any issue.

Latest windows 10 on my new surface laptop and all works fine to my rock, did not have to change a thing. Really like this laptop, apart from the matte blackness is a dust and fingerprint magnet.

I have added again a share of my NAS to scan again my volume but unfortunately it seems that even after reset the database I still can’t create again my library. How I can solve this issue as the database volume seems to be corrupted ? If I can avoid to install again all the system from scratch it will be great.
Thanks all for your advice

Adding too this as I just ran into the same issue… I couldn’t see \ROCK\ at all to begin with from my windows machine. Verified I had SMB 1.0 turned on but no dice. After some digging I realized that I was using my company laptop and SMB was being blocked by policy. Switched to my personal laptop and ran into the password prompt. Using “guest” for both username & password gave me access.

1 Like

This worked for me, thank you!