PS Audio DAC, grouped playback, high-res MQA problem

So I’ve got a repeatable issue that I’m hoping someone can help me with. I run a couple different Roon setups, and really love it. In this setup, I’m using a beefy Mac Mini to run Roon Core, with a wired Ethernet connection. My music resides on a Synology server, connected via wired Ethernet. I normally use as many as 3 endpoints, which are:

  1. Devialet Dialog connected directly to the Mac mini via Optical (driving a pair of Devialet Phantoms), configured as “Built-in Output” rather than “System Output”. It has a 96kHz upper limit.
  2. Bluesound Flex connected via WiFi, a Roon Ready endpoint
  3. PS Audio DirectStream DAC connected via wired Ethernet (via the Bridge II), also a Roon Ready endpoint

The DS does full MQA decoding and rendering in the latest firmware (which I have). The Devialet doesn’t do MQA, so it’s configured to have the Core convert to PCM.

The repeatable problem seems to happen when I have grouped playback that includes the Devialet and the DS DAC (whether the BlueSound is included in the grouping seems not to matter, and the BlueSound and Devialet don’t seem to have a problem without the DS), and when I’m playing a high-bitrate MQA song from Tidal. I’ll use Yes “Close to the Edge” as an example (it reports as FLAC 48kHz 24 bit, MQA 192kHz).

If I play separately to either the DS or the Devialet, behavior is as expected. The DS reports it’s getting 192kHz MQA when getting played by itself. The Devialet stream alone gets converted to 96/24, and plays fine. If I group them, Roon signal path reports it is sending the DS 96/24 with MQA signaling (Lossless of course). I assume that sending 96/24 instead of 192/24 has to do with grouping rules. But the problem is that the DS still thinks its getting 192/24 instead of 96/24 (that’s what is reported on the front panel). While in this state, playback is terrible (lots of dropouts), and eventually I get the dreaded message about Tidal content loading too slowly before cascading failures. If I do this for more than a few seconds, the DS itself needs to be rebooted because it’s completely unresponsive.

I can repeat this indefinitely with any of my MQA sources over 96kHz. I haven’t tried all permutations of MQA sources, but if I do a 96kHz source, the grouped behavior is still wonky. In this case, the DS reports its getting 96/16 even though Roon reports the signal path as 96/24. And it fails completely after a few seconds.

So it seems that grouping endpoints that have different MQA capabilities can result in the DS being confused about what the stream actually is. I obviously can’t tell if it’s a DS problem or a Roon problem, but figured I’d start here.

I have also tried different configurations for MQA on the DS (none, renderer, decoder, both), and that doesn’t seem to change things. But those were just quick tests so I’m not positive there’s not something buried in there.

Anyway, thanks for any insights you might have!


Here are screenshots of the Signal path in various configurations:
DS Playing by itself:

When grouped, here are the DS and the Devialet:


This issue with grouped MQA playback may be a related problem.

Sounds likely. Maybe this will help them track it down.

Hello @David_Roberts,

Thanks for the detailed report, it’s always helpful to speed up the troubleshooting process.

The next time you encounter this behavior, could you please note the time (local) that it occurs and reply to this thread with that information. I will then be able to enable diagnostics on your account and request Roon logs for this time-period.


Hello @David_Roberts,

Could you check what version of the PS Audio Network Bridge II firmware you are running? The most current version is V3.6.2. Firmware V3.6.2 included fixes for dropouts and distortions when playing Core Decoded MQA streams, which is the exact scenario triggered by grouped MQA playback.


Hi John,

My Bridge II is somehow not updating firmware, so I’ve contacted PS Audio to see if they can help. It reports that no upgrade is available, but it’s running 3.5.1. I will let you know if the problem persists after I get the update.



Hello @David_Roberts,

According to PS Audio, they took down the V3.6.2 firmware update due to an issue with incorrect album art being shown on the display. According to the latest update from PS Audio, they are currently testing a new firmware that will resolve this issue, as well as the MQA playback issue that was fixed in V3.6.2.


Cool. I’ll keep an eye out for new updates from them.