PS Audio DirectStream MK2 DAC not found

Roon Core Machine

432 EVO core music server.

Networking Gear & Setup Details

Connected Audio Devices

PS Audio DirectStream MK2 DAC

Number of Tracks in Library

Description of Issue

Hi, I’ve just bought the new PS Audio DirectStream MK2 DAC which I’m trying to connect to my 432 EVO core that USB has a green light Internet is connected but when I open the Roon app cannot find PS Audio.

Can you please help me thanks.

Hi @Mark_Pielage could you give a few details about the core software, whether you’re running ROCK or not and the operating system if you’re not running ROCK. Presumably you’re hooking the DAC straight to the core via USB?

Thanks.

He’s not running ROCK. He’s using an 432 EVO Aeon Music Server.

@Mark_Pielage - can you post a screenshot of Roon’s Settings > Audio screen, showing the “Connected to Core” section?

1 Like

Ahhhh, good catch @Geoff_Coupe I assumed it was some sort of mini PC affair that I’d not heard of. I’ll leave this in your more capable thanks.

Hi yes I’m running to that USB straight to the streamer thanks

Was the PS Audio DAC powered on and connected when you made this screenshot?

Oh yes, it’s all plugged in. Turned on nothing shows up in room as far as USB connections
I had the earlier version PS audios dac that no worries as soon as I plug the new one in what is, couldn’t get the recognize the matter how many times I rebooted and recheck the settings maybe there’s a driver issue

Paging @wklie - have you any thoughts as to why the PS Audio DirectStream MK2 DAC is not showing up in Roon’s Settings > Audio page? Thanks.

I have not received any Lumin user report about using this DAC so far.

I suggest:

  • Changing the DAC input to something else, then to USB
  • Disconnect the USB cable. Reboot the Roon Core, power cycle the DAC. After both are booted up, reconnect the USB cable.
  • Use a USB computer printer cable instead.
  • If you have a computer, verify the USB DAC operation with the computer first (not necessarily using Roon). If that works, install Roon there and transfer the Core temporarily, and check whether Roon on the computer can see the DAC. If you don’t have a computer, see if you can get a cable to connect it to your smartphone.
1 Like

Further findings from 2500 posts across two threads.

  1. Someone with Roon Nucleus confirmed USB to work.

  2. If your firmware is older than 2.3.3 with FPGA 119, you need to upgrade its firmware(s). If I’m reading it correctly, It appears you will need to ask for it in e-mail since they are not on public download page.

  3. FPGA 113 had known issues with switching input.

  4. Auto input select vs manual input select may make a difference.

  5. There were some beta units that need to be sent back to be reworked.

2 Likes

Hi thanks yes I plugged in my MAC laptop and Roon worked fine
So I unplugged it connected it to my 432evo and Roon couldn’t discover it
Even though the evo does I’ve been through the settings 50 million time :face_with_spiral_eyes:still no joy is there any way to reset Roon so it doesn’t hold my previous settings start afresh then it might search for new divides
Thanks for your help

  1. Verify your DAC is using the latest firmwares.

  2. There should be different USB ports from the 432 EVO. Try each of them, especially the normal USB 2.0 ports that are NOT marked for USB DAC.

  3. Have you tried a normal non-audiophile computer USB printer cable?

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.