QNAP Can't get QPKG to Open

I’ve been trying to troubleshoot QNAP install with no luck so far.
I’ve tried multiple reinstalls, manual qpkg installs with no avail.

Everything seems to be installing fine until I’m trying to get RoonServer configured.

Whenever I’m trying to open RoonServer from QNAP I’m getting Internal Server Error:

Hardware is TS-1283 XU-RP on Firmware

Moved to support area.

Hi @Yuzu
Could you send me the address of your browser’s addressbar when you access your QNAP web administration? (a private message is also ok, if you don’t want to share it publicly).
If you did not open the web interface by its IP address, please try, if that changes anything.

I access my QNAP via local IPv4 IP

Which in my case resolves to:

Not using SSL or using local domain name doesn’t change a thing in this case.

I’ve temporarily worked around the issue by manually installing the server to test whatever it will boot, and it does just fine. Still have to figure out how to set up a deamon for it if I want to continue using it ( the shell script doesn’t really work well on QNAP )

Would still prefer to have it QNAP PKG way tho…

I am curious whatever access/error logs can be found somewhere to see what’s actually the root cause of the error, but I have no clue.

Hi @Yuzu,
Thanks for the info.
Can you check, if you can access the RoonServer UI by opening it directly
https:// << IP-ADDRESS >> : << PORT >> /cgi-bin/qpkg/RoonServer

(in case of your given IP it should be: )

You’ll need to be logged in your QNAP web administration as an admin user.

Do you have any blocker extension enabled in your webbrowser?
Which browser do you use and does a different browser work?
Also, does your QNAP have multiple IP addresses?

Same error happens when accessing the IP directly, yes my QNAP has multiple IP addresses and produces same error on both.

I’ve tried with both Firefox and Edge with adblock addons disabled.

The error is produced even without account logged in, something to note ( but doesn’t change anything when logged in either )

Hi @Yuzu ,

Are you running any firewalls on this NAS? What is the exact web address giving you this error in Firefox/Edge?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.