QNAP - database move to external SSD - not transfered?

I know there are a few threads on using an external SSD, but I wanted to check if the database is meant to move when you use the Roon server interface to change the database location?

I just tried this and after waiting some time, plus checking for activity on the NAS, and found that the database was gone, plus my control points no longer saw the server (had to set up as new).

I have backups, albeit a couple of days old, so I restored from backup and seems to be OK now. However, if this is expected behaviour a bit of warning on the server interface when you change the database location would be nice. If it is not expected behaviour, then what is the procedure to make sure the database moves?


FYI using a TS251D, two mirrored spinning disks (8TB Ironwolf), find it hard to believe a USB3.1 external SSD will be faster than the internal HDDs, but thought I’d give it a go. Separates the drive access for database and music files anyway I guess.

If you change the database location, you need to move the database files/restore a backup to the new location. Roon won’t do it for you.

SSDs work better for the database, because there’s no latency associated with drive spin-up like there is with HDD.

I had my DB on a 12 drive RAID 10 array - worked OK. Still reckon it’s snappier on a 2 drive RAID 0 SSD array.

Ah, OK thanks for that. A line of text stating that with the option to change the database location would have made my life easier!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.