QNAP NAS and issues playing TIDAL

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sonos System with several speakers.

Description Of Issue
Roon was running for nearly 2 years without any problem. Now I cannot play any songs. Roon seems to stream the song within my WLAN, but nothing happens.

Roon does not work anymore with the Android app, nor with the iPadOS.
I reinstalled the apps, rebooted everything, reinstalled the Roon software on my NAS.

Tidal works, however.
I have no idea, what to do as a next step.


1 Like

Hello @Christian_Reiser, could you please elaborate on your network setup, including a description of how your core connects to the router? Also, do you have any issues playing TIDAL content to system output of your remote? What about other content?

Hi Nuwriy,

My QNAP NAS with the Roon Core and the Roon database on a SSD is directly connected to the router via LAN.

Tidal content is playing on my Sonos system without problems via the Tidal app or the Sonos app.


Hello @Christian_Reiser, have you rebooted and logged out and back into Roon since this happened? Please let me know if that helps!

Just tried. It worked for one song. Then I was unable again to play the second song: no streaming, Display of the song length is oscillating between 0:00 and end of the song.

1 Like

Hello @Christian_Reiser, and thanks for trying that! Could you please reproduce the issue one more time and reply here with a timestamp (in your local time) when you do so I can enable diagnostics for your account? I’d also like to know what song was playing at the time, thanks!

Hi Nuwriy,
I just tried to stream via Roon. It was not working, as expected. local time 17:38 (05:38 pm)
Song: Daddy Dream, Nils Lofgren
I rebooted my NAS with the ROON Core at 17:40 (05:40 om)
and tried again to stream the same song at 17:55 (05:55 pm)
and it does not work - that’s just annoying !!

Hello @Christian_Reiser,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hello Nuwriy,
do you have any news from your technical stuff? I tried Roon several times: rebooted my NAS, tried the Android app, the iPadOS app and tried to stream from my desktop - without any success!
Hope to hear from you soon!

Hello @Christian_Reiser, your ticket is still with the QA team, and I’d like to add more information for the team to review. Can you tell me the model number of your router, as well as trying a different device as the core temporarily to see if the issue persists or if it’s limited to the QNAP. Thanks!

Hi Nuwriy,
my router is a FRITZ!Box 6490 Cable. Regarding trying a different device: I have an old QNAP NAS.Shall I de-install Roon on my current device NAS TS-453Bmini and install it on the old one? What should I do with my Roon data bank located on a SSD?

Hi Nuwriy,
I just notice, that my old NAS has a Marvell 6282 1.6GHz processor and is not compatible with ROON . How should I move on. I am more and more frustrated that the program does not run, after 18 months without any problem. I really want to find a quick solution, if necessary by install ROON from scratch on.

Hello @Christian_Reiser, do you have a mac or PC you could use as the core to see if the issue can be reproduced there as well?

I just installed the core on my Workstation and deactivated the Core on the NAS. It seems to work. Streaming at different Sonos devices is possible. So what will be the next step? I want to use my NAS as core again. Shall I delete Roon on the NAS together with the database located on an external SSD, which is connected to the NAS? Please give me advice. Thanks Christian

You NAS is below minimum recommended spec to run roon so if you are looking for a long term solution I would move the server off it. People do run on Celerons but then they often come across issues like this.
The benchmark below is the NAS processor compared to a relatively low powered version 8 i3 nuc.

But the QNAP NAS I have used for about 1 1/2 years without any problems was recommended for Roon. So what happened in the last two month? Have the requirements for running Roon increased due to a new Roon core? I am looking for a long term solution, because I have a lifetime subscription.

I think the minimum spec had always been an i3.

So what is your recommendation?

I’d move it off the Nas and put it on anything else
Mac mini, pc, nuc etc

hi guys … any solution on this issue already? I have exactly the same issue! getting mad here :frowning: