QNAP - Not Showing Local Folders Anymore [See Staff Post - Fix is released]

I ran into this issue (Roon not showing local folders) a couple weeks ago after it working flawlessly for years.

There were 2 changes made to my NAS at the time it stopped working.

  1. upgrade to a new NAS OS. Just a patch update, not the major update from 4.x to 5.x
  2. I added a new share to the data volume that held my Roon DB.

I removed the new share on the data volume in an attempt to revert the change, but that didn’t help. I’m still fairly confident that adding the new share is what triggered the issue, and it’s a weird interaction at the QNAP OS level.

Hopefully this will help with troubleshooting.

My setup:
Music Library: HDD based data volume
RoonDB: SSD based data volume

Does anyone know if the Roon DB needs to be shared? I just noticed that it’s in my shared folder list, and I can’t remember if it’s the default, or if it got changed when I added a new share on the SDD volume. If it’s not necessary, I may experiment with removing all shares from the SSD volume and seeing if that may help.

Could you please let us know the progress on this issue?


Hello All,

We realize it has been some time since you have heard from us, but there has been quite a lot of work regarding this issue happening in the background.

I wanted to touch base with some good news, which is that after a lengthy investigation, we have finally had a breakthrough earlier this week in understanding the issue, what is causing it, and how to resolve it.

The fix for this issue is set to go out to Early Access testers the week of December 19th, and then to the production RoonServer release following the winter holidays.

For those impacted by this issue, please keep an eye out for the earlyaccess release coming up and let us know if it solves the issue on your end. You can freely join the earlyaccess program by following this guide: https://help.roonlabs.com/portal/en/kb/articles/roon-early-access-program

We have also been working with @crieke , and have discovered a manual fix for this issue, but the fix involves editing the RoonServer startup script and is technically involved, so I will let Chris explain the manual fix in a comment below.

This issue has been discussed internally on a weekly basis for some time, and we apologize for the lengthy investigation that it took until the root cause of the issue was located, this issue was tricky to nail down.

Please, stay tuned for the next earlyaccess RoonServer release or Chris’ workaround which will be mentioned below. Thank you!


Thanks @noris @crieke and team for this positive update. All users who suffered from that bug that long will very much appreciate the fix - and I am sure many will test and contribute in the earlyaccess build.


Thank you very much @noris @crieke and everyone who helped to bring this issue to a close.

1 Like

It seems the issue only occurs if the HOME variable is unset. I had this issue on one of my QNAP devices and once the Roon team had figured out the circumstance of no music files in the library, I was able overcome the issue by declaring the HOME variable in the RoonServer.sh script by adding the line to the RoonServer.sh script:

export HOME="/root"

It won’t be required anymore, when the bug in Roon Server has been addressed, so I won’t supply an update to the QNAP App Center.
(However there will still be an update available soon, which addresses handling of temporary folders. It will not have this line included!)

I’ve just prepared an interim build (click to Download), which is based on the upcoming App Center release and added the above fix. It is dated one day earlier (compared to the upcoming App Center version), so you can easily switch back to the regular release, when the bugfix has been included in Roon Server itself and the mentioned update of Roon Server is available at the App Center by clicking the “Update” button in the App Center.

I have also updated the Legacy 1.8 Installer for Roon Server, as I have no info, if this build will get an update anytime soon. It can be downloaded from the roononnas.org website.


Thanks for the detailed description @crieke. Just one thing to assure: there is no connection to the CPU used (which also was shown by the bug reports of users ranging from somewhat underpowered to high performance ones). Only mentioning here as there was a rumor once this might be related to the CPU used (@noris)

The cpu issue might be related to the tmp folder, for which I’ve already sent an update to qnap and which is already included in the interim build above.

I’m sorry to say that the interim build didn’t help.

The beginning was promising as all files were quickly scanned but after Qnap restart I lost all the local files from my library. Only Tidal/Qobuz albums are left now.

I’ve sent a private message to you for further investigation.

1 Like

After manual modification of RoonServer.sh it works perfectly :slight_smile:

Thanks @crieke for support (and great Qnap package first of all) !!!


So when trying this do I / others also need to manually adjust that file?

No, I have adjusted the installation and updated the link in my post. It should work now without manual modification. :wink:


I have tried the fixed that @crieke has provided. It fixes the issue. Thank you very much for helping us get rid of this headache.


Roon just auto-updated on my QNAP. After the update, the issue has gone.

You mean a firmware update?

I dont think the issue is fixed yet. I am still showing 10 copies of every album and upon next restart the issue returns.

1 Like

No, I meant Roon server update.

Try to install this https://roononnas.org/builds/QNAP/interim/RoonServer_2022-11-29_x86_64.qpkg manually. This fixed the issue for me.

1 Like

I installed that version but I have the same issue. Right now, my library is scanning and Roon is showing over 400K tracks with 10 versions of every album. Roon is saying I have over 1 million(!!) tracks (I only have 60K).