QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

You are running quite old QTS version (there are 9 more major versions available) and even for that version there is newer build available. Maybe that’s the reason why you are still on the safe side? For me that problem started with QTS 5.0

1 Like

For me too - and the problem is back with every single restart of the NAS :grimacing:

? It is released in October 2021? QNAP still updates the “lesser” versions but assumed mainly for security and maintenance reasons. You do know that new features means new bugs, right? :wink:

Hi @Markus_Hubner ,

We continue to investigate this issue with the dev team and with @crieke 's help, there have been no further concrete updates that I can share at this time. The only known workaround until we are able to pinpoint the issue is to change the guest access rights. Once we have an update to share, someone from the Roon team (or Chris Rieke) will update the thread accordingly. Thanks!

1 Like

Thank you. If anyone needs more feedback, data etc. to support in fixing this just tell.

Just chiming in that updating to QTS5 has resulted in my local library disappearing. Let me know if I can provide any data / logs / etc.

1 Like

You’re not the only one. The workaround is to change Guest Access on your shared folder containing your Music. The early conventional wisdom was to change it to “Read” or “Read/Write” but i’ve found that you just need to change it to something else. So if it was already at “Read”, changing it to “Read/Write” or even back to “Deny” would fix the issue. Of course if you reboot, you have to do this all over again.

As I have to restart my NAS often per week I completely get lost of all local files. And doing the fix including rescanning the files every single time is quite a deal breaker as many can understand.

I’ve been Stopping Roon on the NAS before rebooting.

Then I reboot.

Start Roon.

Then:
Very quickly! - navigate to Shared Folded permissions and change the Guest rights.

Force rescan, in Roon | Settings | Storage

I find this way Roon does not seem to have time to ‘lose’ many of the local files, and recovery via rescan is mercifully short.

@support

I followed your procedure but that didn’t work for me. Hopefully, this issue gets fixe quickly.

Hi

Must admit that the work-around didn’t work for me either.

Just to be 110% sure I understand the work-around correctly; it is the guest permission for the shared folder which contains my music files, which needs to be toggled?

QTS: 5.0.0.1891 (latest at this point)
Roon: 1.8 (build 884)

Question: how long time (roughly) would it take for Roon to scan a folder structure with 3000 songs on a TS-453D with 4Gb of RAM?

Kind regards
Jens

It didn’t bring back your files, or it didn’t save any time, or both?

For me, I lose some of the files but get them back quicker this way.

Yes, toggle the guest permission for the shared folder in which you keep local files (as recommended by Roon support). All I am suggesting that is different is to close down Roon app on your NAS before you reboot. I think it saves scanning time after you’ve done the ‘toggling’.

Sorry if it wasn’t helpful,

John

I would toggle it for all Roon related folders. So also the one where Roon database is (this should be in a different place than Roon media folder).

Also I strongly recommend that you double the RAM used in your 453D. 4gb is not enough to run Roon core properly. I use 253D with 8gb of RAM. 3000 songs shouldn’t take long to scan.

HI John

I don’t think you are to blame at all.

I’m actually just trying out Roon for the first time, and I have yet to see my own music collection being accessible through Roon :frowning:

This is how my NAS is organized:

Music files on a RAID1 volume:
/Multimedia (shared folder)
/Musik
/Artist 1
/Album 1
Song 1.flac

Song n.flac
/Album n

/Artist n

Roon server and DB on volume on a SSD drive:
/RoonDB (shared folder)

The storage in Roon as follows:


I assumes that Roon automatically looks into subfolders to find the flac files stored in each of the album folders.

I’ve tried to toggle the Guest Access Right on both the /Multimedia and the /RoonDB folders and then done a forced rescan of the storage from my Mac. The rescan completes within a sec. and I cannot find any of my own music inside Roon, so I suspect that Roon hasn’t been able to find it in the specified storage location.

Kind regards
Jens

Hi Patouskiii

I’ve have tried toggling both folders:
/Multimedia (which contains a folder which holds my music)
/RoonDB

But it seemed not to have any effect.

You might be right about RAM: currently using 43%, but I’ll cross that bridge if I decide to stay with Roon … at the moment it’s a big MAYBE due to this bug, which seems to have been going on for a fairly long time without any proper fix :frowning:

Kind regards
Jens

Hi again

I my case toggling of the guest permission had no effect, but I managed to get get the Roon core connected to the folder whit my music by setting up a shared connection to the folder on the NAS; so the to line does NOT work, but the second line does.

Pretty glad I got this to work, as I’m evaluating Roon future use …

Anyway … just a work-around to a bug, which needs a fix :unamused:

Kind regards
Jens

2 Likes

Hi all

so this still happens to me every shut down (with is once a week in the winter here with all he power outages… :frowning: )…

i can fix it each time with the permission fix (still annoying but better then no Roon at all…) but then immediately after the fix Roon goes into a full scan mode and it seems i loose all my library statistics, latest adds etc…

is there anyway to avoid this? am i missing something?

thx alot

Z

1 Like

I am not sure if the roon development team is watching this thread or not. But this issue has been several months old already. It is quite a serious issue for us. Would you please prioritize the fix for this? I have been a very happy Roon fan for 5 years. Please don’t change my mind.

1 Like

Could we have some feedback on progress with this issue. I am able to work round, and have shared my methods (which don’t seem to have helped anyone!) and I’d like to know where we are with this now. @support

Same here. I am a bit disappointed by Roon support for this one to be honest, and I have been using (and recommending) Roon for years now.