QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

I use Roon on a QNAP but have always assumed it wasn’t officially supported. So whatever Roon is doing is possibly just good will (and good PR).

Does anyone know if this is the case?

It’s supported.

This issue has been with us for more than 2 months. The issue is consistently reproducible. If it gets enough attention, I personally feel that it should have been solved already. Are there any way to escalate this issue? Or using this forum is the only way to get Roon support? I am not sure if it is even read by Roon staffs or not.

1 Like

@noris Another month has passed and as you see this is really painful for many QNAP users. What’s the status / intended timeline for this?

4 Likes

Hi @Markus_Hubner ,

This issue is still in progress, we’ve been discussing internally and with @crieke trying to determine what is causing it.

An interesting observation we’ve recently found is that this issue only occurs when starting RoonSever via the QNAP App Center, if you start it over SSH, the issue is avoided (in both cases the starting user is admin so not related to the user profile).

It seems like a permissions issue, but trying to find the root cause is a work-in-progress. Once we have more details to share, we’ll update everyone here.

4 Likes

A pitty any improvements didn’t make it into recent 991 build. Can the community do any further to help get this fixed as it’s really taking a long shot.

@crieke Any update?

I have had this same issue since a few months but have I have always been able to figure it out between two restarts of the NAS when they occur.
My actual problem is that the latest update has been applied to Roon and it requires a database update which leads to restart Roon and makes the library vanished as usual…Then I restore the database backup and the same database update is required and again…
Then I do not have Roon working anymore as i seem stuck in a loop.
@noris Any clue here ?
Cheers, Fabrice

1 Like

HI @Fabrice75017 ,

Have you tried this?

As for an update on the ticket itself, we have since made one other discovery here, which is that creating a new shared folder (even if it contains absolutely nothing) allows the QNAP shares to be seen again in Roon. This bug is a strange one, and we continue to investigate.

Finally a workaround / fix would be really needed. As is happens quite often to shutdown the NAS and then every single time this bug occurs as well as extensive effort to reindex library etc.

For some reason, the Guest Access toggle workaround that I’ve needed for Roon on QNAP for months is no longer necessary. I can’t explain it but sometime in the last update or two, the problem which always occurred on reboot disappeared. Any explanation from the engineers?

I’m running QuTS Hero 5.0.0.1949.

I’ve also found that the problem seems to have disappeared - no idea when or why.

Whenever it happened I’m pretty sure the problem still occurred after QuTS Hero 5.0.0.1949 was released. That release dropped on 2-17-22 and I installed it the next day and I remember the problem still happening with Roon. So it was likely one of the releases that happened since then.

For some reason this problem reappears sometimes after a new version install. Now I installed Build 923 and the core is (once again) just initializing or I get the endless loading jellyfish and I can’t connect to it. It might go away by tomorrow morning or it might not. Anyway it’s not normal behavior and I’m currently unable to use Roon. I hope this problem gets fixed for good sometime soon.

1 Like

Looks like 923 is doing the problem all over again. And I just updated to QuTS Hero 5.0.0.1986 too.

1 Like

Any updates regarding this bug? Forced to reboot due to Qnap latest firmware update which include security fixes. If permanent fix is nowhere close, how about a regular update inform us (the end users) how the bug is tracking?

3 Likes

I would be keen to get an update on this as well. The issue popped up again last week after a power outage. Luckily these are very rare around here and the workaround works. But a long term solution would be much better!

Especially for energy saving aware people (which are steadily increasing) powering down their NAS over night or when away a day or more this bug is highly annoying.

@kevin So what’s the deal here? Having to deal with this for months and also paying for a stable solution is making this increasingly hard to swallow.

2 Likes

This was the only way I got it to work as well and then saw this here. Weird as it was working well before until I updated/reinstalled my QNAP over the weekend.