QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

@AMP Thank you for the update. Though you may understand that „patience“ has already been heavily stressed as this bug is still there for nearly 6 months(!).

This finally really needs some attention and focus. Hopefully with your commitment now this gets fixed asap.

It’s not a QNAP issue. This problem started when Roon updated how the core functions on Linux servers. It was total overhaul back then promising faster and snappier UI etc. I can’t remember the version number but the problems with missing libraries and startup failures started back then. Before that I ran Roon on QNAP for over a year with zero hiccups.

Nowadays Roon have worked mostly fine on my TS-253D but it’s not 100% stable. I really hope they can find a solution for this situation since it’s clearly bothering many QNAP users.

Firstly a huge thanks to @Reinhold and his “Linux Super-Guru” friend Bernd for the 127.0.0.1 workaround which seems by far the least annoying workaround so far. With reference to the 2 “drawbacks” you noted though…

I’m not really familiar with expected Roon Core performance on a QNAP NAS. Could you possibly give some very rough context for how the scanning speed is now in terms of roughly how long the scan took on what NAS and how many albums are in your collections (or tracks if your more of an individual-track-oriented guy)? Please don’t do anything special to answer my question but some rough extra detail from memory of how your previous rescan behaved would be interesting.

On the second drawback does that only include locally added files? Do you still see new albums if you add them from a streaming service (I use Qobuz) where typically that might happen for me if Roon Radio throws up something I really like and I add the Qobuz streaming version to my library for a while until I decide I like it enough to buy a physical download. I’m hoping that still works OK since I assume it’s all to do with the Roon database rather than the music folders but I did just want to check that point.

I assume the solution for not detecting new physical music files is to rescan the entire music folder whenever you add new files (FLAC or whatever) to your library? That’s not a huge issue for me because due to my try-it-out-from-Qobuz strategy I tend to buy new music infrequently but when I do make my infrequent purchases I tend to buy quite a few albums at a time so even leaving a rescan to run overnight once every few months isn’t going to inconvenience me too much.

Having said all of that I do hope that Roon can identify this issue soon so that workarounds and corresponding compromises are no longer required. This is all extremely timely for me since I am expecting my first ever QNAP NAS plus drives to arrive from Amazon today.

I’ve just tested again the scan time and now I don’t see any significant difference in times.
So either the first scan was slower, there was other load on QNAP or I just can’t explain that :slight_smile:

9251 FLAC files were scanned in 6 minutes.

That applies only to local files. Qobuz/Tidal favorites are not affected by that problem and remain in the library after QNAP restart.

Lack of detection of the new files means that new local files added to the disk are not being added to the library on the spot. You need to rescan manually or wait for automatic rescan interval.

1 Like

Thanks for that, I really appreciate it. For my particular use case it sounds as if I probably won’t even have to wait for a Roon fix since the 127.0.0.1 workaround will be a pretty much unnoticeable inconvenience for me. Sadly however there is a bug in the latest QNAP firmware that throws up “unexpected error” when trying to create a SED storage space and I really want to make use of SED so my brand new QNAP NAS is currently sitting powered off on my desk until QNAP respond to my support ticket and hopefully fix the bug and then it will be full steam ahead on moving my Roon core and music files to my new NAS.

@Reinhold Your default permission fix has just repeatedly worked for me on a new TBS-464 running 5.0.0 build 20220324.

A HS-453DX on the same release of QTS and Roon has never had the issue, but has been upgraded as releases have come out over the last few years.

Thanks. Russ

Well, I’m now in the camp of Roon Server not seeing local files on my QNAP 1688x running QuTS Hero 5.0.0.1986. I had to rebuild my entire server from scratch recently to upgrade to larger hard drives. Previously changing the guest privs worked as a workaround for the local files problem which was an annoyance but not the end of the world. When I rebuilt the server and reinstalled Roon, there was a period of time where it seemed like Roon saw the local files and was processing them, and then they counted down to zero. Changing the guest access did nothing unlike the last time. Since I had restored the previous Roon database, I thought maybe that may have been the problem so I began from scratch, uninstalling Roon and deleting the database from the shared folder on the SSD. I went through the entire install process all over again and the same thing happened with a fresh database. No visibility to any of my local music files.

I am now trying to solution using a network share looking at the NAS itself (127.0.0.1), but as others have noticed, it’s really slow in the scanning process. Like, it’ll be well into tomorrow before it scans everything. This is not going as i had hoped.

Would be nice to get an update on when this issue is fixed. Thanks

2 Likes

Not that it really matters to me, i have other Cores, but Build 952 finally managed to break my Roon Core with the issue reported!
I have been running my primary Roon Core on the TS-470 Pro since 2016(?). The reports of loss of library content have eluded my install, perhaps due to the fact that the TS-470 Pro is getting a bit long in the tooth, and QNAP stopped major development for it with QTS 4.3.6.

I updated to QTS 4.3.6.1965 a couple of months ago without issues, and the latest Roon builds before 952 sailed through without a glitch. However after b952 being installed, the NAS was forced to be relocated, and when i powered it up in it’s new spot yesterday my library was reported to contain around 350 albums… (my Qobuz favorites).
Sure enough, under storage beneath each path no “tracks imported” were reported.

I edited the storage paths to point towards 127.0.0.1 instead, but this caused Roon to re-identify/analyze the full library. The old claim that the same files will be recognized on a new location is not true with Roon anymore.

In an effort to prevent re-analyzis of 175K tracks i decided to re-install Roon with the QNAP package, and then restore my latest backup. (november!)

After some efforts the restore was finished and i was able to log in with this Core, and to my surprise, my library was back! But the joy was momentary, as i noted that the Album and Track counts were actually counting downwards, rather than increasing.

So, back into Storage setting and rather edit each path towards smb://127.0.0.1/Multimedia instead, and the library seemed to stabilize and actually add the few dozen albums that was added while this was happening.

So, two things:

  1. QNAP is definently showing local folders, it’s just that Roon cant seem to find their contents…
  2. Why the heck can i both create backups and restores to the traditional paths with Roon, but media cannot be found under Multimedia?

Just an update that might not help anyone here…

After many months with this issue, fearing to restart/update the NAS OS as much as required because i’d spend a tough time each time trying to recover from those files that vanish,…and the last reboot was enough as i couldn’t succeed in recovering Roon…

Keep it simple (and invest a bit of money)

I have ended with buying a NUC intel, installed W10, made some cleaning and installed Roon. That works obviously like a charm and I will now forget the hassle of depending of a non officially supported bit on QNAP…
My NAS is just a NAS (and a serious one) and I’m very happy with that. It will now stay focused on its primary mission, and always updated.

Music please now…

Still, i hope a solution will be delivered soon for all of you guys.

++

2 Likes

So what is the current status finally?

1 Like

This worked for me too! Thanks!

@mike This increasingly becoming very annoying (especially since after ever reboot causing a lot of troubles and which is required by many users).

As you see this severe bug is there for 6 months now(!) and the the latest feedback from Roon is still you are trying to investigate and calling for patience is unfortunately by far not what Roon stands for. It’s not just about all the paying users expecting a working and stable product - but also for every Roon QNAP user something that is just the basic requirement for a software solution like Roon.

So please finally check back with the internal team and provide a timeline that users can rely on and get the trust back that there is willingness to provide progress / a solution.

2 Likes

That would be very nice!

New QTS version released today. I installed it and everything works fine. I haven’t had the local folder issue lately but those who have, maybe give new QTS version a try?

Hi, the QTS upgrade didn’t resolve things here. :disappointed:

Edit/Update: Confirmed, new version of QTS does not fix the issue.

So you don’t need this temp solution anymore?

“My temp solution is to use QNAP IP address instead of local name in ROON Storage location.
Ex. “\192.168.x.x.\SharedData” where \SharedData is a folder shared on my local network.”

No, my QNAP sees the local folders currently. I did have this problem originally but after multiple re-installs, restores from backup and tweaks mentioned in this thread I somehow got it working like it used to before this issue appeared after that one Roon update.

Every time there’s an update for Roon it takes an hour or two before my remote control points can find the core though. Eventually it has always been found (for now) but this behavior isn’t normal either.

Good to know - THX for the info.

I tried the latest version of qnap firmware myself. I didn’t solve the issue.

Could the Roon team accelerate on this front? The issue has been with us for more than 6 months. The issue is easily reproducible. Very frustrating.

2 Likes