QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

@crieke Seems @support or other stuff members are strangely no longer answering. Can you shed some light on this?

2 Likes

I have been trying to isolate the issue as much as possible and send all my info directly to the Roon team. I can’t see anything specific wrong with the qnap installation routine.
There is not much more I can do here at the moment, but to wait for their feedback and ask for status updates.

7 Likes

Thank you very much for your commitment!
As you mentioned we can all only wait for the response from the Roon team but feel somewhat concerned as there is no feedback again for a long time - left alone any fix for over 6 months now.
So @support @AMP is there anyone willing to provide some progress update?

Any updates? Adding local files via localhost IP address is still a doable workaround in Roon build 970, but no luck for the regular approach…The path of local folders can be specified, but there is no way they can be scanned and added to your library.

1 Like

I took some more time today to look into the issue. I could not find the origin of it, but I think I might have found a workaround, that sticks even when rebooting.

Knowing, that all files reappear, when making any changes in the shared folder section, I tried to plug in a small USB thumbdrive (I also formatted it with an ext4 filesystem on the QNAP, but actually that might not even be required ).
I hit the “Force Rescan” button in Roon storage settings and all music files reappeared. I rebooted the QNAP and when it was back online and Roon had started again all files were still available.
So if you have a small spare usb thumdrive, just plug it in and leave it there.
Unfortunately, this does not solve the core issue, but it might be the least annoying workaround so far…

Thanks for the tip. Unfortunately, this doesn’t work for me. :frowning:

USB Thumbdrive-Solution didn’t work (as the one with adding and deleting a new shared folder). However adding the folder via the IP-Adress worked like a charm!

So @support @AMP are you really not willing to comment here and provide an update to this important bug for QNAP users?!

2 Likes