QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

Which bug? I’m not aware of any bug regarding inotfy on Linux systems. I don’t see a reason why it shouldn’t work if prerequisites are met – even over SMB.

Oh was referring to the general bug/thread here.

AFAIK there is an ongoing investigation. No details/reasons are known so far.

Hi

All very useful information . Thank you for that. I was not so clear on the first post. When I first set up my core and imported my library into it, it worked flawlessly and if I added a file or folder on the core it instantly triggered Roon to update. With a network folder it did not but you are saying there is a four hour interval. Can I shorten that? I did a force rescan and it was actually quick.

My NAS is 6 years old but has 4 new drives but you are right I doubt it has much memory. Would it benefit me to put the Roon data base on a SSD drive connected to my NAS?

I understand your statement about large libraries.

Roon reports 86078 tracks

Besides those issues I was dealing with compatibility issues with my Bluesound Node, Roon and audio dropouts. I use a different DAC, Schiit and it was using usb out of the node. That caused issues. I read to use a different out. I chose optical and that fixed it for now.

Oh the joy. Thank you for your help!!!

The bluesound was purchased because I liked the Roon interface and my streamer would only use airplay with it. Node was said to be Roon ready.

Needless to say it was a lot of new elements at one time.

Please read the documentation to learn more about caveats and pitfalls when running Roon on an underpowered Core:

I personally don’t think that an SSD for Roon’s database will solve all your issues. Even additionally adding more RAM, if that is even supported by your model, may not solve all the issues. There is still the under-specced CPU with only 2 processing cores that has to run all the NAS processes too besides Roon.

The usual default value for max_user_watches is 8192 – so more than ten times less than your current library size. Please check. Please also check the RAM utilization on your NAS – your NAS may already need to swap memory to the HDD’s.

I got that, but as it looks like, you can’t go back to that setup because of the current issue described in this thread. Speculation: Using local folders, it may work without changing max_user_watches because Roon runs as user root who may not be bound by that limitation. Using a network share instead, the built-in samba software is responsible for initiating the real-time watching and this software probably doesn’t run as user root.

Go into Settings|Storage and click on the three dots at the right side behind your storage configuration to bring-up a menu with available options. Choose “Edit” there and look at the options available.
Sorry that I can’t be more precise, but I don’t have the issue discussed in this thread with my NAS and configuration so I still use a local folder which doesn’t have the same options available as a network share.

Good to hear but unrelated to your Core AFAIK.

2 Likes

You may have a look at this thread.

Nice weekend

1 Like

Thank You will do.

Ok, Thank you again for taking the time to answer my questions and to point me towards insightful information. Did more homework last night. My NAS has 8GB of Memory and 4 cores. So that should cover me? (for now). The CPU is Intel(R) Celeron(R) CPU J1900 up to 1993 MHZ.

I read the links you sent. The big suggestion was to keep the Roon database on an SSD not a spinning disk so I am going to do that tomorrow.

Have a great weekend.

1 Like

The minimum CPU is listed as an Intel i3.

1 Like

I ran into this issue (Roon not showing local folders) a couple weeks ago after it working flawlessly for years.

There were 2 changes made to my NAS at the time it stopped working.

  1. upgrade to a new NAS OS. Just a patch update, not the major update from 4.x to 5.x
  2. I added a new share to the data volume that held my Roon DB.

I removed the new share on the data volume in an attempt to revert the change, but that didn’t help. I’m still fairly confident that adding the new share is what triggered the issue, and it’s a weird interaction at the QNAP OS level.

Hopefully this will help with troubleshooting.

My setup:
QNAP TS-873, 20GB RAM
Music Library: HDD based data volume
RoonDB: SSD based data volume

Does anyone know if the Roon DB needs to be shared? I just noticed that it’s in my shared folder list, and I can’t remember if it’s the default, or if it got changed when I added a new share on the SDD volume. If it’s not necessary, I may experiment with removing all shares from the SSD volume and seeing if that may help.