QNAP Restore Backup Failed - Help?

Hello, i’m trying to restore a backup after wiping my QNAP Nas to install an SSD drive.

I’m getting a restore to backup failed after 1% with various backup dates. My initial thought is the folder structure on the drive is different, roon may not have permission to create new folders to match the old structure. Any advice/support appreciated to get this restored.

Add images

Thanks for your help

Are you going into Settings/Backups/Find backups then browse or are you trying to use the restore in Scheduled Backups? If the directory no longer exists or has moved you need to use the “Find backups” option to locate the backup and restore from there, don’t use the “Scheduled backups” - “Backups Manager”.

I can find all the backups. It worked restoring the exact backup folder from a separate USB hard drive. Trying to restore from a roonbackup folder locally would always fail odd, I noticed it was recommended to use a separate USB drive to restore googling similar threads.

Thanks for responding!

Hi Andy, it should work by any these methods provided the directory exists and is accessible. The fact that it works via USB with the same files would indicate the backup isn’t corrupted but may be some kind of access issue. I’ve used various methods when rebuilding my QNAP without issue. It’s hard to know without more detail.

It might be a permission issue as now I’m having an issue with my music folder, forced rescan is not working and it is not picking up my local music stored in this folder. Used to work perfectly fine without issue. I’ve tried creating a new folder and ensuring ‘everyone’ has read access in shared folders. It’s a QNAP nas, any idea what could be causing this?

This issue is not resolved. Seems no clear cause has been found by now. Use the workarounds from the issue thread: