QNAP Roon Server no longer working

Core Machine (Operating system/System info/Roon build number)
QNAP TS-453BT3/4.3.6/Roon build number 1.6 (build 416).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Wired 10 GB Ethernet & Comcast 1 GB WiFi modem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Oppo UDP-205.

Description Of Issue
Roon stopped working on QNAP

I have 2 Roon cores and 1 license. Since I don’t want to keep my main iMac disks spinning all of the time I also keep a 2nd core on my QNAP. Everything was fine until a few days ago when it completely stopped working.

  1. I bring up Roon and it sees the 2 cores. I select the QNAP.

  2. There is nothing in the library, although the music files are there. I select Import settings. Sometimes I can add the folder, sometimes it just hangs never showing me anything. Even if I add the folder, and ask it to do a forced rescan, nothing happens. The Roon icon flashes and disappears.

  3. It says there are no managed audio devices. I ask it to search I just see a blank page with “Networked These devices have been located on your network”. Running an arp-scan on the QNAP 10 GB ethernet interface I see a device (an Oppo 205).

There has been, I think, a QNAP firmware update recently. I’m wondering if maybe that might have caused the problem.

All of a sudden it started working, found the libraries and play devices.

But now a day later I can’t even log in to Roon. Both on my iMac and iPhone I just get the “Logging in” message. Eventually I get a network error message. All of the other QNAP network apps work just fine - Manager, Plex, Infuse SMB.

Hi @David_Moor,

Can you please check to see if there is enough free space left on the QNAP to properly operate? Have you tried rebooting the QNAP and is the behavior still the same afterwards?

Thanks. I had 3 TB free, but was over the warning threshold. Deleted stuff and did a reboot and filesystem check. Seems to be working now.

I moved the QNAP 10 Gb cable to another switch while the server was running and everything got wiped. I stopped and restarted the Roon server seeing if that would restore things.

If I go to the QNAP and open roon in app center. The short info screen in tells me the database location and that I’ve used 77% of 15.63 TB. That’s fine.

But if I go into the Roon App on my iMac no database location is set. The Tidal login has also been lost. So I again had to start over from scratch.

Hi @David_Moor,

I’m not quite sure I understand you here. The iMac should have it’s own database location if you’ve been using it as the Core. If you deleted the Roon App / Database from the Mac and reinstalled it fresh then this kind of behavior can occur, but I can’t think of a reason this would trigger by itself unless you were using the iMac as only a Roon Remote for the QNAP.

Do you have Backups of your Roon Database saved somewhere safe? If so I would suggest restoring to one of these backups or create a new backup from the QNAP and restore this to the iMac.

Sorry I wasn’t clear. I have 2 servers, 1 license. I shutdown my iMac most of the time to keep from spinning all of those disks, and switch to the QNAP Roon server.

The problem seems to be that when Roon network connectivity is “lost” (even though all other QNAP network apps work) the server seems to just wipe itself out, as per my previous post.

Hi @David_Moor,

Thanks for clarifying the error state. This behavior seems a bit atypical, would you mind uploading your QNAP logs to Dropbox / Google Drive and post a link here? You can upload logs by using these instructions (https://roononnas.org/en/qnap/), please be sure to include the ROON_DEBUG_EXTERNAL_LOG.txt in the logs.

Here’s are two links, logs and screenshots:

I looked in the logs folder and also downloaded the logs via the QNAP app in app center but saw no roon_debug_external_log.txt.

Roon was working on the QNAP. There was a firmware update and a reboot. I was over my 80% threshold, but still had about 2 TB free. I set my Roon core to the QNAP and there is nothing there. Even the Tidal login is lost. I do see connected devices though.

Hi @David_Moor,

Thanks for sharing those screenshots, it does indeed look like there is nothing on the database even though it shows that you are still using 77% of it. Can you please run this diagnostics tool and let me know if it reports any RAM or Hard Drive issues? https://appcenter.qnap.com/eng/qpkg/overview/diagnosticApp

No problem with the Memory or SSD tests. HDD Stress test will take some time. Will post results when available. I recently installed 2 512 GB Cache SSDs (316 GB available with 30% over-provisioning) RAID 1. I don’t remember when the problem started, but there is a possibility that it might be related.

Hi @David_Moor,
I looked through your log files and it seems contain no errors that explain the situation. But I also noticed, that you set the Roon Server’s database location to /Multimedia/Music. I assume this is the path where your audio files are located.
Roon’s database, which you have specified to be stored there, is a set of files that store all the settings and preferences. The zip file of your provided log files contained only 2 log files (normally it has about 20). So I am wondering, is it possible that you deleted a folder named “RoonServer” (unwittingly?) from your /Multimedia/Music directory or did you maybe change the database location in the QNAP Roon Server app window?

In general it is not a good idea to store the database next to your music files.

1 Like

I moved the Roon directory out of the Music folder. That seems to have made a difference - 24 hours with no problems!

Hi @David_Moor,

Thanks for the update here, do let us know if things are still stable after a few days and we can go ahead and close this issue.

Still stable, so you can close. Problem was the location of the Roon directory.


Hi @David_Moor,

Thanks for the update here, glad to hear things are still stable!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.