QNAP Upgrading to Roon 1.3 - In trouble - Nothing Works Now

I’m in deep shit now…

Nothing works :slight_smile:

No networks devices shows up anymore, I’m using a Qnap.

Not sure even where to start.
In my iPad no network devices shows up. Try to connect HQP. no response.
Same on my PC.

On my HTPC that I use RDT, its even worse.
I can coose between two cores, (since there exist an old 1,2 not in use).
But when choosing the QNAP, noting happens. Roon control want even start.

There it stats:
Linux 4,2,6/ and ip of my Qnap
Version 1.3 (build 193) stable
“A green dot” Update required.

There are appleTV’s (latest version) on my network a SBT, and a MicroRendu.

Should I start a new tread ?
How to proceed ?

Hi R1200CL,
Has your HTPC remote already version 1.3 installed?

I just did that update as I expected that was the problem there. Still same problems all over, At least they are the same now :slight_smile:
Which is no audio device founded.

If you like we can use teamviewer…

If any help:

When using my iPad: In the settings for Setup and Configure Roon OS devices, it only searches.

(I’ve just email you my contact details if needed)

OK. Here is an interesting update.
I changed core to my HTPC, and suddenly all my audio shows up. But the IP address Roon reports on my HTPC is totally wrong.

Logon takes very long time, and when changing back to QNAP, things are the same

Also I’m not able to log in to my Tidal account from iPad, but I could do from desktop app. but when skipping login, it seems that I have access.

Can anyone confirm their Qnap update did work ?

A friend has failed with his Qnap, he was running core on it and all was ok on 1.2, after the update Roon remotes can not connect to the Qnap? We tried downloading the Qnap package again to no avail, we get the screen inviting us to connect to the Linux core but then just hangs with the ‘space invader’. Giving up and moving back to the Mac for now.


Do you have a core running on the QNAP and your HTPC simultaneously? Was one of them originally created by copying the database from the other?

If that’s the case, shut one of them down, restart your remotes and see if you can connect. There’s a unique ID number associated with each database instance and if two cores are running on the same network with the same ID then the remotes get very confused.

When the Mac was started as core the Qnap was de-authorised Roon app turned off and rebooted to be sure, and the reverse was done when we tried to go to the Qnap as core we even removed Roon and deleted the folders from the library folder then downloaded Roon again. Roon is now running perfectly on the Mac and busy adding the library.


My QNAP worked perfectly.

My update went incredibly smooth and corrected some issues I had previously with Tidal and Roon account not being accessible.

On a Qnap ?

I’ve just had one hour video support :grinning:
Roon has a fantastic support team.

It may seem that the Qnap installation file and update is OK, but the Roon database conversion/upgrade is the issue.

We do not know for 100% yet.

If you are able to store (move) your Roon and RAAT under a new folder (under RoonServer) in your Qnap you most likely will be ok by deleting your qpkg and reinstall.
Or actually not reinstall, just restart the Roon server.

Of cause you loose what you have stored, and have to reconnect your local files.

I have no knowledge if those that have same problems as me will get help to have their databases converter or not.

I guess it may be a good idea for Qnap users to wait with upgrade :grinning:

Not two core running simulations, at that would require two licenses.
No copy of database.

But there may exist two different cores in the Roon cloud, which may be an issue. Hm… interesting. Cause you can’t manage your Roon cloud, or can you ?

After installing the controller I was asked to update the database on the QNAP. Then this screen appeared for about 5 minutes. I have roughly 6500 albums.
My QNAP is a TVS471 with the Roon database running on a USB 3.0 connected SSD.

Now everything is working again plus the new features. It is funny that a new album appeared now that was apparently not recognized in the previous version.

The new album may be multi Chanel. I had one of those. The old version would not have picked it up.

I’ve been having a bunch of trouble too. My QNAP is underpowered for sure, but it worked almost perfectly with 1.2 with only minor inconveniences where the remote would disconnect.

After updating to 1.3 (194), my processor is often pegged at 90-100% and RAM (8GB) is also often up in the high 80% range.

The symptom is that the system becomes totally unresponsive and hangs with the “looking for core” screen.

Is it possible that this new update is causing the processor to work that much harder, or does @crieke think that there might be something more going on with the QNAP implementation?

Before updating, I backed up my RoonServer folder completely to my home folder on the QNAP. Should that be deleted?

The background analysis has been going for a few days now. Is that normal?

Thanks in advance.

1.3 requires that all your files are re-analyzed, so that’s probably happening in the background and impacting performance. You can confirm this in Settings > Library.

Once that’s done, 1.3 should perform slightly better than 1.2, but generally speaking I would still recommend against an under-powered Core for a variety of reasons, including that you’ll probably have problems using DSP features.

Let us know how it goes once Analysis finishes @David_Korus. Thanks!

Thanks for getting back so quickly.

I’m getting this for long periods of time causing me to have to stop and re-start the Core.

Here’s the analysis progress since the 194 update (installed almost immediately after it was released):

Could the analysis be crippling the system in 1.3 vs. 1.2 where I didn’t have these issues?

Thanks again.

I have the same problem. After upgrading to 1.3 the QNAP device cant be found anymore. I reinstalled the .qpgk without any success. Any hints to get this working again?

Thx a lot Thilo