Qobuz 44/16 data rate streamed via Roon is larger than streamed via Volumio

But Roon uses 2Mbit/sec four hours, it should have finished downloading the track/album at some point. Volumio does download and cache during the first 10sec, that is why it stutters, but then it levels off to 1,2Mb/sec.

If your download bandwidth was really stable at 2 Mbps, there should be no problem with 44.1/16 files. Prebuffering begins before finishing the previous track, and the download continues at the max possible bandwidth until the track is completely buffered. Looking at my own bandwidth usage I find that the local streaming account for approximately 1,55 Mbps over WiFi. But with your limited Internet bandwidth how can you make sure that there is no other traffic in the background? That could be email, or even the Roon Server itself, and then the process will fail.

Well, I stop the Roon playback now and then, and the rate drops to 0. I have not logged into Windows, just started Roon as a service. And stopping Roon and playing Volumio changes the rate from 2.1 to 1.2 Mbit/sec.

That seems to be correct. If I manually empty the queue, then the bandwidth usage shrinks to 1.2 Mbit/s. If I select an album it fills the queue and the bandwidth maxes out. That is not a nice behavior, as Roon steals all remaining bandwidth simply for downloading the queue where there is not really a need doing so. Even if RAAT needs to be fed continuously, it can not be expected that there is a sudden need to dump the full queue into a Raat device.

That is not so. Watching the Roon log in real time shows that it downloads a track, starting shortly before the previous track finishes playing, to be able to play gapless, I suppose. It then uses the available download bandwidth to finish caching the current track.

That’s not how Roon is doing the caching. It doesn’t cache an entire album, less all tracks queued. If you have the means to watch the Roon Server log in real time, do so, it will make things clearer to you.

2 Mbps download bandwidth is very little… Roon not only downloads and caches tracks from streaming providers, but it downloads e.g. metadata and images in the background.

I myself a couple of months ago was affected by bad Internet access, and I have seen that below 4-5 Mbps bandwidth online streaming of 44.1/16 tracks in unreliable. As always, that’s my experience and YMMV…

The moment I click on “clear upcoming” in the queue window, all Internet traffic stops. Roon just plays only the current track which it did cache already. Adding stuff to the queue starts the Internet traffic again. So Roon does cache the entire queue. I am thinking of a workaround, feeding the cache track by track…I guess I can’t.

Again, this is not what I experience and what I see while observing the Roon server activity in real time.

Of course… the current track already is cached, and there are no upcoming tracks.

Of course it will, precaching the next track on the queue to allow for gapless playback. But it won’t download and cache all tracks on the queue. If this were so, you could queue an album and wait for it being completely downloaded and cached. Then playback of the whole album should work, even if you cut your Internet connection. And that is not so.

Hi @Joachim_Strobel,

Thanks for reaching out!

Can you please let me know the exact local time + date + track you experience this behavior with?

Thanks so much for coming back on this. The care is really appreciated.
I made up a playlist of two songs, one 6 min, one 2 min. And Roon would stop caching and hence using up all my tiny 2.1Mb/s about 4 minute into the first stream. I then added a third track and Room would only start caching again once the second track started. So, Roon does only cache one track ahead. I could not test if that behavior is the same for Albums. Meaning that whenever I play an Album Roon will handle caching differently. But after all, as far as I can see, an Album is just a one-click Playlist for Roon.
Now, Volumio for example has a user changeable pre-Cache size that makes sure that the user can use some of the left over bandwidth, where in my case it is a challenge to surf and stream 44/16 using Roon with 2.1mb/s

1 Like

Just a thought…

It might be possible to configure a managed switch to limit the download bandwidth available to Roon. Whether this would be an acceptable compromise I don’t know, but could be worth some research.

You might conclude it’s a whole can of worms you prefer to not open…

Thank, that is good. However, I am on WLAN and have not yet found a setting in my Fritzbox to limit WiFi bandwith. There used to a setting for Guest account bandwith, but is seems to have disappeared in FritzOS 7.2.

Go for Internet => filters
FB 7490

Danke. Auf der 7530 geht das aber leider nicht.

Hello @Joachim_Strobel,

Thanks again for sharing those timestamps, I have activated diagnostics mode for your account and what this action does is automatically upload a log set to our servers.

Our technical team has reviewed the logs and it looks as if the network connection to the HiFiBerry is dropping off.

As a test, can we please ask that you try “System Output” on your Windows 10 PC for a few days and let us know if you have any issues on that zone?

System Output should send the stream to your PCs internal speakers, please give this a try and let us know how it goes, thanks!

Hello Noris,
Yes it is true, the WiFi connection to my Volumio powered Hifiberries drops from time to time and I have to reboot them. I am not sure if Roon causes that. I feel that Volumio via WiFi might be a bit unstable, I had to disable the fallback-Hotspot already as they would not find their original WIFI otherwise.
The 2Mbit stream into Roon runs smoothly and allows 44/16 streaming, but makes simultaneous surfing a bit of a challenge. I have set my Surf-IPad to high priority and my Vaio running Roon as background task in my Fritz rooter, which helps a bit.
I try internal and come back.
I have another place where my Hifiberries are tethered to the same Roon Server via Ethernet and they never drop out (but then I have 50 Mbit/s at that place)

1 Like

Sorry, Noris,
I was a bit slow catching the problem, I grasped it only after seeing other posts on this: Roon causes a Raspi4 running Volumio to crash while on WiFi. The VolumioRaspi simply disappears from the Network and needs a hard reboot to comeback.
I can sort of trigger that by streaming at my full 2Mbit bandwidth via Roon on a WiFi tethered Win10 to Volumio while using other apps on Windows that consume a lot of bandwidth, like complicated websites or an Adobe update. At some point, either Win or Roon (or my Fritzbox) decides to drop the WiFi stream to Volumio, possibly because there is nothing left to stream and that causes Volumio to close the WiFi down. Happens more easily when streaming multi-room to two Raspi4. I am in no mood tracking WiFi packages, but will observe it bit closer. Never happens while on Ethernet.
(I suspect that Volumio is not very forgiving for WiFi timeouts. It has a build in feature to start its own hotspot once it can not find its attached WiFi on startup any more. For me, it did that on every second startup as it does not seem to look for its WiFi very carefully. I had to disable that function, but that just fixes that problem but not the WiFi behavior)

1 Like

Why use Volumio? Have you tried Ropieee it’s made for Roon and works flawlessly over WiFi. I have three endpoints running it and it never drops a beat. There is also RopieeeXL if you want the added features of Airplay, UPnP, squeezelite or HQP NAA.

As of 6 month ago I could not find a Raspi software that would enable HDMI with the Roon bridge except Volumio. I heard that that could be tweaked via the configuration file for most packages, but am in no mood to try that.

You can with dietpi and could set up the webui extension with chromium to get now playing up if that’s what your after.

Ropieee completely disables HDMI audio so that would make it useless for your needs.