Qobuz Albums not added on Android Remote

Core Machine

HP EliteDesk 800 G2 Desktop Mini Business PC, Intel Quad-Core i5-6500T, 16G DDR4,240G SSD,VGA,DP

Network Details

1Gb Ethernet

Audio Devices

USB DACs connected to Roopie Rasp Pi (2X)

Description of Issue

Android Remote 1.8 (Build 790) stable
ROCK 1.8 (Build 790) stable

1.- Either from the Qobuz or from a search, click on the plus (+) button to add the album to the library
2.- You see the button turn to a spinning wheel to indicate is working
3.- Spinning wheel never stops spinning
4.- Album is not added.

This works on Mac OS X Roon - it fails IN ALL THE ANDROID DEVICES I OWN, a Galaxy Note 10 and a Lenovo Tab M10 Plus, 10.3

Have you tried rebooting the Core? (not official support, just a friendly user).

Different symptoms but perhaps same cause

See my recent (and ongoing) issue regarding favs in Qobuz disappearing. I suspect a linked problem

And also reply to @James_Neilson2

Thanks for the suggestions - the Core has been rebooted, just not before I posted, will do again, just in case. That said, I did not think it was relevant because the Mac OS X Roon client connected to the same core works great - only the Android Remote exhibits that behaviour. But will try, same as some of the suggestions in @James_Neilson2 's post.

Thanks - hopefully Roon also has suggestions.


Roon Support
More info: I cleared the app cache - changes. I cleared the whole storage for the app. If you press the plus (+) button to add one album - ANY - it will work, 1 out of 3 times, but after that, no more albums can be added, behaviour repeats.


1 Like

What happens when you add from the Qobuz app/ site direct? Does Roon add it into your library?

For me some are added then disappear, others stay. I think there are issues in Roon “talking” to Qobuz servers.

I wish I could investigate more. But, my Note 10 and 4 other android devices are working fine, not seeing what you are. Rock core.

Thanks - OK, to Roon support:

This works:

  1. Log out of Qobuz
  2. Clear cache and storage
  3. Log in to Qobuz
  4. Sync library now

Then they show up - it only works in that sequence, do it separately or skip a step and it won’t work. Clear only the cache, won’t work; clear only the storage, won’t work; do it without login out of qobuz, it won’t work, etc. Still think is a bug, but at least I have a ( even if annoying ) workaround.


Just a reminder to Roon support - remember that this is not only the album not being added, it is also about the (+) button being stuck as a spinning wheel.

Any news, Roon support?

Hi @vmartell

I see you’re running ROCK on an HP Elite Desk. The HP is an unsupported platform for ROCK, which limits the troubleshooting we can do. When you say it works on your Mac OS X, are you using the Mac as the Core, or just as a remote?

Try setting up the Mac as the Core and see if your Android devices will work with that setup. If you’re still seeing the problem, please take a screenshot with the spinning wheel and share it with us here.

Let us know how it goes - we’re here to help!

Thanks !


  1. Will test as described and post as soon as I test - main thing is the library - is on connected storage and a bit of a pain to get to.

  2. Related question - will keeping the ROCK on the Elite be an issue for support? - if you read the specs, it is identical to an Intel NUC model - I worked out the equivalent before installing to make sure it worked and it did - just can’t remember which one. From what you are saying, moving forward, am I better off putting Ubuntu or Arch on the box and installing your core daemon? Is there a preference? Ubuntu/Arch? Which version?

Unfortunately, yes, keeping the ROCK on the elite may prove to be an issue - we keep most of our supported configurations on hand for testing, and if something unexpected comes up we can’t test or troubleshoot outside of those models. In addition, we’ve made particular arrangements with Intel on their NUC products - Intel doesn’t change some of their basic configurations without letting us know, which means we’re able to produce software that will always be compatible with those configurations. On the other hand, non-NUC products may or may not work. So it’s much more than just power or speed or similar specs.

For us to be able to support your system, it’s a good idea to either switch to the NUC or go with a traditional Core install. Our Linux installation guide says

We have had the strongest positive experiences with Ubuntu 15.10, and up-to-date Arch machines