Qobuz and Windows 10 Defender Firewall

(Jozef Schildermans) #1

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro v.1903 / Intel Celeron J3355 8 GB RAM / Roon build 1.6 (build 416) stable (64)bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Not relevant (see below)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Not relevant (see below)

Description Of Issue

Windows Defender Firewall somehow and sometimes blocks Quboz log-in in Roon. If the firewall is active, roon and all its parts work and you can play local music, but for no apparent reason the Qobuz connection is lost. It is not possible to login.

Solution: disable the Windows firewall completely and it works.

Of cours this not a solution; so which ports needs to be opened to have a stable Qobuz login via Roon? (Qobuz software itself works flawlessly on the same network.)

PS: The three Roon software pieces are allowed to communicate through the firewall (raatserver.exe, roonappliance.exe and RoonServer). But apparently that is not enough for Qobuz.

(Aurel) #2

Celeron is the weak link and also HDD if you do not have SSD.

(Jozef Schildermans) #3

Please read the message, I have no problems regarding playback, even DSD 256 bit plays without hick-ups. The issue is the Qobuz connection, which works fine if the Windows firewall is disabled, but this is bad practice.

(Dylan Caudill) #5

Hi @Jozef_Schildermans — Thanks for reaching out!

Typically we’d expect that having the exceptions in for Roon should be all that is needed, but since you’re still seeing issues even with those exceptions in place, it seems like something else is going on here. The next time this occurs please make a note of the time that you try to login to Qobuz and it fails. Once you’ve provided that timestamp we can enable diagnostics and take a closer look at things.

(Jozef Schildermans) #6

Okay, Dylan, I’ll do.

1 Like