Qobuz broke and will not function

Roon Core Machine

Nucleus +

Networking Gear & Setup Details

Bryston streamer x finitely Wi-Fi both Wi-Fi and wired direct

Connected Audio Devices

Roon is my primary music source

Number of Tracks in Library


Description of Issue

Qobuz will not work. When I try to play it just flashes on the play icon

Sometimes Roon and Qobuz get their authorizations out of synch. What I have seen others try with some success is to log out of Qobuz in Roon, then log out of the Roon Core itself, reboot Roon, log back into Roon, then log back into Qobuz from within Roon.

If you are on Comcast (I believe you meant to type Xfinity), there have been some issues with Comcast’s Xfinity security service being overly aggressive with Roon. This thread, starting at Post #42, explains how to turn off some of the security features that were blocking Roon:

1 Like

Please come on now… This is the third thread you’ve opened today about the same problem. By posting ever more threads things will certainly not be attended to any faster. During weekends Roon support is not working, so you’ll have to show a little patience and wait until Monday.

1 Like

service asked me to create a topic and I did. Qobuz is still not working

Monday it is

If this is the same issue as the one mentioned by @Robert_F , try turning off ‘advanced security’ for your Nucleus using the following as a guide:

1 Like


I have closed yet another of your threads on this subject, lets just keep this one open then.
I hope to not see another one.:+1:
Thank you for your patience and understanding.

That doesn’t mean @support will get to your case Monday. There are a lot of people having a lot of issues right now, many related to Build 952.

I going to assume you have done the basics here.
Full reboot of the Core server.
Log out of Qobuz inside Roon first.
Then reboot the Core.
Then log back into Qobuz making sure you use your correct email address and not a username.

Thank you for the Xfinity info, but I have had this modem for almost 2 years.

This seemed to work, but only for about 5 minutes

You might still try and adjust the security settings for Roon Core on your XFinity router. Qobuz might have made recent changes on their end. It’s your best bet.

You could try the reboot that @AceRimmer suggested, but reboot the the router as well (rebooting the router before anything else).

1 Like

The OP in the other thread I mentioned had been using Roon for 8 months without any problems. I suspect, in his case, that the security settings that are applied by the Xfinity had changed. It may be the same for you, so probably worth checking.

1 Like

Hi @Steve_Child ,

Thanks for reaching out. I enabled diagnostics for your Nucleus unit and it looks like you were able to play Qobuz content earlier today, is everything working as expected? Did you locate the source of the issue?

no, I have no idea why Qobuz would not work. The Qobuz “off line” lasted about 4 days, but it seems to work now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.